Post by sansou » Wed Jul 17, 2019 10:37 pm

Dears, I got SyntaxError:Unexpected token : < in JSON at position 0
OK
<!DOCTYPE html>
....
<title>Permission Denied!</title>
when I clicked Edit Order, I use 3.0.2, any idea please? thanks!
no server log or OC admin log related to that

Newbie

Posts

Joined
Fri Feb 17, 2017 11:00 pm

Post by paulfeakins » Thu Jul 18, 2019 5:49 pm

sansou wrote:
Wed Jul 17, 2019 10:37 pm
<title>Permission Denied!</title>
Are you using an htaccess password to protect the whole site?

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by sansou » Sat Jul 20, 2019 4:43 pm

paulfeakins wrote:
Thu Jul 18, 2019 5:49 pm
sansou wrote:
Wed Jul 17, 2019 10:37 pm
<title>Permission Denied!</title>
Are you using an htaccess password to protect the whole site?
My htaccess1 file is .htaccess1 , and I use web.config for URL rewrite; also I use IP2LOCATION-LITE extension to block China IP visiting. any problem with them please?

Newbie

Posts

Joined
Fri Feb 17, 2017 11:00 pm

Post by sansou » Sat Jul 20, 2019 5:05 pm

paulfeakins wrote:
Thu Jul 18, 2019 5:49 pm
sansou wrote:
Wed Jul 17, 2019 10:37 pm
<title>Permission Denied!</title>
Are you using an htaccess password to protect the whole site?
Chrome console:
2/404.php:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
jquery-2.1.1.min.js:4 GET https://ch-power.com/404.php 500 (Internal Server Error)
send @ jquery-2.1.1.min.js:4
ajax @ jquery-2.1.1.min.js:4
(anonymous) @ https://ch-power.com/xxxxxxxx/index.php ... rder_id=18
dispatch @ jquery-2.1.1.min.js:3
r.handle @ jquery-2.1.1.min.js:3

Newbie

Posts

Joined
Fri Feb 17, 2017 11:00 pm

Post by paulfeakins » Sun Jul 21, 2019 5:36 pm

I think the problem is some AJAX is trying to access a URL that is password protected.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by sansou » Sat Aug 10, 2019 6:38 pm

paulfeakins wrote:
Sun Jul 21, 2019 5:36 pm
I think the problem is some AJAX is trying to access a URL that is password protected.
thanks! my site has no URL needs password, seems have to check with programmer

Newbie

Posts

Joined
Fri Feb 17, 2017 11:00 pm

Post by paulfeakins » Mon Aug 12, 2019 5:46 pm

sansou wrote:
Sat Aug 10, 2019 6:38 pm
thanks! my site has no URL needs password, seems have to check with programmer
You could ask in Commercial Support or we could have a look: info@antropy.co.uk

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by letxobnav » Mon Aug 12, 2019 6:21 pm

it is your 404.php page which produces a 500 error.
so open your web developer tools and first see why it is going to your 404.php page in the first place.
After solving that you can see why your 404.php produces a 500 error.

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


Active Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by lilpantherpaw » Sat Sep 14, 2019 9:54 am

I am not sure if this is the correct thread, so please forgive me if it is not. Suddenly, after a module support technician fixed an age verification issue on my OC site, my <Sales> section disappeared and I get the following error: "Permission Denied! You do not have permission to access this page, please refer to your system administrator." I checked all boxes for access for my top tier user group, it made no difference. <Sales> seems to be the only section affected. The module developers say it has nothing to do with their work on their module on my site. I have contacted OC on ZenDesk twice over the past 3 weeks with no response. I do not see any online resolves to this specific issue. I have attached screenshots so you can see my issue.

Attachments

OC Sales-No Permission.jpg

OC Sales-No Permission.jpg (105.24 KiB) Viewed 171 times

OC Missing Sales.jpg

OC Missing Sales.jpg (155.68 KiB) Viewed 171 times


User avatar
Newbie

Posts

Joined
Sun Jan 29, 2012 4:17 am

Post by paulfeakins » Mon Sep 16, 2019 5:14 pm

lilpantherpaw wrote:
Sat Sep 14, 2019 9:54 am
I am not sure if this is the correct thread, so please forgive me if it is not.
I think start a new topic.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom
Who is online

Users browsing this forum: Rob Pickers and 32 guests