Post by csadmin » Wed May 15, 2019 10:01 pm

OpenCart 2.3.0.2 - Theme: Yooblue for 2.3.0.2

Hello all,

Been trying this for the last 2 days now:

- Add product to cart
- Go to checkout
- All works except when I get to payment part
- Can select payment method (cash on delivery, cheque or bank transfer)

Then when I click next it doesn't do anything

Have no other payment extensions (for now)

Doesn't log anything either, downloaded server log from the hosting but nothing there :(

Anyone that could point me in the right direction?

Thanks in advance,
Greetings from Spain
Last edited by csadmin on Thu May 16, 2019 11:47 pm, edited 1 time in total.

Newbie

Posts

Joined
Wed May 15, 2019 8:55 pm

Post by OSWorX » Wed May 15, 2019 11:13 pm

General, your first Address should be the developer of the Theme.
Second, without any URL nobody can try your shop.

p.s.: i moved this posting to the correct forum.

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member
Online

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by csadmin » Thu May 16, 2019 4:35 am

Oops, sorry, new here, here it is:

https://www.chaletshop.nl

Will try and contact the theme developer

Thanks

Newbie

Posts

Joined
Wed May 15, 2019 8:55 pm

Post by OSWorX » Thu May 16, 2019 5:30 am

When I try to checkout after selecting a payment and click Verder, I get an error:

Code: Select all

ajax is not defined
Have you changed/edited a template or any other file?
Could you try it once with the default template (just to be sure that it is the template).

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member
Online

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by csadmin » Thu May 16, 2019 4:59 pm

Have switched it to the default theme and same thing, left it like that to see if that helps, maenwhile I'll start a search on the ajax thing

Thanks so far ;-)

Newbie

Posts

Joined
Wed May 15, 2019 8:55 pm

Post by OSWorX » Thu May 16, 2019 8:37 pm

csadmin wrote:
Thu May 16, 2019 4:59 pm
Have switched it to the default theme and same thing, left it like that to see if that helps, maenwhile I'll start a search on the ajax thing

Thanks so far ;-)
I can see the same error also with the default template.
When I check the source code, I can see that (and this is the reason for the error):

Code: Select all

$(document).delegate('#button-payment-method', 'click', function() {
    ajax({
That should be:

Code: Select all

$(document).delegate('#button-payment-method', 'click', function() {
    $.ajax({
The $ is missing.

Have you edited the template payment_method?
Or have any additional extension installed which manipulates this template?

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member
Online

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by csadmin » Thu May 16, 2019 11:39 pm

Well....

Great work! It now all functions.

What I did to resolve it? Nothing, just re-uploaded the checkout template and now it works
Checked it locally and the $. was there, so thougth, let's give it ago and upload it again and now it works.

Thank you very much for the help!!

Greetings from Spain

Newbie

Posts

Joined
Wed May 15, 2019 8:55 pm
Who is online

Users browsing this forum: No registered users and 10 guests