Post by eire » Sun Mar 17, 2019 1:34 am

Hi,
My current website is on version 1.5.5.1 and I am trying to migrate to 2.3.0.2 so I recently setup a dev sub-folder and installed OC there.

When I go to login to the admin area, I get the following error:
Warning: htmlspecialchars(): charset `UTF-8;' not supported, assuming utf-8 in /public_html/dev/system/library/cart/user.php on line 39Warning: Cannot modify header information - headers already sent by (output started at /public_html/dev/admin/controller/startup/error.php:34) in /public_html/dev/system/library/response.php on line 12.

I have not installed any extensions or theme.

Note: When I created the DB, it defaulted to the swedish default but I have since updated it to utf8_general_ci

As suggested in another forum post, I amended the php.ini and admin/php.ini files. I removed the semicolon from the end of each line but it did not resolve the issue.

If anyone has any suggestions as to how I can resolve this, it would be much appreciated.

Thanks,
Philip

New member

Posts

Joined
Sat Sep 22, 2012 5:04 am

Post by ADD Creative » Sun Mar 17, 2019 2:12 am

In the php.ini and admin/php.ini files. You need remove the semicolon from the end of each line.

So

Code: Select all

default_charset	= UTF-8;
To

Code: Select all

default_charset	= UTF-8
If you are using cPanel with EasyApache 4 or similar. You may also need to login to your cPanel and go to Software -> MultiPHP INI Editor -> Editor Mode and make the same change there for your domain.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by eire » Sun Mar 17, 2019 3:19 am

Hi ADD Creative,
Thank you so much, that resolved the issue. It was the multiPHP ini editor as I had already edited the other two .ini files.

Thanks,
Philip

New member

Posts

Joined
Sat Sep 22, 2012 5:04 am
Who is online

Users browsing this forum: No registered users and 6 guests