Post by vinceooi » Sat Nov 10, 2018 3:57 pm

Hi All, Please help,

not sure since when i am unable to edit/view the product description for new or even existing product.

how to fix this

Attachments

error.JPG

error.JPG (86.81 KiB) Viewed 199 times

Last edited by vinceooi on Mon Nov 12, 2018 8:56 am, edited 1 time in total.

New member

Posts

Joined
Sun Mar 30, 2014 11:54 pm

Post by straightlight » Sat Nov 10, 2018 7:30 pm

Posted screenshot not relevant to an error. More information needed. Forum rules.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by vinceooi » Sat Nov 10, 2018 7:47 pm

can anyone help please?

New member

Posts

Joined
Sun Mar 30, 2014 11:54 pm

Post by straightlight » Sat Nov 10, 2018 7:55 pm

Yes, by following the forum rules. Your first post does not provide enough info for anyone to assist you right now.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by vinceooi » Sun Nov 11, 2018 8:59 am

Sorry, my bad, when i try to edit or create a new product, the description text box doesnt appear ( please refer to the screenshot)
there is no error msg :(

New member

Posts

Joined
Sun Mar 30, 2014 11:54 pm

Post by IP_CAM » Sun Nov 11, 2018 12:39 pm

Well, I would honestly advise you, to move up to the latest v.1.5.6.5_rc Version,
since a lot of Bugs and Misses have been found and fixed since 1.5.6.1.
And then check again, if your problem still exists, or come back here again.

You could over-write all of your existing OC Soure, with the exeption of the both
config.php Files, since no new installation is required for such. And your
existing Extensions/VqMods should work as before. You only have to re-initialize
the VqMod Function be linking http:// yoursite /vqmod/install/index.php
Good Luck! ;)
Ernie
OC v.1.5.6.5_rc: ( latest official Release Candidate )
https://github.com/IP-CAM/Opencart-1.5.6.5_rc
---
OC v.1.5.6.4:
https://www.opencart.com/index.php?rout ... load_id=36

Code: Select all

# OpenCart change log
## v1.5.6.5 (Pending)
#### Bugs fixed
* Updated SQL in admin/model/sale/order.php to fix date_modified filter. Fixes #1371
* Change settitle to setTitle in error/not_found.php
* Fixed issue in Amazon Payments where tax lines where passed as products if cart had different tax rates.
* Fixed the implementation of captchas.
* Incorrect file type when uploading on Windows Machines REF: #1550
* Corrected 404 response headers REF: #1620
* Trigger JS change on page load to ensure that option choices are hidden/shown when editing an option.
* Fixed hyphen problem with PayPal Express checkout url
* Changed PayPal cardissue to issuenumber variabe for PayPal Pro
* Used correct admin setting to check if product count should be done on a category REF: #1828
* Changed response message to hide sensitive DB connection data on failure. REF: 3fff5226d9c48f8f4c948bc2c27a5c91f8dba1a2
* Fixed category count to be called only when count is turned on
* Added formatting to number format in pp express to ensure no comma is added for items over 1000 #2216

#### Changes
* Removed duplicate DELETE SQL query for product attributes REF: #1379
* Small coding standard improvement (spacing on if and else if statements) in Amazon Payments FE template
* Updated link to download location for Amazon Payments adjustment file as it was removed from the source.
* Added missing semi-colon to echo statements in Amazon Checkout REF: #1565
* Removed old subversion file read from admin/controller/footer - redundant code.
* Added speed improvement for the product count check in the category module if it is disabled. Part of the totals calculation were still being done.

#### Added
* Authorize.net solution ID to payment gateway

## v1.5.6.4 (23rd April 2014)
#### Bugs fixed
* Fixed issue with images containing the <? (used in xml etc) string in the source and not uploading. Now only checks long php tag [**view**](https://github.com/opencart/opencart/commit/b04cbbcc40308c47e2d77460358b6450e9ee0e5b)
* Fixed language string for "error_file_type" in admin filemanger/upload method [**view**](https://github.com/opencart/opencart/commit/b04cbbcc40308c47e2d77460358b6450e9ee0e5b)
* Fixed upgrade issues caused by PHP consider 0 equal to null [**view**](https://github.com/opencart/opencart/commit/d6d5473e4d69e9f9f0679e3445899a3bc37a86f1)
* Updated SQL query in getTotalEmailsByProductsOrdered and getEmailsByProductsOrdered to use the limits in the correct method [**view**](https://github.com/opencart/opencart/commit/c5feafce559c81a44ab11315365750ed9b4a0cb1)

#### Changes
* Updated SQL mode in install SQL file and MySQLi adapter to accommodate servers that have strict mode enabled by default [**view**](https://github.com/opencart/opencart/commit/70298dd3c21430935659745436fe1f8709483718)
* Removed Amazon payments xls file from system folder as it can be downloaded online and has no place in the code framework [**view**](https://github.com/opencart/opencart/commit/70298dd3c21430935659745436fe1f8709483718)
* Improved currency update method to include curl timeouts, to handle occasional timeout issues [**view**](https://github.com/opencart/opencart/commit/bda066fdbde486107337ca1069bcba0dabecc67f)

#### Added
* Nothing

## v1.5.6.3 (15th April 2014)
#### Bugs fixed
* Image manager issue where the thumbnails failed to load [**view**](https://github.com/opencart/opencart/commit/b84978b5ca6683d4c62951256ef25f68a685ce92)
* PayPal Express totals calculation, fixed incorrect variable names [**view**](https://github.com/opencart/opencart/commit/78c4e9ac0f8fe51c69a1ddc1fb443dae2a5934f7)
* Fixed report for coupons to search the history table instead for start/end filters [**view**](https://github.com/opencart/opencart/commit/580ed0482f804a37e13fcab5363a38a76ce4feb9)

#### Changes
* Allow arrays to be written to the log file [**view**](https://github.com/opencart/opencart/commit/1e430128cd055498666fd5a2be2267b933a4b2c8)
* Check uploaded files for php content, reduce the risk of image files containing php and running on insecure servers [**view**](https://github.com/opencart/opencart/commit/c11ef46681b2c2d87b6c3fd7b1394f53b6b72e45)

#### Added
* Nothing

## v1.5.6.2 (10th April 2014)
#### Bugs fixed
- **PayPal Express Checkout** Added error handling if no shipping options for weight based shipping are found [**view**](https://github.com/opencart/opencart/commit/201004c7dcbec43d17477a099fc8522f56537c00)
- **PayPal Express Checkout** Fixed message when cart totals do not match order amounts [**view**](https://github.com/opencart/opencart/commit/1bf9db4306223760ba00a1a6bd8524cb1f96128b)
- **PayPal Express Checkout** Fixed state issue, changed variable from PAYMENTREQUEST_0_SHIPTOCOUNTRYCODE to PAYMENTREQUEST_0_SHIPTOSTATE [**view**](https://github.com/opencart/opencart/commit/ff2705e21aa3062db53a4a39e5651d231af20e9c)
- **PayPal Express Checkout** Added fix for to allow for download only items and PayPal guest checkout. Guest checkout with no shipping option will not return any address data for the checkout so exceptions for no payment address data have been handled [**view**](https://github.com/opencart/opencart/commit/0a94a4073743cced97e0944d702425c7c57cf866)
- Fix for from and mail-to mail headers [**view**](https://github.com/opencart/opencart/commit/03bc37b4303bc3a9e9b6d9d34d604f0126aa61d1)

#### Changes
* **Klarna Account** gateway minimum amount update [**view 1**](https://github.com/opencart/opencart/commit/0c579e27168db635e43a0d9d2562c4bb5b26f464) [**view 2**](https://github.com/opencart/opencart/commit/d4ee47aedd456828c656075da6aecc345365d4ff)
* **PayPal Express Checkout** wrapped logging calls with if statements to check if debug is enabled in the settings [**view**](https://github.com/opencart/opencart/commit/765ea85956ca1d50aea5c8108c7c39a6dd4ad765)
* **PayPal Express Checkout** Updated SQL check for zone information to include code and title, covers differences between data response for different country formats [**view**](https://github.com/opencart/opencart/commit/395d4cc04c26b12dfa9a427142a9890876ceecf7)
* Cookies changed to HttpOnly [**view**](https://github.com/opencart/opencart/commit/53c376abb238a5d0bb14aa5e1a39f0601a4c6b9f)
* Changed UTF8 helper functions to new code [**view**](https://github.com/opencart/opencart/commit/d55aa27958895ed4f3141d4cffc94c7589aae48c)
* Updated OpenBay Pro to latest v2334 [**view**](https://github.com/opencart/opencart/pull/1327)

#### Added
* New checks during install to check for iconv function or mbstring extension as used by UTF8 helper [**view**](https://github.com/opencart/opencart/commit/8f4a58899e5ca0316b3e3be49a1171ccf3b0db26)

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by OSWorX » Sun Nov 11, 2018 2:43 pm

vinceooi wrote:
Sun Nov 11, 2018 8:59 am
Sorry, my bad, when i try to edit or create a new product, the description text box doesnt appear ( please refer to the screenshot)
there is no error msg :(
To keep it short (others will post nonsens and endless ..): it seems to me that the script for the editor is not loaded.
Have you ever checked the output with the developer tools in your browser - hit F12 ?
And which Browser are you using?

Forum Rules: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by villagedefrance » Sun Nov 11, 2018 3:43 pm

I agree with OSWorX, it looks like your CKEditor script is not loaded, or the Token is missing (CKEditor needs the Token to work).

Most likely the problem will be in your "product_form.tpl", at the bottom.
It is also worth checking that CKEditor files are actually present in your "javascript" folder.

Out of Interest: Does CKEditor loads correctly for description on other pages? like "Category" or "Information"?

OpenCart custom solutions @ https://villagedefrance.net


User avatar
Active Member

Posts

Joined
Wed Oct 13, 2010 10:35 pm
Location - UK

Post by vinceooi » Mon Nov 12, 2018 8:40 am

Hi both, thank you for your reply. but i am not expert. how to check whether is it loading or not ?

i have tested in different PC, it still the same

New member

Posts

Joined
Sun Mar 30, 2014 11:54 pm

Post by vinceooi » Mon Nov 12, 2018 8:51 am

This is my product form.tpl , not sure why unable to attach the .tpl

New member

Posts

Joined
Sun Mar 30, 2014 11:54 pm

Post by vinceooi » Mon Nov 12, 2018 9:04 am

you are right, Category and Information also having the same issue with the "Description" area, not loaded
villagedefrance wrote:
Sun Nov 11, 2018 3:43 pm
I agree with OSWorX, it looks like your CKEditor script is not loaded, or the Token is missing (CKEditor needs the Token to work).

Most likely the problem will be in your "product_form.tpl", at the bottom.
It is also worth checking that CKEditor files are actually present in your "javascript" folder.

Out of Interest: Does CKEditor loads correctly for description on other pages? like "Category" or "Information"?

New member

Posts

Joined
Sun Mar 30, 2014 11:54 pm

Post by OSWorX » Mon Nov 12, 2018 4:01 pm

As written, check and if not loaded, load the required Library for CKEditor and it will work.
Is this installation Original or Modified?
Did the editor ever work?

If you are not able to fix that, either post a request in the commercial section in this forum or hire a developer somewhere.

Forum Rules: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by vinceooi » Mon Nov 12, 2018 8:23 pm

Hi OSWorx, this is original OC 1.5.6.1 with a theme for frontstore.

should be no modification to the product form.tpl and it just sudden not working few days ago.

How do i check whether the CKEditor is loaded or not ? where to check? please advice.

and i can share my product form.tpl. but it doesnt allow to attached to this post.
OSWorX wrote:
Mon Nov 12, 2018 4:01 pm
As written, check and if not loaded, load the required Library for CKEditor and it will work.
Is this installation Original or Modified?
Did the editor ever work?

If you are not able to fix that, either post a request in the commercial section in this forum or hire a developer somewhere.

New member

Posts

Joined
Sun Mar 30, 2014 11:54 pm
Who is online

Users browsing this forum: No registered users and 22 guests