Post by leeburgess » Sat Oct 13, 2018 1:38 am

OC 3.0.2.0
Default theme

I have enabled password protect in admin folder by adding a .htaccess file.
AuthName "Admin Area"
AuthUserFile "/home/xxxxxx/.htpasswds/public_html/admin/passwd"
AuthType Basic
require valid-user

But when I goto admin URL it says page cannot be found.

How do I resolve please?

New member

Posts

Joined
Sat Sep 16, 2017 3:19 am

Post by EvolveWebHosting » Sat Oct 13, 2018 4:42 am

leeburgess wrote:
Sat Oct 13, 2018 1:38 am
OC 3.0.2.0
Default theme

I have enabled password protect in admin folder by adding a .htaccess file.
AuthName "Admin Area"
AuthUserFile "/home/xxxxxx/.htpasswds/public_html/admin/passwd"
AuthType Basic
require valid-user

But when I goto admin URL it says page cannot be found.

How do I resolve please?
There is a .htaccess file included with Opencart (named .htaccess.txt to begin with) that you can add this code to.

The 'AuthName' you entered needs to be the folder name on your server (admin by default) and it's case sensitive.

Image
https://www.evolvewebhost.com
Free 30 day Shared Web Hosting Trial
$10.49 .com Registration and $9.99 .com Transfers in now - Experience a higher level of support and reliability
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by leeburgess » Sat Oct 13, 2018 4:42 pm

Still the same just does a page cannot be found. Is it because I bave redirect on .htaccess in main folder? If so how can I resolve the admin issue?

New member

Posts

Joined
Sat Sep 16, 2017 3:19 am

Post by EvolveWebHosting » Sat Oct 13, 2018 11:34 pm

leeburgess wrote:
Sat Oct 13, 2018 4:42 pm
Still the same just does a page cannot be found. Is it because I bave redirect on .htaccess in main folder? If so how can I resolve the admin issue?
It's hard to say for sure when I'm unable to see your setup but this article should help or even your hosting company support team should be able to help you:
https://documentation.cpanel.net/displa ... ry+Privacy

Image
https://www.evolvewebhost.com
Free 30 day Shared Web Hosting Trial
$10.49 .com Registration and $9.99 .com Transfers in now - Experience a higher level of support and reliability
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by leeburgess » Sat Oct 13, 2018 11:43 pm

That's the guide I followed but once I do that the admin folder is not accessible as it shows page cannot be found.

New member

Posts

Joined
Sat Sep 16, 2017 3:19 am

Post by EvolveWebHosting » Sun Oct 14, 2018 8:11 am

leeburgess wrote:
Sat Oct 13, 2018 11:43 pm
That's the guide I followed but once I do that the admin folder is not accessible as it shows page cannot be found.
I think your quickest way to resolve it is to contact your hosting provider. Unfortunately, we aren't hosting your site, otherwise we could have had a look at it for you and resolved it already. If you're interested in signing up with us, we can certainly get things setup properly for you.

Image
https://www.evolvewebhost.com
Free 30 day Shared Web Hosting Trial
$10.49 .com Registration and $9.99 .com Transfers in now - Experience a higher level of support and reliability
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by IP_CAM » Sun Oct 14, 2018 10:26 am


For Sale: Top URL's, including OpenCart V-Pro installed, like seen here:
http://www.bigmax.ch - http://www.ipcam.li - http://www.opencart.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by leeburgess » Sun Oct 14, 2018 4:39 pm

I have done that but then cannot access admin panel at all. Could it be something to do with .htaccess in main directory?

New member

Posts

Joined
Sat Sep 16, 2017 3:19 am

Post by leeburgess » Sun Oct 14, 2018 6:44 pm

For anyone with the same issue you have to add
ErrorDocument 401 "Unauthorized"
To .htaccess in main opencart root.

New member

Posts

Joined
Sat Sep 16, 2017 3:19 am
Who is online

Users browsing this forum: No registered users and 17 guests