Post by Lavingstar » Sat Aug 11, 2018 12:57 am

Hallo zusammen,

Mijoshop 4.0.5 ist installiert mit Opencart Version 3.0.2.0 in einer Joomla Webseite 3.8.11.

Das Problem ist beim reinlegen von Artikeln in den Warenkorb, dass der Button oben anzeigt "Lädt... aktualisiert" - aber dann trotzdem nicht der hineingelegte Artikel angezeigt wird. Wenn man auf den Button klickt, sieht man allerdings, dass die Artikel im Warenkorb sind.
Und wenn man auf eine andere Seite klickt und die Seite neu lädt, wird auch der Button richtig aktualisiert - aber eben nicht in "Echtzeit", siehe Screenshot.
Das ist mit FF, Chrome und IE (bzw. Edge) überall gleich, egal ob eingeloggt oder als Gast. Auch ein löschen von Cache Dateien hat nicht geholfen.

Kann hier jemand weiterhelfen und einen Hinweis geben, woran das liegen könnte?

Attachments

Screenshot_4.png

Warenkorb zeigt 0,00€ obwohl gefüllt. - Screenshot_4.png (16.58 KiB) Viewed 573 times


Newbie

Posts

Joined
Thu Jun 21, 2018 2:02 am

Post by OSWorX » Sat Aug 11, 2018 8:51 pm

Lavingstar wrote:
Sat Aug 11, 2018 12:57 am
Hallo zusammen,

Mijoshop 4.0.5 ist installiert mit Opencart Version 3.0.2.0 in einer Joomla Webseite 3.8.11.

Kann hier jemand weiterhelfen und einen Hinweis geben, woran das liegen könnte?
Hallo,

weder noch (gilt auch für die andere Meldung), da hier ein indivuell angepasstes System( MijoShop = Joomla & OpenCart) verwendet wird.
Daher gilt: sich an den Hersteller von Mijoshop - Miwisoft - wenden welche diese Zusammenstellung anbieten (und auch dementsprechend anpassen damit es halbwegs funktioniert).

Hier geht es nur um OpenCart.

p.s.: es bringt garnichts doppelt um Hilfe zu fragen (Frage hier und nochmals das Gleiche auf Englisch)!

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by Lavingstar » Sun Aug 12, 2018 5:34 am

OSWorX wrote:
Sat Aug 11, 2018 8:51 pm
Hier geht es nur um OpenCart.
Und dieser Button - insbesondere die Funktionalität - gehört doch zu Opencart.
Er gehört weder zu Joomla, noch zum Mijoshop.

Newbie

Posts

Joined
Thu Jun 21, 2018 2:02 am

Post by OSWorX » Sun Aug 12, 2018 7:11 pm

Lavingstar wrote:
Sun Aug 12, 2018 5:34 am
OSWorX wrote:
Sat Aug 11, 2018 8:51 pm
Hier geht es nur um OpenCart.
Und dieser Button - insbesondere die Funktionalität - gehört doch zu Opencart.
Er gehört weder zu Joomla, noch zum Mijoshop.
Nochmals: die verwendete Lösung implementiert OpenCart in Joomla.
Dafür wird OpenCart als Joomlakomponente umgeschrieben.
Heisst, auch wenn dieser Button eigentlich zu OpenCart gehört, er - bzw. die Funktionalität - wird durch die Anpassung geändert.
Siehe:

Code: Select all

index.php?option=com_mijoshop&route=checkout/cart/add&format=raw&tmpl=component
Und somit ist dann hier wieder dieses Forum die falsche Adresse, denn:
Mijoshop ist nichts anderes als Joomla plus ein angepasstes OpenCart.

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by Lavingstar » Sun Aug 12, 2018 8:19 pm

Ok, das ist verstanden. Aber mal losgelöst von Zugehörigkeiten:

Wenn das Problem theoretisch bei einer reinen OpenCart Installation auftreten würde (ohne Joomla und Mijoshop):
In welchen Dateien würde ich dann am besten suchen und rumprobieren, um möglicherweise eine Lösung zu finden?

Vielleicht hilft mir dieser Ansatz ja schon weiter, dass ich etwas mehr herausfinden kann...

Newbie

Posts

Joined
Thu Jun 21, 2018 2:02 am

Post by OSWorX » Sun Aug 12, 2018 9:51 pm

Lavingstar wrote:
Sun Aug 12, 2018 8:19 pm
Ok, das ist verstanden. Aber mal losgelöst von Zugehörigkeiten:

Wenn das Problem theoretisch bei einer reinen OpenCart Installation auftreten würde (ohne Joomla und Mijoshop):
In welchen Dateien würde ich dann am besten suchen und rumprobieren, um möglicherweise eine Lösung zu finden?

Vielleicht hilft mir dieser Ansatz ja schon weiter, dass ich etwas mehr herausfinden kann...
1. nicht die Frage von 'Zugehörigkeiten'
2. am besten mal nur OpenCart installieren und sehen ob das Problem dann auch auftaucht (was es nicht wird)
3. common.js

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria
Who is online

Users browsing this forum: No registered users and 5 guests