Post by SetiaBudi » Sun Jul 01, 2018 8:45 am

I am using opencart version 1.6.8 for my apparel e-commerce website.

1) Do I need to update to newest version of opencart?

2) If I update to a higher version of opencart, will there is any pages that is not working properly? Or is there an error that appears?

3) Will all url pages remain as they are today? Because for all url pages I have optimized its to be seo-friendly.

4) And what about the database? Would there is any conflicts?

Any advice or comment will be very appreciated. Thank you very much.

Newbie

Posts

Joined
Thu Nov 30, 2017 4:59 pm

Post by IP_CAM » Sun Jul 01, 2018 9:08 am

1) I am using opencart version 1.6.8 for my apparel e-commerce website. Do I need to update to newest version of opencart?
Well, that would be an older Version from Villagedefrance, since there was no 1.5.6.8 OC-Release.
https://villagedefrance.net/downloads
---
2) If I update to a higher version of opencart, will there is any pages that is not working properly? Or is there an error that appears?
Your OC cannot be updated, by eventually exchanging a few files only in an existing Version.
A completely new installation has to be made, and new extensions have to be bought,
if one used custom Themes and/or Extensions before, and still needs similar functions
in a new install.
---
3) Will all url pages remain as they are today? Because for all url pages I have optimized its to be seo-friendly.
Nothing will remain, since it will be a brandnew installation. But SEO-Links, stored in a Database, might
also be exported and then re-imported into a new DB.
---
4) And what about the database? Would there is any conflicts?
An existing 1.5.x database will no longer function, due to many changes and
additions, beeing part of a new Version. Only some content out of an existing
database might be exported and later re-imported, in a MODIFIED way, to
match the new Version DB Archidecture, and the new OC way of doing things.
---
Like it or not, but one cannot expect old Auto Tire Sizes and Parts, to still match
an new Car, it's as easy as that. :D
Good Luck ! ;)
Ernie
Last edited by IP_CAM on Wed Jul 04, 2018 10:51 am, edited 1 time in total.

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by SetiaBudi » Mon Jul 02, 2018 7:05 am

IP_CAM wrote:
Sun Jul 01, 2018 9:08 am
1) I am using opencart version 1.6.8 for my apparel e-commerce website. Do I need to update to newest version of opencart?
Well, that would be an older Version from Villagedefrance, since there was no 1.5.6.8 OC-Release.
https://villagedefrance.net/downloads
---
2) If I update to a higher version of opencart, will there is any pages that is not working properly? Or is there an error that appears?
Your OC cannot be updated, by eventually exchanging a few files only in an existing Version.
A completely new installation has to be made, and new extensions have to be bought,
if one used custom Themes and/or Extensions before, and still needs similar functions
in a new install.
---
3) Will all url pages remain as they are today? Because for all url pages I have optimized its to be seo-friendly.
Nothing will remain, since it will be a brandnew installation. But SEO-Links, stored in a Database, might
also be exported and then re-imported into a new DB.
---
4) And what about the database? Would there is any conflicts?
An existing 1.5.x database will no longer function, due to many changes and
additions, beeing part of a new Version. Only some content out of an existing
database might be exported and later re-imported, in a MODIFIED way, to
match the new Version DB Archidecture, and the new OC way of doing things.
---
Like it or not, but one cannot expect old Auto Tire Sizes and Parts, to still match
an new Car, it's as easy as that. :D
Good Luck ! ;)
Ernie
Thank you for the explanation. I truly appreciate it.

My bad, I were wrong about my version, it was 1.5.6.4.

What I am afraid is the security of my old opencart 1.5.6.4 can be compromised too easily. In the other hand, for updating my old opencart to newest opencart will require too many time. I also need to configure many of my setting, recheck all the plugins work or not. I understand a bit about programming in PHP.

1) I am about buying two plugins in short time, one for mobile friendly and one for shipping / delivery. Do you think before buying those new plugins, I should update my 1.5.6.4 opencart, or just read the web about 1.5.6.4 security holes, and tried to fix it?

2) Then, for security purpose so my web can not be hacked so easily, which one is the best deal, update my opencart to newest version, or still maintain this old 1.5.6.4 version but try to fix some security hole if I found it?

I have done the standard hardening, like htaccess, file permission, right setting, and so on.

3) Is there any patch or something like that to fill security holes of old version?

4) If someday, my website got hacked, what is the best way to fill the security holes of old version?

5) If I prefer maintain my old 1.5.6.4 opencart, what is the best security tips for this purpose?

Once again, thank you.

Best regards,
Setia Budi.

Newbie

Posts

Joined
Thu Nov 30, 2017 4:59 pm

Post by IP_CAM » Mon Jul 02, 2018 9:15 am

What I am afraid is the security of my old opencart 1.5.6.4 can be compromised too easily. In the other hand, for updating my old opencart to newest opencart will require too many time. I also need to configure many of my setting, recheck all the plugins work or not. I understand a bit about programming in PHP.
Well, if you understand a little about programming, just download the latest 1.5.6.5_rc,
it contains all Fixes, still found in v.1.5.6.4. It's only a Release Candidate, and so hidden
from the official OC List, but also the best 1.5.x Version ever made. About 25 Files have
been changed/fixed/updated, compared with v.1.5.6.4, to get a Version, which so far has
not been mentioned in any security-related Topics anywhere. ;)
https://github.com/opencart/opencart/tr ... 306fb75707
---
I am about buying two plugins in short time, one for mobile friendly and one for shipping / delivery. Do you think before buying those new plugins, I should update my 1.5.6.4 opencart, or just read the web about 1.5.6.4 security holes, and tried to fix it?
Well, you don't really have to buy a Theme, to make 1.5.6.x mobile friendly, there are at least
40 nice free + usable Themes available, as well as some Extensions, to make such work, without
changing something 'default' in an existing 1.5.6.4+1.5.6.5_rc Version. Some are fully Bootstrap-3
type Themes, like the fantastic:
OC Bootstrap - Opencart Bootstrap 3 Theme (not default OC-2 style/class compatible!)
https://www.opencart.com/index.php?rout ... n_id=14631
But some free Theme Extensions should be handled with Care, or better, not be touched, because
they partly change existing default things, to an extend, that no other Theme will function anymore,
without fully remove/replace their Code, even DB-Stuff, with default Code, to clear a system out again.
--
Or then, test some of the nice YOOCART- Zerocart - Panforest.net Variations. Most of them
still have a few minor misses, but that's easy to fix, if one has some knowledge on Code + CSS.
https://www.opencart.com/index.php?rout ... _license=0
And a responsive free v.1.5.6.x Admin Section also exists, if one needs to access Admin on portables:
ImpulsePro 2: OpenCart Admin Theme (Bootstrap) - v2.0.1.5
https://www.opencart.com/index.php?rout ... n_id=13691
---
Another Option would be, to fully Switch to OC-2 Style Front Design, or even replacing the default OC
Theme with a fully responsive OC-2.x Default Code Bootstrap-3 Theme. This can be done, by adding
a VqMod- and module-supported Theme Extension to an existing 1.5.6.x default Installation, or then
install it as complete Installation Package, both offered by famous PEKU (Pekka) from Finland, for free.
https://www.opencart.com/index.php?rout ... ember=peku
It's only drawback could be, that it also has OC v.2.+ like OcMod installed, by default, for not
much reason, since I was probably one of the very few ever, changing vqmods to ocmods, just to
find out, if and how this works. It does! :laugh: But it really makes NO sense, to use OcMod, along
using VqMod! :crazy:
The good thing about it is, that it can easy be switched off again after installation! :P
---
And by doing such, the variety on free Designs explodes, since it only takes another Stylesheet
from an existing free OC v2.0.x Design, and possibly a few Pics and a header/footer file,
to generate, what you can see here:
http://www.opencart.li/themes.html
It's the (near!) ultimate solution, still, a drawback could be, that one needs to make existing
1.5.x Extensions able to handle 'responsive Theme' Code. So, if one downloads a free Extension,
one better should make sure, to download both, the 1.5.x and the v.2.0.x Version of it, if available,
to make it mucho easier, to so get the matching v.1.5.x Code for the
system/ + controller/ + model/ sections, and the (likely) already matching
v.2.0.x Code for the Theme Sections. :laugh: ;)
---
So, whatever you decide on, some work will be part of it. ::)
But better don't move up to the latest, it will be replaced by an even later one soon,
to so be not much longer cared about, I assume...
---
Then, for security purpose so my web can not be hacked so easily, which one is the best deal, update my opencart to newest version, or still maintain this old 1.5.6.4 version but try to fix some security hole if I found it? I have done the standard hardening, like htaccess, file permission, right setting, and so on.
Security-wise, I have not found yet anything about 1.5.6.5_rc on the Web, related to
security problems. Still, there might only be a 'some hundreds' amount in Operation,
but even then, we would get to know about around here, I guess... 8)

But OC does usually not only consist out of OC, but some Extensions as well, and
some of them might not meet the requirements. Just like Journal Themes, a couple
of Subversions ago... :choke: And if one also has potentially attacked Software,
like Wordpress or similar things, on such an OC Site, the risk is much greater, compared
to a Situation, where only OC is part of such a Site.
My test Sites list quite many hacking attempts, but so far, not one of them succeeded.
But is also heavy depends on a Hoster, if something almost comes for free, it cannot
be worth much either, just like in real life too !
---
If I prefer maintain my old 1.5.6.4 opencart, what is the best security tips for this purpose?
https://www.opencart.com/index.php?rout ... n_id=25864
https://www.opencart.com/index.php?rout ... n_id=15901
https://www.opencart.com/index.php?rout ... n_id=21836
https://www.opencart.com/index.php?rout ... n_id=21371
https://www.opencart.com/index.php?rout ... n_id=27076
https://www.opencart.com/index.php?rout ... n_id=22023
https://www.opencart.com/index.php?rout ... n_id=20605
https://www.opencart.com/index.php?rout ... n_id=22296
https://www.opencart.com/index.php?rout ... n_id=13529
https://www.opencart.com/index.php?rout ... n_id=17569
Some are doing the same, or just a little different , use, what meet's best.
viewtopic.php?t=166501#p634026
Paid:
https://www.opencart.com/index.php?rout ... n_id=14775
---
Good Luck ;)
Ernie
PS: A bunch of OC Goodies can also be found here:
https://github.com/IP-CAM
---
Last edited by IP_CAM on Wed Jul 04, 2018 10:49 am, edited 1 time in total.

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by SetiaBudi » Tue Jul 03, 2018 11:37 am

Thank a lot for your kindness to reply and explain its to me.

I understand many of your advice. And I would do it. Your idea to implement the release candidate 1.5.6.5_rc was so brilliant. I would prefer that than to upgrade to newest opencart 3.

Very much appreciated.
IP_CAM wrote:
Mon Jul 02, 2018 9:15 am
What I am afraid is the security of my old opencart 1.5.6.4 can be compromised too easily. In the other hand, for updating my old opencart to newest opencart will require too many time. I also need to configure many of my setting, recheck all the plugins work or not. I understand a bit about programming in PHP.
Well, if you understand a little about programming, just download the latest 1.5.6.5_rc,
it contains all Fixes, still found in v.1.5.6.4. It's only a Release Candidate, and so hidden
from the official OC List, but also the best 1.5.x Version ever made. About 25 Files have
been changed/fixed/updated, compared with v.1.5.6.4, to get a Version, which so far has
not been mentioned in any security-related Topics anywhere. ;)
https://github.com/opencart/opencart/tr ... 306fb75707
---
I am about buying two plugins in short time, one for mobile friendly and one for shipping / delivery. Do you think before buying those new plugins, I should update my 1.5.6.4 opencart, or just read the web about 1.5.6.4 security holes, and tried to fix it?
Well, you don't really have to buy a Theme, to make 1.5.6.x mobile friendly, there are at least
40 nice free + usable Themes available, as well as some Extensions, to make such work, without
changing something 'default' in an existing 1.5.6.4+1.5.6.5_rc Version. Some are fully Bootstrap-3
type Themes, like the fantastic:
OC Bootstrap - Opencart Bootstrap 3 Theme (not default OC-2 style/class compatible!)
https://www.opencart.com/index.php?rout ... n_id=14631
But some free Theme Extensions should be handled with Care, or better, not be touched, because
they partly change existing default things, to an extend, that no other Theme will function anymore,
without fully remove/replace their Code, even DB-Stuff, with default Code, to clear a system out again.
--
Or then, test some of the nice YOOCART- Zerocart - Panforest.net Variations. Most of them
still have a few minor misses, but that's easy to fix, if one has some knowledge on Code + CSS.
https://www.opencart.com/index.php?rout ... _license=0
And a responsive free v.1.5.6.x Admin Section also exists, if one needs to access Admin on portables:
ImpulsePro 2: OpenCart Admin Theme (Bootstrap) - v2.0.1.5
https://www.opencart.com/index.php?rout ... n_id=13691
---
Another Option would be, to fully Switch to OC-2 Style Front Design, or even replacing the default OC
Theme with a fully responsive OC-2.x Default Code Bootstrap-3 Theme. This can be done, by adding
a VqMod- and module-supported Theme Extension to an existing 1.5.6.x default Installation, or then
install it as complete Installation Package, both offered by famous PEKU (Pekka) from Finland, for free.
https://www.opencart.com/index.php?rout ... ember=peku
It's only drawback could be, that it also has OC v.2.+ like OcMod installed, by default, for not
much reason, since I was probably one of the very few ever, changing vqmods to ocmods, just to
find out, if and how this works. It does! :laugh: But it really makes NO sense, to use OcMod, along
using VqMod! :crazy:
The good thing about it is, that it can easy be switched off again after installation! :P
---
And by doing such, the variety on free Designs explodes, since it only takes another Stylesheet
from an existing free OC v2.0.x Design, and possibly a few Pics and a header/footer file,
to generate, what you can see here:
http://www.opencart.li/themes.html
It's the (near!) ultimate solution, still, a drawback could be, that one needs to make existing
1.5.x Extensions able to handle 'responsive Theme' Code. So, if one downloads a free Extension,
one better should make sure, to download both, the 1.5.x and the v.2.0.x Version of it, if available,
to make it mucho easier, to so get the matching v.1.5.x Code for the
system/ + controller/ + model/ sections, and the (likely) already matching
v.2.0.x Code for the Theme Sections. :laugh: ;)
---
So, whatever you decide on, some work will be part of it. ::)
But better don't move up to the latest, it will be replaced by an even later one soon,
to so be not much longer cared about, I assume...
---
Then, for security purpose so my web can not be hacked so easily, which one is the best deal, update my opencart to newest version, or still maintain this old 1.5.6.4 version but try to fix some security hole if I found it? I have done the standard hardening, like htaccess, file permission, right setting, and so on.
Security-wise, I have not found yet anything about 1.5.6.5_rc on the Web, related to
security problems. Still, there might only be a 'some hundreds' amount in Operation,
but even then, we would get to know about around here, I guess... 8)

But OC does usually not only consist out of OC, but some Extensions as well, and
some of them might not meet the requirements. Just like Journal Themes, a couple
of Subversions ago... :choke: And if one also has potentially attacked Software,
like Wordpress or similar things, on such an OC Site, the risk is much greater, compared
to a Situation, where only OC is part of such a Site.
My test Sites list quite many hacking attempts, but so far, not one of them succeeded.
But is also heavy depends on a Hoster, if something almost comes for free, it cannot
be worth much either, just like in real life too !
---
If I prefer maintain my old 1.5.6.4 opencart, what is the best security tips for this purpose?
https://www.opencart.com/index.php?rout ... n_id=25864
https://www.opencart.com/index.php?rout ... n_id=15901
https://www.opencart.com/index.php?rout ... n_id=21836
https://www.opencart.com/index.php?rout ... n_id=21371
https://www.opencart.com/index.php?rout ... n_id=27076
https://www.opencart.com/index.php?rout ... n_id=22023
https://www.opencart.com/index.php?rout ... n_id=20605
https://www.opencart.com/index.php?rout ... n_id=22296
https://www.opencart.com/index.php?rout ... n_id=13529
https://www.opencart.com/index.php?rout ... n_id=17569
Some are doing the same, or just a little different , use, what meet's best.
viewtopic.php?t=166501#p634026
Paid:
https://www.opencart.com/index.php?rout ... n_id=14775
---
Good Luck ;)
Ernie
PS: A bunch of OC Goodies can also be found here:
https://github.com/IP-CAM
---

Newbie

Posts

Joined
Thu Nov 30, 2017 4:59 pm

Post by IP_CAM » Wed Jul 04, 2018 9:50 am

No problem, get it done ! :D
And I only took the opportunity, to 'combine' my Knowledge on this on a single Page.
It might keep others, beeing confronted with similar 'Issues', from the need, to find out,
what v.1.5.x 'Upgrade' Options, and Consequences, might exist in the first place.

And since it works up to PHP v.7.2.5, so far (but not all Extensions do!), and by use
of a free Extension (a system/... replacement file!), either from PEKU,
(seemengly already built-into the latest pekka2 Github.com OC EDGE release)
https://github.com/IP-CAM/Opencart-1.5.6.5-Edge
Change library/encryption.php compatible to PHP 7.x
https://www.opencart.com/index.php?rout ... n_id=34060
or from here:
Opencart 1.5.6.4 & PHP 7 - PHP 7.2
https://www.opencart.com/index.php?rout ... n_id=34428
means, that it will so be able, to do it's Job for still some Years to come. Especially
for those, familiar with it's admin handling, and so rather unwilling, to restart about
from scratch again, without technically or security-wise beeing forced to. :-[
And OC will be more different again anyway, in a couple of Years ... :laugh:
Good Luck! ;)
Ernie
---

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: Bing [Bot] and 16 guests