Post by omass » Fri Sep 01, 2017 3:39 pm

Hi,

OC version 3.0.2.0. Fresh install. Problem: go to category page, where no products. Normally you see text: There are no products to list in this category. But with 3.0.2.0 it is written: Your shopping cart is empty!. The same on the account page, e.g. when you choose Reward points and if there are no reward points, bellow text appears: Your shopping cart is empty!

Does anyone knows a sollution?

New member

Posts

Joined
Sat Jan 12, 2013 3:16 am

Post by AlexChanHK » Fri Sep 01, 2017 4:19 pm

It happened due to the variable of the text_empty of header and category file have some conflict.

please try to go the main folder\catalog\language\en-gb\product\category.php and edit the this content.
text_empty to text_category_empty

And go to the main folder\catalog\view\theme\default\template\product\category.twig and edit the this content.
text_empty to text_category_empty

then it should be fixed.

__________________________________________________________________
New web developer in Opencart ;)
Please mention we work at 9:30 am to 18:30 pm in every Monday to Friday.(UTC+8)


New member

Posts

Joined
Thu Mar 16, 2017 4:34 pm

Post by omass » Fri Sep 01, 2017 4:46 pm

It works, although I wanted to understand real problem, where the confilct is "sitting". Anyway, thank's.

New member

Posts

Joined
Sat Jan 12, 2013 3:16 am

Post by rrzvv » Fri Sep 22, 2017 2:39 am

This is happening everywhere. Any updates please ?

Newbie

Posts

Joined
Sat Jul 22, 2017 3:34 am

Post by rrzvv » Fri Sep 22, 2017 6:46 pm

Figured out !!!!

modify in /system/config/catalog.php at the end find

Code: Select all

	//),
	'controller/*/after'  => array(
		'event/debug/after'
	)
	
modify in

Code: Select all

	//),
	//'controller/*/after'  => array(
		//'event/debug/after'
	//)

Newbie

Posts

Joined
Sat Jul 22, 2017 3:34 am

Post by Chip22 » Fri Sep 22, 2017 8:55 pm

I have same problem...but none of the solutions work...If I product add to cart, cart is empty but It show success message....

Attachments

Monosnap+2017-09-22+15-07-32.png

Monosnap+2017-09-22+15-07-32.png (125.93 KiB) Viewed 3610 times


Newbie

Posts

Joined
Fri Sep 22, 2017 8:33 pm

Post by dblu » Fri Oct 20, 2017 1:27 pm

I am trying to build an online store. Installed everything and trying to modify the site now. However, I am facing the same problem. The shopping cart is empty no matter I add products there. I have tried both methods above, but cannot fix.

Can anyone provide any troubleshoot in this situation? Thanks.

Just in case: http://sweetieland.0fees.us

Newbie

Posts

Joined
Fri Oct 20, 2017 12:37 pm

Post by straightlight » Sat Oct 21, 2017 2:18 am

dblu wrote:
Fri Oct 20, 2017 1:27 pm
I am trying to build an online store. Installed everything and trying to modify the site now. However, I am facing the same problem. The shopping cart is empty no matter I add products there. I have tried both methods above, but cannot fix.

Can anyone provide any troubleshoot in this situation? Thanks.

Just in case: http://sweetieland.0fees.us
Which OC version are you using?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by dblu » Sat Oct 21, 2017 10:16 am

straightlight wrote:
Sat Oct 21, 2017 2:18 am
dblu wrote:
Fri Oct 20, 2017 1:27 pm
I am trying to build an online store. Installed everything and trying to modify the site now. However, I am facing the same problem. The shopping cart is empty no matter I add products there. I have tried both methods above, but cannot fix.

Can anyone provide any troubleshoot in this situation? Thanks.

Just in case: http://sweetieland.0fees.us
Which OC version are you using?
3.0.2.0

Newbie

Posts

Joined
Fri Oct 20, 2017 12:37 pm

Post by straightlight » Sat Oct 21, 2017 10:27 am

Does this issue occur when logged in as a user, using the store link from the admin or as a guest user?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by dblu » Sat Oct 21, 2017 12:44 pm

straightlight wrote:
Sat Oct 21, 2017 10:27 am
Does this issue occur when logged in as a user, using the store link from the admin or as a guest user?
No matter as a user or admin, also have this problem. (even I am using another device - login on my mac and as a guest on my iPad - the cart also empty).

Thanks.

Newbie

Posts

Joined
Fri Oct 20, 2017 12:37 pm

Post by straightlight » Sat Oct 21, 2017 9:06 pm

Do you notice any errors in the logs?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by dblu » Sun Oct 22, 2017 4:58 pm

straightlight wrote:
Sat Oct 21, 2017 9:06 pm
Do you notice any errors in the logs?
No. There has only one error in the log and I have already fixed that issue after I followed a post in this forum.

Newbie

Posts

Joined
Fri Oct 20, 2017 12:37 pm

Post by straightlight » Sun Oct 22, 2017 8:58 pm

Check the error logs from the FTP (normally in the logs/error_log file and the logs/access_log file) to see if additional errors are showing compared to the Opencart error logs. If something is preventing a product to be added to the cart, it does not originate by its own.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by dblu » Mon Oct 23, 2017 10:29 am

straightlight wrote:
Sun Oct 22, 2017 8:58 pm
Check the error logs from the FTP (normally in the logs/error_log file and the logs/access_log file) to see if additional errors are showing compared to the Opencart error logs. If something is preventing a product to be added to the cart, it does not originate by its own.
Can you let me know where the logs is? I mean under which folder? I cannot see the log inside the admin folder.

One more thing, is it related to this problem? This warning exists every time when I log in to my admin panel.
Image

Attachments

Error OC.png

Error OC.png (48.32 KiB) Viewed 3400 times


Newbie

Posts

Joined
Fri Oct 20, 2017 12:37 pm

Post by straightlight » Mon Oct 23, 2017 10:37 am

For now, close the security window. Then, go to the admin - > system - > maintenance - > error logs and see if you notice new lines added when trying to add a product to the cart.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by dblu » Mon Oct 23, 2017 11:11 am

straightlight wrote:
Mon Oct 23, 2017 10:37 am
For now, close the security window. Then, go to the admin - > system - > maintenance - > error logs and see if you notice new lines added when trying to add a product to the cart.
Okay, I got this; but I have already fixed this.
Image

Attachments

Error Log.png

Error Log.png (42.38 KiB) Viewed 3386 times


Newbie

Posts

Joined
Fri Oct 20, 2017 12:37 pm

Post by straightlight » Mon Oct 23, 2017 11:22 am

There are 86 files and 181 occurrences relying on the realpath function. This is a crucial function that needs to be used in Opencart. If you cannot remove the restriction that is in effect on your domain, contact your host support to resolve this issue. However, if you can, followed are detailed example: https://stackoverflow.com/questions/184 ... owed-paths

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by dblu » Mon Oct 23, 2017 1:54 pm

straightlight wrote:
Mon Oct 23, 2017 11:22 am
There are 86 files and 181 occurrences relying on the realpath function. This is a crucial function that needs to be used in Opencart. If you cannot remove the restriction that is in effect on your domain, contact your host support to resolve this issue. However, if you can, followed are detailed example: https://stackoverflow.com/questions/184 ... owed-paths
I doubt that am I address my situation a bit messy as I read through this thread again and found that I have a bit difference between the original poster.

My problem is
When I add an item to the Cart, I am able to receive, like "Success: You have added Canon EOS 5D to your shopping cart!"
But, when I click the Shopping Cart to process check out - "Your shopping cart is empty!" is showing.

Image

Is the solution above can fix this problem? Since I do not quite understand what should I do when I read the link that you provided to me. In fact, I tried to log-in my host support and cannot find the php-setting (wanna followed the link you gave me).

Thanks again.

Attachments

Cart Empty.png

Cart Empty.png (83.83 KiB) Viewed 3359 times


Newbie

Posts

Joined
Fri Oct 20, 2017 12:37 pm

Post by straightlight » Mon Oct 23, 2017 9:07 pm

Is the solution above can fix this problem? Since I do not quite understand what should I do when I read the link that you provided to me. In fact, I tried to log-in my host support and cannot find the php-setting (wanna followed the link you gave me).
Contact your host support for assistance.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 2 guests