Post by tgdonohue » Tue Jun 06, 2017 3:52 am

I am runnuning OC 2.3.02
Working on the data base directly, I added 1 character to a text field.(the field "name" in the table oc_option_description).
Bang!
Nothing on the site appears whether I am at the main index page or the Admin index page.
Looking at the source code from my browser shows no code at all.
Yes, I immediately restored the database to the state prior the event with no result.
I really do not know where to begin on debugging this.
I would welcome some guidance. Thanks

New member

Posts

Joined
Sat Mar 12, 2016 3:03 am

Post by MrPhil » Tue Jun 06, 2017 6:47 am

A "White Screen Of Death" with no page source means a fatal PHP error. There might be something logged in a file somewhere, such as error_log. Presumably you didn't just change the database -- you also made one or more PHP changes. Restore your PHP files to where they were before, and start hunting for the editing mistake.

User avatar
Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm

Post by tgdonohue » Tue Jun 06, 2017 7:29 am

That's a place to start thank you.
And, yes, the DB edit may have been coincidental rather than causal. That such an edit would have that effect, didn't make sense to me.

Still open for suggestions

New member

Posts

Joined
Sat Mar 12, 2016 3:03 am

Post by MrPhil » Fri Jun 09, 2017 10:24 pm

tgdonohue wrote:
Tue Jun 06, 2017 7:29 am
Still open for suggestions
mrphil wrote: Restore your PHP files to where they were before, and start hunting for the editing mistake.
You will find an error in your PHP. Case closed.

User avatar
Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm

Post by tgdonohue » Sat Jun 10, 2017 7:34 am

Thanks
A colleague who is unfamiliar with OC directed the Config.php to a db without realizing there was another in the admin directory.

New member

Posts

Joined
Sat Mar 12, 2016 3:03 am
Who is online

Users browsing this forum: No registered users and 36 guests