Post by kryptonbulbs » Sun Jul 25, 2010 8:15 am

I know, there are a million threads on this... I have read about half of them and have not come up with a solution.

I need to use SMTP mail, I have experience setting these up and know for a fact I am putting the right info into the form fields.

I get absolutely no mail, the customer doesnt get mailed, the admin doesnt get mailed, and the contact form doesnt work.

I really want to use opencart, throught trying to get this mail fixed I have been checking out other CMS and I just havent foud anything else I like to use as much as opencart.

I have only discovered 2 issues,
the email
and the fact that I cant add the same item to my cart twice (I have 4 different options on an item so if a customer wanted to order 1 one way and 1 the other way I would like them to be able to)

Other than these I have found the system very user firendly and great to use. I need the email to be fixed to back able to use this, I would like the cart issue to be fixed but can work around it with more products.

Any help on either of these issues is appreciated.

New member

Posts

Joined
Sat Jul 24, 2010 8:41 am

Post by DKLeader » Mon Jul 26, 2010 10:26 pm

Hi,

Dont know if I should have started a new thread, but got almost the same problem with the mails.
When I change the status of a order mails are sent and customers creation email, but no invoices to customers or admins are sent (ticked it of in settings). The same with new orders - no info to admins.
I find it strange since the emails with the status change is passed to customers.

// DKLeader

CZGames.dk - A Danish Hosting Company
With eSport clan, and other affiliates

SuperWeb.dk - Webhosting
Owned by CZGames.dk

CGData.dk I/S - IT Supplies (HardWare and Software)
Shop will be opened on a later date.


Newbie

Posts

Joined
Mon Jul 26, 2010 9:36 pm
Location - Denmark

Post by kryptonbulbs » Tue Jul 27, 2010 8:13 am

OK, I've got it half working. Its really messed up though.

I am using SMTP mail however I had to set the mail protocol to "mail" instead of "smtp"

Now, the contact form works, and the admin emails work, they are sent to one of my domain emails.

However, depending on the email of the customer sometimes their host rejects it. My roadrunner ISP rejects it, a customers AOL ISP (same as rr really) rejects it, maybe more???

If i place an order and have it sent to my gmail account it goes right through.

Anybody know why it would be sending mails that get rejected by these mail servers? I really need my customers to get their emails.

New member

Posts

Joined
Sat Jul 24, 2010 8:41 am

Post by JAY6390 » Tue Jul 27, 2010 8:24 am

Sounds like it might be an SPF record issue. Contact your hosting and ask them if they can put an SPF record into your DNS entry so servers don't think you are a spammer

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by kryptonbulbs » Tue Jul 27, 2010 11:27 am

JAY6390 wrote:Sounds like it might be an SPF record issue. Contact your hosting and ask them if they can put an SPF record into your DNS entry so servers don't think you are a spammer
Thanks Jay, I have opened a support ticket with my host. I will update the thread with the results

New member

Posts

Joined
Sat Jul 24, 2010 8:41 am

Post by DKLeader » Tue Jul 27, 2010 5:03 pm

JAY6390 wrote:Sounds like it might be an SPF record issue. Contact your hosting and ask them if they can put an SPF record into your DNS entry so servers don't think you are a spammer
If it was a SPF record issue wouldnt it affect all e-mails sent to a customer? As I wrote in my post earlier in this thread, I have sort of the same problem exept for changes made to status on order and the welcome email. I created myself as a customer and had same issue with the invoice not being received.
I am hosting the shop on own domainserver, DNS servers and mailserver.

// DKLeader

CZGames.dk - A Danish Hosting Company
With eSport clan, and other affiliates

SuperWeb.dk - Webhosting
Owned by CZGames.dk

CGData.dk I/S - IT Supplies (HardWare and Software)
Shop will be opened on a later date.


Newbie

Posts

Joined
Mon Jul 26, 2010 9:36 pm
Location - Denmark

Post by JAY6390 » Tue Jul 27, 2010 6:41 pm

In your specific case I can't really comment DKLeader but since kryptonbulbs has it only affecting some emails, it could be the spam filtering software used by the ISP that has its threshold set to a higher level than others

Gmail has quite a low threshold for the SPF record, where as Hotmail is quite high. You can send emails to both with the exact same content, and Gmail will receive it and hotmail will not

In answer to your question, yes it will affect all emails sent to a customer, but only to the same customers

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by spikeachu » Wed Jul 28, 2010 4:17 am

I had a problem where some emails were being sent but not others.

On checking the error log, I found that a module I had implemented had an undefined index call, this stopped outbound email. Upon sorting out the undefined index, the mail started going again.

Might be worth checking the error log to see if there are any errors showing when an action is performed that should send mail.

Regards, Spike.

Wedding Invitations and Stationery by Love2print

Commercial Mods
Product Colours on Category Page
Cardsave Direct Gateway
Clear Cache
Promotional Watermarks on Images
Multiple Category / Product Templates ** Popular **
Log Failed Login Attempts
Display Eligible Coupons with Products
Twitter Feeds

Have I helped you out or saved you some time? Please donate


Active Member

Posts

Joined
Fri Mar 12, 2010 6:31 am

Post by JAY6390 » Wed Jul 28, 2010 5:03 am

Ah good to know Spike :) Thanks for sharing

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by DKLeader » Wed Jul 28, 2010 11:37 pm

Hi,

Just checked the log (believe there is only one) and it only had this :
2010-07-27 17:39:42 - PHP Warning: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /webspace/czgames/jakob/superweb.dk/www/html/shop/system/library/mail.php on line 156
2010-07-27 17:39:42 - PHP Warning: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to mail.cgdata.dk:587 (php_network_getaddresses: getaddrinfo failed: Name or service not known) in /webspace/czgames/jakob/superweb.dk/www/html/shop/system/library/mail.php on line 156
But that one was a human error - entered wrong data into the mail section trying smtp.
Have tried both mail and smtp with same results. Only 2 type of emails are forwarded to the customers : welcome message and status change on orders. Tried the mail function in OpenCart and these are not forwarded either.

CZGames.dk - A Danish Hosting Company
With eSport clan, and other affiliates

SuperWeb.dk - Webhosting
Owned by CZGames.dk

CGData.dk I/S - IT Supplies (HardWare and Software)
Shop will be opened on a later date.


Newbie

Posts

Joined
Mon Jul 26, 2010 9:36 pm
Location - Denmark

Post by stonehinged » Wed Sep 01, 2010 8:52 am

I was so frustrated with email delivery I simply removed all settings under the 'Mail' tab under Settings in Admin and the contact page worked and sent a mail. I was floored! I'm using 1.4.7. Could this be right?

STONEHINGED
Handcrafted, Semi-Precious Jewelry
http://www.stonehinged.com/


User avatar
Active Member

Posts

Joined
Wed Aug 18, 2010 9:10 am
Location - US

Post by al3xandr1a » Fri Sep 17, 2010 12:01 am

So what's the final say/solution about this thread?
Also wondering, has this been a problem on v1.4.8b only? ???

~al3xandr1a
Newbie / Student


User avatar
New member

Posts

Joined
Fri Jul 02, 2010 7:27 pm

Post by Pittman » Thu Apr 12, 2012 3:07 am

Ugh, I am having the SAME problem, and find it frustrating that Opencart's Mail system is inherently flawed (apparently) and that NOBODY seems to have figured out what this problem is.

I have my mail settings setup to use SMTP, as my email server is different from my companies website host (we use an in house mail server, whereas the main website is hosted thru a hosting company).

Here's the error I'm getting, which is nearly identical to HUNDREDS of other users...

2012-04-10 17:49:26 - PHP Warning: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to incoming.johncpittmaninc.com:25 (Connection refused) in /home3/johncpit/public_html/johnpittman/opencart/system/library/mail.php on line 161
2012-04-10 17:49:26 - PHP Notice: Error: Connection refused (111) in /home3/johncpit/public_html/johnpittman/opencart/system/library/mail.php on line 164


I had thought that Opencart was the solution to my companies problem......but if they can't even make a system that has an easy-to-configure/setup mail delivery system, then I think I may need to look into alternatives.

I find it absolutely ridiculous that something that is such a basic and elementary part of ANY website is so frustratingly hard to setup properly with Opencart.

Newbie

Posts

Joined
Fri Mar 09, 2012 12:43 am
Who is online

Users browsing this forum: No registered users and 29 guests