Post by percmac » Mon Mar 14, 2016 11:08 pm

I tried to upgrade my website through Softaculous.. This is what I am getting:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

OK

<br />
<b>Notice</b>: Undefined index: affiliate_activity_id in <b>/home/guduecom/public_html/install/model/upgrade/1001.php</b> on line <b>90</b><br />
{"error":"Error Code(0): Error: Unknown column 'affiliate_activity_id' in 'where clause'<br \/>Error No: 1054<br \/>UPDATE `oc_affiliate_activity` SET `data` = '{\\\"affiliate_id\\\":1,\\\"name\\\":\\\"PERCY Nxumalo\\\"}' WHERE `affiliate_activity_id` = '0' in \/home\/guduecom\/public_html\/system\/library\/db\/mysqli.php on line 40"}

Newbie

Posts

Joined
Mon Mar 14, 2016 11:06 pm

Post by Johnathan » Tue Mar 15, 2016 12:11 am

1. Restore your site from a backup.

2. Never use Softaculous for upgrades. It will almost never work properly.

3. The upgrade script (which Softaculous probably didn't use anyway) is broken in 2.2.0.0. I'd stay away from upgrading until it's officially fixed.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by Randem » Tue Mar 15, 2016 11:02 am

Hi percmac,

Do not attempt to use the OpenCart upgrade script, it is broken... You can try these scripts for your upgrading...

Upgrade from 1.5.x to 2.1.0.x - http://www.randemsystems.com/support/op ... n-2-1-0-1/
Upgrade from 2.1.0.x to 2.2.0.0 - http://www.randemsystems.com/support/op ... 0/#msg6260

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am
Who is online

Users browsing this forum: No registered users and 7 guests