Post by NIcoleKiefer » Thu Jan 21, 2016 12:07 am

Hi I'm new, not just here but with the whole ecommerce thing and I seem to be not good at it, at all. My hoster freehostia is offering the open cart software and I intalled it this morning. I tried to change the General information and store information under settings, following the instructions from documentation. However every time I try I get this message and no changes are being saved Warning: Please check the form carefully for error! It doesn't tell me what's amiss. Neither can I create a new store under the same URL Anyone can tell me what I'm doing wrong?

Thanks Nicole

Newbie

Posts

Joined
Wed Jan 20, 2016 11:59 pm

Post by Randem » Fri Jan 22, 2016 1:33 pm

Hi NIcoleKiefer,

You need to check all tabs in the store for a red asterisk on the left of the name of the field. These fields are required and you will not be able to save any changes until all these fields are filled in.

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by Quantme » Sat Mar 26, 2016 9:49 am

Same issue, cannot modify default values. Even with a fresh installation I click on 'Settings' and immediately clicking on 'Save' (without modifying a thing) the same error message. What could be happening? Thanks in advance.

$me = !$me ? $you : $me++;


User avatar
Newbie

Posts

Joined
Sat Mar 26, 2016 9:42 am
Location - México

Post by Randem » Sun Mar 27, 2016 11:36 am

It is the same ; you cannot save if the required fields are not filled in. Cannot know more without seeing your exact page am message.

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by Quantme » Sun Mar 27, 2016 12:19 pm

I found something. Steps to error:

1. Download OC 2.2
2. Upload and install to server.
3. Download translation (es-mx) from http://translate.opencart.com/ and upload to server.
4. Go to /admin page, enter to 'Settings' and select 'Your store'.
5. Select 'es-mx' language and save.
6. Try to modify and get error.

The way I fixed (by now) is modifying directly 'setting' table from DB (config_admin_language) to 'en-gb' and voilà! I can modify it all! But if I select 'es-mx' language the error appears again. I will setup the store in english first and try to select local language at the end.

Don't know why language files can do that, I hope don't interfere with store activity. Customer needs front/back-end in 'es-mx'.

Any idea? Thanks for your time and attention.

$me = !$me ? $you : $me++;


User avatar
Newbie

Posts

Joined
Sat Mar 26, 2016 9:42 am
Location - México

Post by Randem » Sun Mar 27, 2016 12:26 pm

That may be an issue in v2.2. Are you sure that the language is for v2.2?
Why did you decide on using v2.2 instead of something a little more reliable (v2.1)?

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by Quantme » Sun Mar 27, 2016 1:09 pm

Ooops! Feel like a dumb. Translation files are for 2.0x :-\ I didn't notice the version. I tried to found the 2.2x version, even the english version to participate translating by myself without results. The way I'm thinking to resolve it is duplicating and translating file by file :(

I downloaded 2.2x because is available from opencart site. It will be good knowing if is a stable release before get it.

Thanks for all.

$me = !$me ? $you : $me++;


User avatar
Newbie

Posts

Joined
Sat Mar 26, 2016 9:42 am
Location - México

Post by Randem » Sun Mar 27, 2016 3:06 pm

Good you found the issue. BTW you can download previous versions of OpenCart from the OpenCart website

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am
Who is online

Users browsing this forum: No registered users and 8 guests