Post by codywood » Fri Oct 16, 2015 3:21 am

I have a number of extensions/modifications installed and at least half of them give me the error that I pasted below. I'm using Opencart 2.0.2.0.

I disabled all of the modifications and enabled just one at a time, and then checked for the error. After each check I would disable that extension. In other words, only one extension was active at a time from the modifications page and at least half of them produced the same error.

Here's the error:

Warning: DOMDocument::loadXML(): Start tag expected, '<' not found in Entity, line: 1 in /home/techeq/public_html/store01/admin/controller/extension/modification.php on line 139Notice: Trying to get property of non-object in /home/techeq/public_html/store01/admin/controller/extension/modification.php on line 142
Fatal error: Call to a member function getElementsByTagName() on a non-object in /home/techeq/public_html/store01/admin/controller/extension/modification.php on line 152

So obviously this is not one, or even two extensions causing the problem. At least half of the extensions installed produce the exact same error above.

See attached file modification.php.

thanks

New member

Posts

Joined
Mon Sep 15, 2014 10:42 am

Post by qahar » Fri Oct 16, 2015 12:47 pm

Few days ago someone use my extension and get the same exact issue.
The funny thing is that my extension use vQmod and not OcMod.

Just wondering, have you clear system\modification manually?

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by codywood » Sat Oct 17, 2015 1:15 pm

What do you mean by clearing it manually?

New member

Posts

Joined
Mon Sep 15, 2014 10:42 am

Post by codywood » Sat Oct 17, 2015 1:16 pm

On the modification page I just clicked the clear button and then click the refresh button and received the following error. Is anyone familiar with this?

Warning: DOMDocument::loadXML(): Start tag expected, '<' not found in Entity, line: 1 in /home/techeq/public_html/store01/admin/controller/extension/modification.php on line 139Notice: Trying to get property of non-object in /home/techeq/public_html/store01/admin/controller/extension/modification.php on line 142
Fatal error: Call to a member function getElementsByTagName() on a non-object in /home/techeq/public_html/store01/admin/controller/extension/modification.php on line 152

Thanks

New member

Posts

Joined
Mon Sep 15, 2014 10:42 am

Post by codywood » Sat Oct 17, 2015 1:19 pm

I'm still getting the following error on the front end. Can anyone advise?

Notice: Undefined variable: categories in /home/techeq/public_html/store01/vqmod/vqcache/vq2-catalog_controller_product_category.php on line 438Warning: Invalid argument supplied for foreach() in /home/techeq/public_html/store01/vqmod/vqcache/vq2-catalog_controller_product_category.php on line 438

Thanks

New member

Posts

Joined
Mon Sep 15, 2014 10:42 am

Post by clorne » Thu Oct 22, 2015 3:14 pm

There appears to be a little bit of confusion here between vQmod and OCMOD extensions.

It may help some people to read "OCMOD an introduction and installation guide for OpenCart users"

http://ocextensions.co.uk/ocmod/ocmod

Active Member

Posts

Joined
Fri Dec 23, 2011 6:03 pm

Post by marlaaragao » Tue Dec 22, 2015 8:05 pm

Hello!

I'm getting the same error (Warning: DOMDocument::loadXML(): Start tag expected, '<' not found in Entity, line: 1 in C:\xampp\htdocs\opencart-2.1.0.1\upload\admin\controller\extension\modification.php on line 139).

Everything was working fine yesterday. Simply, I started getting the error on refresh (and was just installing a module that has been installed hundreds of times). I manage to get the $xml content at the time of the error:

Thats the line 139: $dom->loadXml($xml);
The $xml content is:

[...]
5 => string 'vqmod/xml/add_getRecurrings_on_catalog_model_product.xml' (length=56)
[...]

You see, that's a path, not a xml content. Instead of getting the content of the file, it gets the path, and I don't understand why this started happening out of nowhere. Can anyone pleasee help me? Thanks!

Newbie

Posts

Joined
Tue Dec 22, 2015 7:53 pm

Post by jonathortense » Wed Dec 23, 2015 10:00 am

I have the same error here. Any solution?

Newbie

Posts

Joined
Sat Oct 25, 2014 7:59 am

Post by codywood » Thu Jan 14, 2016 10:31 am

I still have this problem. Please, someone help all of us!

New member

Posts

Joined
Mon Sep 15, 2014 10:42 am

Post by opencartboost » Sat Jan 16, 2016 9:00 pm

Did you try contact developer who develop that extensions?

Active Member

Posts

Joined
Thu Jul 09, 2015 5:59 am

Post by Rufusd » Mon Jan 25, 2016 1:05 pm

I have this error too, but little different. Many say it should be related to OCMOD or vQMod, but we need to know the exact procedure in overcoming this issue. I couldn't locate OCMod installation anywhere in my modules or extension, tried re-configuring vQmod, no luck.

Someone, please assist with the right solution.

Error in Admin panel while giving refresh:


Warning: DOMDocument::loadXML(): Start tag expected, '<' not found in Entity, line: 1 in /home/open/public_html/admin/controller/extension/modification.php on line 140Notice: Trying to get property of non-object in /home/open/public_html/admin/controller/extension/modification.php on line 143
Fatal error: Call to a member function getElementsByTagName() on a non-object in /home/open/public_html/admin/controller/extension/modification.php on line 153

Thanks in advance!

Newbie

Posts

Joined
Sun Nov 01, 2015 6:45 pm
Who is online

Users browsing this forum: No registered users and 5 guests