Post by NetCaffe » Tue Apr 14, 2015 5:29 am

Hello,
I'm having issues with the Maintenance Mode. I noticed that fore some reason my site keeps switching to Maintenance Mode automatically. Anyone know why it's doing it & how I can fix the problem?

Newbie

Posts

Joined
Wed Apr 08, 2015 10:18 am

Post by NetCaffe » Thu Apr 16, 2015 6:33 am

BUMP

Newbie

Posts

Joined
Wed Apr 08, 2015 10:18 am

Post by viethemes » Thu Apr 16, 2015 2:03 pm

Did you refresh modifications in admin > Extensions > Modifications before?
In OpenCart 2.0.2.0, it switches to the maintenance mode automatically when modifications are being built and disable after this process is done.

http://www.viethemes.com - OpenCart turtorials, news, tips and stricks, extension

Our extensions:
Visual Theme Editor - Powerful tool for customizing style of any theme visually
Live Theme Editor - Customize layout, colors, backgrounds, fonts of the default theme
Theme Animation - Animation Editor for any theme

Extra Positions PRO, Custom JavaScript, Custom CSS and others


User avatar
Active Member

Posts

Joined
Thu Jan 08, 2015 12:17 pm


Post by NetCaffe » Sun Apr 19, 2015 5:18 am

viethemes wrote:Did you refresh modifications in admin > Extensions > Modifications before?
In OpenCart 2.0.2.0, it switches to the maintenance mode automatically when modifications are being built and disable after this process is done.

Yes I did refresh the modifications. That now makes scenes.


Thank you.

Newbie

Posts

Joined
Wed Apr 08, 2015 10:18 am

Post by aljawaid » Sun May 31, 2015 6:25 pm

The same happens in 2.0.3.1 but doesn't re-enable. Seems like something is triggering maintenance mode to activate even though I have disabled all my extensions.

Total e-commerce newbie bravely testing OC v2.0.3.1 before rolling it live...getting there slowly, somehow. Maybe not. I dunno.


Active Member

Posts

Joined
Fri Oct 10, 2014 10:33 pm
Location - UK

Post by viethemes » Sun May 31, 2015 11:11 pm

I have made a OCMOD extension to fix it. You can download it here: https://www.dropbox.com/s/va83gsyx3tzty ... d.xml?dl=0.
Note that, after you install this extension, please turn off the maintenance mode in store settings.
Last edited by viethemes on Thu Jun 04, 2015 8:59 pm, edited 1 time in total.

http://www.viethemes.com - OpenCart turtorials, news, tips and stricks, extension

Our extensions:
Visual Theme Editor - Powerful tool for customizing style of any theme visually
Live Theme Editor - Customize layout, colors, backgrounds, fonts of the default theme
Theme Animation - Animation Editor for any theme

Extra Positions PRO, Custom JavaScript, Custom CSS and others


User avatar
Active Member

Posts

Joined
Thu Jan 08, 2015 12:17 pm


Post by aljawaid » Sun May 31, 2015 11:39 pm

viethemes wrote:I have made a OCMOD extension to fix it. You can download it here: https://www.dropbox.com/s/va83gsyx3tzty ... d.xml?dl=0.
Note that, after you install this extension, please turn off the maintenance mode in store settings.
Hello thanks for this, it seems to work. Although will keep monitoring it.

Do you think this was a bug for 2.0.3.1?

Total e-commerce newbie bravely testing OC v2.0.3.1 before rolling it live...getting there slowly, somehow. Maybe not. I dunno.


Active Member

Posts

Joined
Fri Oct 10, 2014 10:33 pm
Location - UK

Post by viethemes » Mon Jun 01, 2015 10:16 pm

Yes. It is bug of OpenCart 2.0.3.1. Hope this error is fixed soon.

http://www.viethemes.com - OpenCart turtorials, news, tips and stricks, extension

Our extensions:
Visual Theme Editor - Powerful tool for customizing style of any theme visually
Live Theme Editor - Customize layout, colors, backgrounds, fonts of the default theme
Theme Animation - Animation Editor for any theme

Extra Positions PRO, Custom JavaScript, Custom CSS and others


User avatar
Active Member

Posts

Joined
Thu Jan 08, 2015 12:17 pm


Post by Freakshow » Thu Jun 04, 2015 2:51 pm

Anyone more using this hotfix and have feedback that it is holding, i need to trust my store is open 24/7 :o ::)


User avatar
Active Member

Posts

Joined
Tue Dec 30, 2014 3:52 am
Location - Norway

Post by aljawaid » Thu Jun 04, 2015 2:56 pm

Freakshow wrote:Anyone more using this hotfix and have feedback that it is holding, i need to trust my store is open 24/7 :o ::)
I've not had a problem since Viethemes fix - the better one I found in just one mod without replacing files. Another one came up in the store but it was replacing the actual modification.php file so I wasn't too sure about it.

Total e-commerce newbie bravely testing OC v2.0.3.1 before rolling it live...getting there slowly, somehow. Maybe not. I dunno.


Active Member

Posts

Joined
Fri Oct 10, 2014 10:33 pm
Location - UK

Post by Freakshow » Thu Jun 04, 2015 3:00 pm

aljawaid wrote:
Freakshow wrote:Anyone more using this hotfix and have feedback that it is holding, i need to trust my store is open 24/7 :o ::)
I've not had a problem since Viethemes fix - the better one I found in just one mod without replacing files. Another one came up in the store but it was replacing the actual modification.php file so I wasn't too sure about it.
Good to know, thank you for the feedback.
It is when stuff like this happens i really get skeptical, to trust that your money maker is open for business, well that is kinda core essential if you ask me :)


User avatar
Active Member

Posts

Joined
Tue Dec 30, 2014 3:52 am
Location - Norway

Post by aljawaid » Thu Jun 04, 2015 4:18 pm

Freakshow wrote:
Good to know, thank you for the feedback.
It is when stuff like this happens i really get skeptical, to trust that your money maker is open for business, well that is kinda core essential if you ask me :)
No worries. Totally agree. I'm struggling to go live as e-comm came to me as a complete new thing and OC was the best option I found where I could make it look my way with a decent interface.

When you're new to the game in every aspect, it's hard to justify spending money on something that may or may not work to the management. I'm all for developers charging for extra extensions, but when the core doesn't seem stable enough, I struggle to spend (sometimes overcharged) money on developers who may or may not sort my problem from the other side of the world.

The forums, docs all are outdated or specific to v1.5 which doesn't help build confidence at all.

I digress, but from battling and struggling from OC2.0 to 2.0.3.1 in a test environment with no live shop yet I do believe it is a "better" version than before and gives me some hope.

Total e-commerce newbie bravely testing OC v2.0.3.1 before rolling it live...getting there slowly, somehow. Maybe not. I dunno.


Active Member

Posts

Joined
Fri Oct 10, 2014 10:33 pm
Location - UK

Post by fido-x » Thu Jun 04, 2015 4:27 pm

viethemes wrote:I have made a OCMOD extension to fix it. You can download it here: https://www.dropbox.com/s/va83gsyx3tzty ... d.xml?dl=0.
This won't work. The modification will be lost as soon as you refresh your modification cache.
viethemes wrote:Note that, after you install this extension, please turn off the maintenance mode in store settings.
Bingo! We have a winner.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by viethemes » Thu Jun 04, 2015 8:49 pm

fido-x wrote:
viethemes wrote:I have made a OCMOD extension to fix it. You can download it here: https://www.dropbox.com/s/va83gsyx3tzty ... d.xml?dl=0.
This won't work. The modification will be lost as soon as you refresh your modification cache.
viethemes wrote:Note that, after you install this extension, please turn off the maintenance mode in store settings.
Bingo! We have a winner.
Because the maintenance mod is turned on before, so we need to turn it off after installing the extension :)

http://www.viethemes.com - OpenCart turtorials, news, tips and stricks, extension

Our extensions:
Visual Theme Editor - Powerful tool for customizing style of any theme visually
Live Theme Editor - Customize layout, colors, backgrounds, fonts of the default theme
Theme Animation - Animation Editor for any theme

Extra Positions PRO, Custom JavaScript, Custom CSS and others


User avatar
Active Member

Posts

Joined
Thu Jan 08, 2015 12:17 pm


Post by fido-x » Thu Jun 04, 2015 10:18 pm

viethemes wrote:Because the maintenance mod is turned on before, so we need to turn it off after installing the extension :)
You don't get it. How do you install the modification? Answer, by refreshing your modification cache. The first thing this does is put the site into maintenance mode (standard behaviour). The problem is, that it doesn't take the site out of maintenance mode afterwards. Your code sets maintenance mode to "true", which only ensures that it stays on.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by fido-x » Thu Jun 04, 2015 10:21 pm

PS. For a fix, see viewtopic.php?f=191&t=145612

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by viethemes » Fri Jun 05, 2015 1:10 am

Please note that the extension is a hot fix! I will fix the problem on next times when you refresh modifications.

http://www.viethemes.com - OpenCart turtorials, news, tips and stricks, extension

Our extensions:
Visual Theme Editor - Powerful tool for customizing style of any theme visually
Live Theme Editor - Customize layout, colors, backgrounds, fonts of the default theme
Theme Animation - Animation Editor for any theme

Extra Positions PRO, Custom JavaScript, Custom CSS and others


User avatar
Active Member

Posts

Joined
Thu Jan 08, 2015 12:17 pm


Post by NginUS » Fri Sep 11, 2015 12:27 pm

viethemes wrote:I have made a OCMOD extension to fix it. You can download it here: https://www.dropbox.com/s/va83gsyx3tzty ... d.xml?dl=0.
Note that, after you install this extension, please turn off the maintenance mode in store settings.
I did this:

1) Install the xml file with extension installer
2) Refresh the modifications cache
3) Disable maintenance mode one last time

...Is there anything else that needs to happen to make this work, or am I good?

Thx,
-N

Newbie

Posts

Joined
Fri Sep 11, 2015 9:49 am

Post by kjwork » Thu Oct 01, 2015 10:41 pm

Thanks .. working for now

Newbie

Posts

Joined
Thu Oct 01, 2015 10:39 pm
Who is online

Users browsing this forum: shahab7073 and 36 guests