Post by JonnieG » Sun Jan 18, 2015 8:07 am

When a customer selects a product and pays with points and money the points are NOT deducted from the customers total points until the admin changes the order status to complete. In theory allowing the customer to shop with points that they have already used. Not Good for business!

Any points involved in a payment or part payment should be deducted when a customer presses confirm order.

I'm using Opencart version 2.0.1.1

Newbie

Posts

Joined
Sun Jan 18, 2015 7:49 am

Post by yangb0 » Thu Mar 05, 2015 2:54 pm

Same here!

Newbie

Posts

Joined
Thu Mar 05, 2015 2:54 pm

Post by Prophet Mykola » Tue Nov 17, 2015 9:48 pm

I am running version 2.1.0.1, now the reward points are not deducted at all, even when order is set to 'complete.


Posts

Joined
Tue Nov 17, 2015 9:38 pm

Post by hmf » Wed Jan 13, 2016 11:40 pm

I am having the same issue in 1.5.3.1

Anyone have a fix?

hmf
New member

Posts

Joined
Thu May 31, 2012 2:17 am

Post by gogoweb » Sun Jan 17, 2016 1:29 am

Hello,
I've found a solution for the bug in OpenCart 2.1.0.1 and 2.1.0.2
I've implemented it in my module for Auto reward points.

If you choose not to use the module's functions and keep it disabled, it will still fix the problem of deducting customer's points.

All mods | OpenCart Bulk Related Products Ultimate Edition |GeoIP hide Prices / no add to cart by country| CSS override | Direct link to checkout / skip add to cart / buy now link | AUTO pilot - reward & purchase points


New member

Posts

Joined
Sat Oct 18, 2014 6:45 pm


Post by Burt65 » Fri Jan 22, 2016 8:54 pm

gogoweb wrote:Hello,
I've found a solution for the bug in OpenCart 2.1.0.1 and 2.1.0.2
I've implemented it in my module for Auto reward points.

If you choose not to use the module's functions and keep it disabled, it will still fix the problem of deducting customer's points.

You have found the solution? Really? Your post is dated 17/1/16 and the fix was posted by vyshemirsky on GitHub on the 18/11/15...

That's sad...

For anybody else that may still have this problem:

upload/catalog/model/total/reward.php

Change line 68

if ($this->model_account_customer->getRewardTotal($order_info['customer_id']) < $points) {

to

if ($this->model_account_customer->getRewardTotal($order_info['customer_id']) >= $points) {

Over 95% of all computer problems can be traced back to the interface between the keyboard and the chair...


User avatar
Active Member

Posts

Joined
Mon Nov 18, 2013 3:23 pm
Location - Oz

New member

Posts

Joined
Sat Oct 18, 2014 6:45 pm


Post by Burt65 » Sat Jan 30, 2016 5:35 pm

gogoweb wrote:Well I did not know that first, but who cares when it is not published in 2.1.0.2 either!
Well it is painfully obvious that you don't really care much, when you try to take credit and I quote:
We are proud of discovering the bug and implementing a patch for it in our latest release
and then instead of helping people by letting them know what the bug is, try to maximise your profit by selling your extension with the solution...

Sorry mate but it does look cheap and immature!

Luckily for us, you are the minority...

Over 95% of all computer problems can be traced back to the interface between the keyboard and the chair...


User avatar
Active Member

Posts

Joined
Mon Nov 18, 2013 3:23 pm
Location - Oz

Post by kachman » Sat Dec 10, 2016 12:50 pm

there is one other issue i noticed.

If customer has enough points to get a product for free, the system still goes to paypal page and neglects the 100% discount, it just shows the original price on the paypal login page. How can I fix this so that the order is complete without going to paypal?

Newbie

Posts

Joined
Sun Nov 13, 2016 11:50 pm

Post by daneshh » Wed Dec 21, 2016 6:48 pm

when a customer uses his reward point, and then if an admin deletes his order in the admin panel, the reward point will refund to customer and he can use it again
what fix do u have for this ?:(

Newbie

Posts

Joined
Sun Dec 11, 2016 6:47 pm

Post by daneshh » Wed Dec 21, 2016 6:50 pm

kachman wrote:there is one other issue i noticed.

If customer has enough points to get a product for free, the system still goes to paypal page and neglects the 100% discount, it just shows the original price on the paypal login page. How can I fix this so that the order is complete without going to paypal?
there's a module named free order I think ( or something like this ), u should install it and when an order has 0$ invoice, the free payment will be activated automatically.

Newbie

Posts

Joined
Sun Dec 11, 2016 6:47 pm

Post by kachman » Wed Feb 15, 2017 1:10 am

daneshh wrote:
Wed Dec 21, 2016 6:50 pm
kachman wrote:there is one other issue i noticed.

If customer has enough points to get a product for free, the system still goes to paypal page and neglects the 100% discount, it just shows the original price on the paypal login page. How can I fix this so that the order is complete without going to paypal?
there's a module named free order I think ( or something like this ), u should install it and when an order has 0$ invoice, the free payment will be activated automatically.
thanks a lot, its called Free checkout. God bless you my friend

Newbie

Posts

Joined
Sun Nov 13, 2016 11:50 pm

Post by kachman » Wed Feb 15, 2017 1:11 am

daneshh wrote:
Wed Dec 21, 2016 6:48 pm
when a customer uses his reward point, and then if an admin deletes his order in the admin panel, the reward point will refund to customer and he can use it again
what fix do u have for this ?:(
yes i have also noticed this. So i have to manually delete reward points everytime I delete order

Newbie

Posts

Joined
Sun Nov 13, 2016 11:50 pm

Post by orocha » Fri Feb 17, 2017 9:01 pm

Burt65 wrote:
Fri Jan 22, 2016 8:54 pm
gogoweb wrote:Hello,
I've found a solution for the bug in OpenCart 2.1.0.1 and 2.1.0.2
I've implemented it in my module for Auto reward points.

If you choose not to use the module's functions and keep it disabled, it will still fix the problem of deducting customer's points.

You have found the solution? Really? Your post is dated 17/1/16 and the fix was posted by vyshemirsky on GitHub on the 18/11/15...

That's sad...

For anybody else that may still have this problem:

upload/catalog/model/total/reward.php

Change line 68

if ($this->model_account_customer->getRewardTotal($order_info['customer_id']) < $points) {

to

if ($this->model_account_customer->getRewardTotal($order_info['customer_id']) >= $points) {
Hello,

The solution to the OpenCart bug problem of not cashing reward points when the client uses the points was posted above but only for versions 2.1 and 2.2, but for previous versions like 2.0.3.1 did anyone find out?

Newbie

Posts

Joined
Fri Feb 17, 2017 8:17 pm

Post by ajbeigh » Mon Dec 04, 2017 12:39 am

Burt65 wrote:
Fri Jan 22, 2016 8:54 pm
gogoweb wrote:Hello,
I've found a solution for the bug in OpenCart 2.1.0.1 and 2.1.0.2
I've implemented it in my module for Auto reward points.

If you choose not to use the module's functions and keep it disabled, it will still fix the problem of deducting customer's points.

You have found the solution? Really? Your post is dated 17/1/16 and the fix was posted by vyshemirsky on GitHub on the 18/11/15...

That's sad...

For anybody else that may still have this problem:

upload/catalog/model/total/reward.php

Change line 68

if ($this->model_account_customer->getRewardTotal($order_info['customer_id']) < $points) {

to

if ($this->model_account_customer->getRewardTotal($order_info['customer_id']) >= $points) {
Hi, i tried this, but didn't work, can someone please help me, i'm using opencart v2.1.0.2

Newbie

Posts

Joined
Sat Nov 11, 2017 4:32 pm

Post by ADD Creative » Tue Dec 05, 2017 8:21 pm

As mentioned in the first post, have you set the order to a completed status?

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom
Who is online

Users browsing this forum: No registered users and 4 guests