Post by p4m » Wed Mar 24, 2010 6:57 pm

Hello,

I have upgraded OC from 1.2.9 to 1.4.4, but I can't anymore open my store online because of this remaining error mess:

Code: Select all

Error: Unknown column 'language_id' in 'where clause'
Error No: 1054
SELECT * FROM weight_class WHERE language_id = '2'
I have English as 1rst language and french as the 2nd one.

here are my weight_class settings:

Code: Select all

INSERT INTO `weight_class` (`weight_class_id`, `value`) VALUES
(1, 1.00000000),
(2, 1000.00000000),
(5, 2.20460000),
(6, 35.27400000);


INSERT INTO `weight_class_description` (`weight_class_id`, `language_id`, `title`, `unit`) VALUES
(1, 1, 'Kilograms', 'kg'),
(2, 1, 'Grams', 'g'),
(1, 2, 'Kilogrammes', 'kg'),
(2, 2, 'Grammes', 'g'),
(5, 1, 'Pound ', 'lb'),
(5, 2, 'Livres ', 'lb'),
(6, 1, 'Ounce', 'oz'),
(6, 2, 'Once', 'oz');
I've try to change the settings like delete the french entries, but error still here.

I am stuck, I can't figure out the problem. Thanks for help
Last edited by i2Paq on Thu Mar 25, 2010 12:12 am, edited 1 time in total.
Reason: Topic moved

p4m
New member

Posts

Joined
Mon May 04, 2009 7:53 pm

Post by i2Paq » Thu Mar 25, 2010 12:12 am

Did you follow the step by step upgrade instructions provided in the Installation & Upgrade Support?

You know that there is no direct upgrade from 1.2.9 to 1.4.4?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by p4m » Thu Mar 25, 2010 7:02 am

Yes I have saved my Database, deleted it and using a database editor I have re-enter, table by table, my product info in the 1.4.4 database since it is sligthly different than the 1.2.9 one. Then I have copy the files from 1.4.4 upload folder over the 1.2.9 ones in my Opencart folder keeping my config files in admin and root. I ran the code indicated in upgrade.txt

Is there somrthing wrong in this process?? What do you suggest me to do to upgrade from 1.2.9 to 1.4.4, successive upgrade???

Thanks

p4m
New member

Posts

Joined
Mon May 04, 2009 7:53 pm

Post by i2Paq » Thu Mar 25, 2010 3:21 pm

It is missing the language_id column in, what it looks to me, the weight class.

If you ran the upgrade instructions than it should work.

Why not try it again?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by p4m » Thu Mar 25, 2010 9:30 pm

You was right, I just add the language _id in the create weight_class table and now it is working since in the OC1.29, the weight class contained this column and some product setting still refer to it. Thank for your help.

p4m
New member

Posts

Joined
Mon May 04, 2009 7:53 pm

Post by Qphoria » Thu Mar 25, 2010 9:36 pm

That isn't the solution. You are going to have lots of troubles. There is not supposed to be a language_id for weight_class anymore since it was moved to weight_class_description.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by p4m » Thu Mar 25, 2010 10:50 pm

Ok, I have done an install from scratch and will insert my data using "insert into" code.
Will let you know

thanks
Last edited by p4m on Fri Mar 26, 2010 7:49 am, edited 1 time in total.

p4m
New member

Posts

Joined
Mon May 04, 2009 7:53 pm
Who is online

Users browsing this forum: No registered users and 14 guests