Post by webreplicator » Tue Feb 14, 2023 2:49 pm

Hello,
I'm not sure if this is a bug, I performed a fresh install of opencart 4, and I was planning to buy a language pack. Following a video demo from the developer the instruction is to install via the Extension Installer. When I clicked the Installer Menu I get the follogin error:
Error: Undefined constant ZipArchive::RDONLY in /home/www/*****/admin/controller/marketplace/installer.php on line 93

I browsed to the Opencart documentation and it indicates to have the FTP credentials in the store settings. OpenCart V4 does not have the ftp function as indicated in the documentation.
Is anyone having the same issue? Any ideas on how to fix this?

Thanks in advance. Any help will be appreciated.

Newbie

Posts

Joined
Tue Feb 14, 2023 2:10 pm

Post by Johnathan » Tue Feb 14, 2023 10:11 pm

You don't need FTP info for OpenCart 3 or 4. The error you're seeing has to do with the PHP plugin ZipArchive, so you should ask your host whether that is installed on your server. That is needed for the installer to unzip .zip bundles when they are uploaded.

However, I would strongly advise against using OpenCart 4.0 for a live store. There are still some bugs in the latest version, including a major one where order information is displayed from the product's current data, instead of the data at the time the order was placed. Until that is fixed, I would recommend using 3.0.3.8 for new installations.

Image Image Image Image Image


User avatar
Administrator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by webreplicator » Wed Feb 15, 2023 3:43 am

I really appreciate the response.
This is my first time checking out Opencart. I have a few sites with Joomla and Wordpress both cms has no issue unzipping and installing zip archives. And I don't think there is anything missing on the host.
The issue is when I click on the menu Extensions=>Installer It does not load the upload form, it spits the error with a blank page. If the form would load, and in the process of an upload would cause an error then yeah, it could be a problem with the host.

Fort testing I installed v3.0.8.3 in this version the form loads properly. I haven't tried installing anything yet. Perhaps I will consider staying with v3 if I don't find a solution. I'm still exploring.


Thanks you all.

Newbie

Posts

Joined
Tue Feb 14, 2023 2:10 pm

Post by Johnathan » Wed Feb 15, 2023 10:19 pm

OpenCart 3.0 doesn't check for that RDONLY constant, which is probably why it works. This is what the PHP documentation says about that constant:

ZipArchive::RDONLY (int)
Open archive in read only mode. Available as of PHP 7.4.3 and PECL zip 1.17.1, respectively, if built against libzip ≥ 1.0.0.

I'm pretty sure means your PHP version is too low, or the ZipArchive installation isn't correctly (i.e. it's not built against libzip ≥ 1.0.0). Those are just guesses, though, so you'd have to ask your web host about those details.

Image Image Image Image Image


User avatar
Administrator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by hunti » Fri May 24, 2024 5:37 am

webreplicator wrote:
Wed Feb 15, 2023 3:43 am
I really appreciate the response.
This is my first time checking out Opencart. I have a few sites with Joomla and Wordpress both cms has no issue unzipping and installing zip archives. And I don't think there is anything missing on the host.
The issue is when I click on the menu Extensions=>Installer It does not load the upload form, it spits the error with a blank page. If the form would load, and in the process of an upload would cause an error then yeah, it could be a problem with the host.

Fort testing I installed v3.0.8.3 in this version the form loads properly. I haven't tried installing anything yet. Perhaps I will consider staying with v3 if I don't find a solution. I'm still exploring.


Thanks you all.
I have the same problem with error "Undefined constant ZipArchive::RDONLY". Did you find a solution?

Newbie

Posts

Joined
Sun Oct 21, 2018 8:58 pm
Who is online

Users browsing this forum: No registered users and 1 guest