Post by rfcomponents » Fri May 17, 2024 10:01 pm

First ever post on any forum so please bare with me.
4.0.2.3 deployment using bitnami was simple and worked fine for approx 2 months.
Installed Mega Filter Pack application but it never accepted activation key. ( Invalid Token Error )
Raised the issue with OC and not happy.
Live site is visible without issues.
Admin login will now not accept password, just flashes and restore back to same login page. ( URL is Correct )
A wrong Password is not indicated in login box if entered.
Forgotten password link ( from email ) will allow the confirmation password to be different to the first entered password without indicating error.
Not sure if this is related to the Mega Filter as it happened straight after trying to modify currency default to USA and then change a product price
because unless the base was USA, AUD does not use the right math.
Looked at all forums that pointed to old issues such as UTC, admin config and default files for cookie sessions, etc but nothing works.
Modding vm files with ssh key via windows SCP. Deployment seems fine on Google.
I suspect it maybe related to the MariaDB database being corrupted but as a newbie, I can honestly say I am stumped.

Newbie

Posts

Joined
Thu Mar 21, 2024 12:33 pm

Post by paulfeakins » Fri May 17, 2024 11:52 pm

At this point most developers still using 3.0.3.9 as the latest 4 needs to have some bugs ironed out still.

UK OpenCart Hosting | OpenCart Audits | OpenCart Support - please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - London Gatwick, United Kingdom

Post by rfcomponents » Sat May 18, 2024 8:14 am

Thank you Paul.
Appreciate your reply.
It appears there are many issues and not being a SW Guru its rather difficult to iron out.
I opted for the Bitnami solution to prevent the Google SQL billing me large amounts daily.
It would have made sense for them to use a stable release.
I am trying to keep all operations in my Google workplace rather than separate hosts so it looked
good at the time.
Maybe I need to manually deploy the earlier version and duplicate the SQL Config on Google.
Thanks again.

Newbie

Posts

Joined
Thu Mar 21, 2024 12:33 pm

Post by rfcomponents » Wed May 22, 2024 2:02 pm

Incase anyone else sees the same issue
Update, after finally getting access in to the Maria dB, I was getting errors suggesting multiple keys were causing issues in tables.
It got beyond my ability to fix the issue so I did the following :
-Backed up DB.
-Deleted the VM and Deployment from Google
- Installed new Bitnami / openccart 4.0.2.3 on Google.
- Changed the Password
- Logged in and out many times as admin into backend
- Setup API for marketplace ( no issues)
- Uploaded and Installed Mega Filter

- RESULT
MegaFilter required OC System settings for cookies to be chanced from STRICT to NONE to accept activation code
As soon as I did this and entered the activation code, I got kicked back to the Admin Panel advising Invalid Token.

- ADMIN ACCESS GONE
- No PW Errors Indicated
- Continuous Admin redirect back to Login Page

Newbie

Posts

Joined
Thu Mar 21, 2024 12:33 pm

Post by ADD Creative » Wed May 22, 2024 9:49 pm

Have you tried clearing your browser cache? Sound like the issue is caused be the extension you are trying to install.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by rfcomponents » Thu May 23, 2024 8:20 am

I apologize as this is my first time to play with SQL or Ddatabases so I had to learn as I go.
If the formatting is not correct for the forum please change as I have never offered any
advice on a forum before.

-How to Fix issue ( it was same site cookie = none issue )

You will be locked out of the database as root so do the following :
- FTP into site
- Go to /opt/bitnami/mariadb/conf
- Edit my.cnf
-under [mysqld]
add the following skip-grant-tables
close and save

- Restart Bitnami VM for opencart

Now you will be able to log into Database via an SSH Browser but bare in mind the VM instance will most likely have changed your IP address

-in SSH shell use the following commands

Sudo –i
mysql –u root –p ( then enter password )
use database bitnami_opencart ( if this is the database name you are using )

select * from oc_setting (to check config_setting_samesite key is id 342)
if it is the same id : ( Or change to match the ID in the table )

update oc_setting
set value = 'Strict'
where setting_id = 342;

The next steps were just based on other reading and the alter user didn’t seem to work but I tried anyway

flush privileges;
ALTER USER 'root'@'localhost' IDENTIFIED BY 'NewPassword';
( if you get an error just ignore, I guess it cannot be altered when running as root)

Go back to /opt/bitnami/mariadb/conf
- Edit my.cnf
under [mysqld]
remove skip-grant-tables

Restart the VM and again your IP address would have changed

Now you should be able to log in.

Newbie

Posts

Joined
Thu Mar 21, 2024 12:33 pm
Who is online

Users browsing this forum: No registered users and 1 guest