Post by DoctorQ » Wed May 15, 2024 6:56 pm

Hello,
after installing the clean version of opencart 4.0.2.3, I cannot upload any photos and cannot create new folders. Each time a message appears:

"Warning: Directory does not exist!"

screen.png

screen.png (21.57 KiB) Viewed 317 times

In the image manager, I can see the demo folder and file names, but the image thumbnails are not displayed.
I tried changing the folder attributes to 777 but it didn't help.
The links to the folders are correct.
Any ideas?
Last edited by DoctorQ on Thu May 16, 2024 5:01 am, edited 1 time in total.

New member

Posts

Joined
Tue Oct 27, 2009 3:08 pm

Post by paulfeakins » Wed May 15, 2024 7:33 pm

DoctorQ wrote:
Wed May 15, 2024 6:56 pm
after installing the clean version of opencart 4.0.2.3
At this point I'd recommend using 3.0.3.9.

DoctorQ wrote:
Wed May 15, 2024 6:56 pm
I tried changing the folder attributes to 777 but it didn't help.
Don't do that. Folders should be 755, files should be 644.

UK OpenCart Hosting | OpenCart Audits | OpenCart Support - please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - London Gatwick, United Kingdom

Post by DoctorQ » Thu May 16, 2024 12:11 am

Thank you very much for your help.
In fact, reinstalling to a lower version helped, but I also had to downgrade the php interpreter from 8.3 to 7.4 and now everything works.
It's a pity that I didn't check it with the OC 4 version.
Maybe this was because the PHP interpreter was too high?

Anyway, thank you, I'm staying on the older version.
Have a nice day!

New member

Posts

Joined
Tue Oct 27, 2009 3:08 pm

Post by straightlight » Thu May 16, 2024 2:34 am

DoctorQ wrote:
Thu May 16, 2024 12:11 am
Thank you very much for your help.
In fact, reinstalling to a lower version helped, but I also had to downgrade the php interpreter from 8.3 to 7.4 and now everything works.
It's a pity that I didn't check it with the OC 4 version.
Maybe this was because the PHP interpreter was too high?

Anyway, thank you, I'm staying on the older version.
Have a nice day!
The PHP minimum requirements for OC v4.x releases is 7.4. Now that the issue has been solved, please add: [SOLVED] at the beginning of the subject line on your first post.

Dedication and passion goes to those who are able to push and merge a project.

Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: o3445, redactuk and 4 guests