Post by JNeuhoff » Wed Sep 20, 2023 5:31 am

samkung wrote:
Tue Sep 19, 2023 5:01 pm
About Export/Import Tool extension, i am using opencart 2.3.02

After i installed this extension, every single product got error 500:
Undefined index: product_id in /home/xxx/library/cart/cart.php on line 556

my Error.log say:
[19-Sep-2023 11:54:43 Asia/Hong_Kong] PHP Parse error: syntax error, unexpected '??' (T_COALESCE), expecting end of file in /home/dbbeingc/public_html/dummy/system/storage/modification/catalog/view/theme/journal3/template/product/product.tpl on line 199


Domain:https://dummy.db-being.com/index.php?ro ... ct_id=2271


Even i disable/remove the extension. now, i can see the product page on my store.

Also, when i try to export product, the system want me to click the box: Use filter_id instead of filter name in worksheets 'ProductFilters' and 'CategoryFilters' for export file. however, after i clicked the box, it can not be unclick!

Please tell me how to fix this, my site can not work.
Make sure to use unique names for your filters. And use OpenCart, not the Journal3 framework. Check your database to see that the product actually exists, and that it is accessible via the admin backend at Catalog > Products

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by attiliok » Wed Sep 20, 2023 5:36 pm

Hi, anyone can provide instruction for MANUAL INSTALL on OC4?
I can't install by installer.

Thanks in advance!

Newbie

Posts

Joined
Wed Apr 10, 2019 4:16 pm

Post by ASG » Fri Sep 22, 2023 10:08 pm

JNeuhoff wrote:
Wed Sep 20, 2023 4:54 am
I am not able to reproduce your installation problem. Can you provide more details? PHP version? OpenCart version? Web browser used?
PHP 8.2.4, Opencart 4.0.2.1
Firefox, Vivaldi, Safari.

I have gone as far as uninstalling XAMPP and reinstalling it, just to be sure. Pls check the attachments for better clarity on the issue.

Attachments

Screenshot 2023-09-22 at 7.27.26 PM.png

Comparison between XAMPP directory(upper half) and extracted export_import.ocmod(lower half). This is after installing. The system/library/export_import/ directory is missing in XAMPP after install. - Screenshot 2023-09-22 at 7.27.26 PM.png (233.22 KiB) Viewed 9422 times

Screenshot 2023-09-22 at 7.26.01 PM.png

Error after trying to install. - Screenshot 2023-09-22 at 7.26.01 PM.png (32.41 KiB) Viewed 9422 times


ASG
Active Member

Posts

Joined
Tue Sep 30, 2014 11:03 pm

Post by JNeuhoff » Sat Sep 23, 2023 12:09 am

You may have to copy the missing files manually over to your OC 4.0.2.1.

BTW.: Use OC 4.0.2.3, there has been a number of bugfixes in OpenCart itself.

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by ASG » Sat Sep 23, 2023 12:58 am

JNeuhoff wrote:
Sat Sep 23, 2023 12:09 am
You may have to copy the missing files manually over to your OC 4.0.2.1.
Did that. Getting the same error: Error: Class "PhpOffice\PhpSpreadsheet\Spreadsheet" not found in /Applications/XAMPP/xamppfiles/htdocs/oc4/extension/export_import/admin/model/tool/export_import.php on line 5666

ASG
Active Member

Posts

Joined
Tue Sep 30, 2014 11:03 pm

Post by cagatay117 » Wed Sep 27, 2023 9:04 pm

I just wanted to update one property of one product. Exported the products to use as a template, deleted all rows but one. Changed the property I wanted (seo keyword), deleted the description cells (this was important because my descriptions are so long that Excel cannot store all of them in a cell, it was more than 45.000 characters if I am not mistaken). Saved the file, selected `yes` for `use incremental import` and uploaded the file to the extension.

In the end, my description disappeared from the product. When I checked it, I saw that extension calls deleteProduct() function in uploadProducts() function. This seems fine considering the user would fill every detail in the template and it won't create any problem. But in my situation, it was a problem. Why don't you give the option to update only the items the user wants without actually deleting the product completely?

You may think this problem merits custom extension update and needs to be charged. But doesn't `update` means updating some of the details and not touching the others, @JNeuhoff ? By the way, thank you for this useful extension, I am grateful.

User avatar
Newbie

Posts

Joined
Mon Aug 15, 2022 11:06 pm

Post by v-v » Wed Nov 29, 2023 12:41 am

Hi, after years of using I am getting now error message "Trying to access array offset on value of type int " when trying to export - help will be realy appreciated.

I dont know since this appears - may be after change of PHP server.

Running still on 2.2.0, PHP 7.4.33

Thank you for help.
Last edited by v-v on Wed Nov 29, 2023 1:00 am, edited 1 time in total.

v-v
Active Member

Posts

Joined
Wed Jun 16, 2010 10:09 pm

Post by Cue4cheap » Wed Nov 29, 2023 12:55 am

v-v wrote:
Wed Nov 29, 2023 12:41 am
Hi, after years of using I am getting now error message "Trying to access array offset on value of type int " when trying to export - help will be realy appreciated.

I dont know since this appears - may be after change of PHP server.

Running still on 2.2.0

Thank you for help.
Probably moved to PHP 8.x. If that is the case I'd suspect a lot of other things are erroring out too.
Mike

cue4cheap not cheap quality


Expert Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by v-v » Wed Nov 29, 2023 1:24 am

Hi, first, I moved to PHP 8, but as you told, after various errors i went back to php 7.4.33. It works fine, but now i explored problem with export and i am not sure if its relay this moving ... previously it run even on lower php server.

v-v
Active Member

Posts

Joined
Wed Jun 16, 2010 10:09 pm

Post by JNeuhoff » Wed Nov 29, 2023 1:31 am

You could try the opencart-2-x-export-import-multilingual-4-17.ocmod.zip extension which supports newer PHP versions.

However, OpenCart 2.2.0.x versions in general don't support PHP 7.4 or 8.x versions. Hence you should think about upgrading to a newer OpenCart version, e.g. 3.0.3.9 or 3.0.x.x (4.0.x.x versions are still too unstable for live sites).

In the meantime, ask your webhost to set back your PHP version to 7.3.

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by v-v » Wed Nov 29, 2023 1:55 am

JNeuhoff wrote:
Wed Nov 29, 2023 1:31 am
You could try the opencart-2-x-export-import-multilingual-4-17.ocmod.zip extension which supports newer PHP versions.

However, OpenCart 2.2.0.x versions in general don't support PHP 7.4 or 8.x versions. Hence you should think about upgrading to a newer OpenCart version, e.g. 3.0.3.9 or 3.0.x.x (4.0.x.x versions are still too unstable for live sites).

In the meantime, ask your webhost to set back your PHP version to 7.3.
Thank you, hosting provider told me it is not possible to go back for 7.3 :-/ So one of option is some kin d of custom / commercial debug - can it be solution?
Of course, I will try suggested verison also.

v-v
Active Member

Posts

Joined
Wed Jun 16, 2010 10:09 pm

Post by xxvirusxx » Wed Nov 29, 2023 2:07 am

You want to upgrade to 3.0.3.9?

Upgrade Service | OC 2.3.0.2 PHP 8 | My Custom OC 3.0.3.8 | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by v-v » Wed Nov 29, 2023 2:33 am

xxvirusxx wrote:
Wed Nov 29, 2023 2:07 am
You want to upgrade to 3.0.3.9?
No, I have arranged update to latest OC version next year, now i need just debug / fix the export / import tool.

v-v
Active Member

Posts

Joined
Wed Jun 16, 2010 10:09 pm

Post by v-v » Wed Nov 29, 2023 6:44 pm

So, installing last extension version was a solution, thank you all for help! Have a great days!

v-v
Active Member

Posts

Joined
Wed Jun 16, 2010 10:09 pm

Post by Mosstyn » Wed Jan 03, 2024 8:08 pm

Hi,
Using OC 3.0.3.8
I have an issue with a custom product field. Every time I do a product import, the contents of this custom field get wiped. I have about 2000 products, and this is becoming a bit of an issue. I don't necessarily need to import/export this field, but I could do with it not being cleared. Is there an easy fix? Or are we looking at a custom version?

New member

Posts

Joined
Tue Aug 01, 2017 7:02 am

User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by k2tec » Fri Apr 26, 2024 4:49 pm

Hi, I have 3.0.3.8 but modified it to PHP 8.2. Which version of your module is best to use.

Found it I took the cloudversion works great

User avatar
Active Member

Posts

Joined
Mon Apr 12, 2010 8:06 pm

Post by mariosp » Sun May 19, 2024 10:55 pm

I'm getting this error:

Error: Unknown column 'pt.tag' in 'field list'
Error No: 1054
SELECT p.product_id, GROUP_CONCAT(pt.tag SEPARATOR ",") AS tag, pd.* FROM `oc_product` p LEFT JOIN `oc_product_description` pd ON pd.product_id=p.product_id AND pd.language_id='2' LEFT JOIN `oc_product_tag` pt ON pt.product_id=p.product_id AND pt.language_id='2' GROUP BY p.product_id ORDER BY p.product_id ;

this is on product export
All other exports (categories, option, attribute, filter, customers) works fine

Newbie

Posts

Joined
Mon May 14, 2018 9:41 pm

Post by JNeuhoff » Mon May 20, 2024 5:04 pm

mariosp wrote:
Sun May 19, 2024 10:55 pm
I'm getting this error:

Error: Unknown column 'pt.tag' in 'field list'
Error No: 1054
SELECT p.product_id, GROUP_CONCAT(pt.tag SEPARATOR ",") AS tag, pd.* FROM `oc_product` p LEFT JOIN `oc_product_description` pd ON pd.product_id=p.product_id AND pd.language_id='2' LEFT JOIN `oc_product_tag` pt ON pt.product_id=p.product_id AND pt.language_id='2' GROUP BY p.product_id ORDER BY p.product_id ;

this is on product export
All other exports (categories, option, attribute, filter, customers) works fine
Without further details, we won't be able to help you here. The 'oc_product_tag' table hasn't been used since OC 1.5.4 or later and shouldn't be there if using a later OC version.

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by mariosp » Tue May 21, 2024 12:14 am

This is weird, because I am using version 3.0.3.8

Newbie

Posts

Joined
Mon May 14, 2018 9:41 pm
Who is online

Users browsing this forum: No registered users and 1 guest