Post by ADD Creative » Sat Mar 25, 2023 8:47 pm

sandstorm001 wrote:
Sat Mar 25, 2023 5:42 am
So, this 3.0.x.x maintenance branch is always the 3.0.3.8 bug fix/update branch, kinda like an unofficial stable release git branch which I can rely to work on the 3.0.3.8 version?
3.0.x.x maintenance is the most stable version with only PHP compatibility and bug fixes. What OpenCart's plans for it in the future, I have no idea.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by dropaway » Tue Nov 28, 2023 3:55 pm

Is it possible to upgrade an existing site with 3.0.3.8, or does it have to be a fresh install? I have a big problem with sending emails from 3.0.3.8 and PHP 8, has anyone found a partial solution without switching the 3.0.x.x_Maintenance branch? I tried many things but no success...

Newbie

Posts

Joined
Sat Mar 01, 2014 2:31 am

Post by xxvirusxx » Tue Nov 28, 2023 4:59 pm

dropaway wrote:
Tue Nov 28, 2023 3:55 pm
Is it possible to upgrade an existing site with 3.0.3.8, or does it have to be a fresh install?
Yes, add the fixes from 3.0.x.x_Maintenance branch in 3.0.3.8....

https://github.com/opencart/opencart/re ... ag/3.0.3.9

Upgrade Service | OC 2.3.0.2 PHP 8 | My Custom OC 3.0.3.8 | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by dropaway » Tue Nov 28, 2023 5:15 pm

xxvirusxx wrote:
Tue Nov 28, 2023 4:59 pm
dropaway wrote:
Tue Nov 28, 2023 3:55 pm
Is it possible to upgrade an existing site with 3.0.3.8, or does it have to be a fresh install?
Yes, add the fixes from 3.0.x.x_Maintenance branch in 3.0.3.8....

https://github.com/opencart/opencart/re ... ag/3.0.3.9
Is it safe?

Newbie

Posts

Joined
Sat Mar 01, 2014 2:31 am

User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by dropaway » Tue Nov 28, 2023 5:19 pm

For extensions, or are they compatible with 3.0.3.9?

Newbie

Posts

Joined
Sat Mar 01, 2014 2:31 am

Post by xxvirusxx » Tue Nov 28, 2023 5:22 pm

95% will work without issue on 3.0.3.9

Upgrade Service | OC 2.3.0.2 PHP 8 | My Custom OC 3.0.3.8 | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by JNeuhoff » Tue Nov 28, 2023 5:56 pm

dropaway wrote:
Tue Nov 28, 2023 5:19 pm
For extensions, or are they compatible with 3.0.3.9?
Yes, for most of them, see also this forum post.

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by dropaway » Tue Nov 28, 2023 6:33 pm

The reason I want to upgrade my OpenCart (3.0.3-8) is to support PHP version 8 and not send order emails to site admins. It's interesting that customers get them. I got the support to downgrade the PHP version to 7.4 and now they don't work again, very strange... I try through PHP mail and smtp, it's the same.... I'm starting to think it's not from the PHP version 8.0.30

Newbie

Posts

Joined
Sat Mar 01, 2014 2:31 am

Post by JNeuhoff » Tue Nov 28, 2023 7:20 pm

dropaway wrote:
Tue Nov 28, 2023 6:33 pm
The reason I want to upgrade my OpenCart (3.0.3-8) is to support PHP version 8 and not send order emails to site admins.
You should change your settings at System > Settings > edit Store > tab Mail > Mail Alters for this.

As regards your SMTP settings: That's a separate issue, if you want help here you have to provide more details and check the error logs.

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by paulfeakins » Tue Nov 28, 2023 10:55 pm

sandstorm001 wrote:
Sat Mar 25, 2023 5:42 am
So, this 3.0.x.x maintenance branch is always the 3.0.3.8 bug fix/update branch, kinda like an unofficial stable release git branch which I can rely to work on the 3.0.3.8 version?
Nope, there is an official 3.0.3.9 now so you should use that.

UK OpenCart Hosting | OpenCart Audits | OpenCart Support - please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - London Gatwick, United Kingdom

Post by dropaway » Wed Nov 29, 2023 3:11 pm

JNeuhoff wrote:
Tue Nov 28, 2023 7:20 pm
dropaway wrote:
Tue Nov 28, 2023 6:33 pm
The reason I want to upgrade my OpenCart (3.0.3-8) is to support PHP version 8 and not send order emails to site admins.
You should change your settings at System > Settings > edit Store > tab Mail > Mail Alters for this.

As regards your SMTP settings: That's a separate issue, if you want help here you have to provide more details and check the error logs.
Yes, i know. The interesting thing is that there is no error recorded in the error.log related to the e-mails. The customers get order emails but not the admins...

Newbie

Posts

Joined
Sat Mar 01, 2014 2:31 am

Post by xxvirusxx » Wed Nov 29, 2023 4:18 pm

Maybe are in Spam....

Upgrade Service | OC 2.3.0.2 PHP 8 | My Custom OC 3.0.3.8 | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by rohansaadat2 » Wed Nov 29, 2023 8:04 pm

As per my knowledge OpenCart 3.0.3.8 is not fully compatible with PHP 8.1. However, it's crucial to check the official OpenCart website or community forums for any updates or patches that may have been released since then. Developers often release compatibility updates to ensure their software works seamlessly with the latest PHP versions.

Newbie

Posts

Joined
Wed Nov 29, 2023 7:50 pm

Post by dropaway » Thu Nov 30, 2023 12:27 am

xxvirusxx wrote:
Wed Nov 29, 2023 4:18 pm
Maybe are in Spam....
No, the problem is from modification which use mails, i disable it and now work.

Newbie

Posts

Joined
Sat Mar 01, 2014 2:31 am
Who is online

Users browsing this forum: Gobbo and 25 guests