Post by sayimcrafts » Fri Nov 17, 2023 2:15 pm

When registering new account, confirmation email is sent. But while placing orders customers dont receive any email. i am using PHP Mail. I tired using stock theme still wont work. i also get this email
A message that you sent was rejected by the local scanning code that
checks incoming messages on this system. The following error was given:

This message was classified as SPAM and may not be delivered

------ This is a copy of your message, including all the headers. ------

Please guide

Newbie

Posts

Joined
Fri Dec 30, 2022 4:54 pm

Post by paulfeakins » Fri Nov 17, 2023 8:15 pm

sayimcrafts wrote:
Fri Nov 17, 2023 2:15 pm
Please guide
Have you searched this forum? There's loads about this ...

UK OpenCart Hosting | OpenCart Audits | OpenCart Support - please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - London Gatwick, United Kingdom

Post by JNeuhoff » Fri Nov 17, 2023 8:31 pm

First of all, use OpenCart 4.0.2.3, or better, 3.0.3.9, because OpenCart 4 is still subject to a lot of bugfixes and development.

As regards email: Configure it to using the STMP.

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by agenziarc@yahoo.com » Wed Nov 22, 2023 10:17 pm

I have a problem too. I saw that the mail arrives at the store box, but does not reach the customer. Who helps me? Vers. 4.0.2.3

New member

Posts

Joined
Sun Jan 02, 2022 10:40 pm

Post by ADD Creative » Wed Nov 22, 2023 11:42 pm

Try using an online email deliverability checker to check the emails you send out don't look like spam.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by agenziarc@yahoo.com » Thu Nov 23, 2023 6:34 am

Same email with version 3.0.3.8 works with version 4.0.2.3 doesn't work.

New member

Posts

Joined
Sun Jan 02, 2022 10:40 pm

Post by ADD Creative » Thu Nov 23, 2023 5:06 pm

agenziarc@yahoo.com wrote:
Thu Nov 23, 2023 6:34 am
Same email with version 3.0.3.8 works with version 4.0.2.3 doesn't work.
So best to use an online email deliverability checker on both sites to see if there is a difference.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by agenziarc@yahoo.com » Fri Nov 24, 2023 3:33 pm

In version 3.0.3.8 the email works and is sent. In version 4.0.2.3 it doesn't work, it isn't sent.
Email is the same with the same parameters.

New member

Posts

Joined
Sun Jan 02, 2022 10:40 pm

Post by xxvirusxx » Fri Nov 24, 2023 4:05 pm

Tested using Mail, and order email is sent...

Upgrade Service | OC 2.3.0.2 PHP 8 | My Custom OC 3.0.3.8 | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by ADD Creative » Fri Nov 24, 2023 5:04 pm

agenziarc@yahoo.com wrote:
Fri Nov 24, 2023 3:33 pm
In version 3.0.3.8 the email works and is sent. In version 4.0.2.3 it doesn't work, it isn't sent.
Email is the same with the same parameters.
Goto Extensions -> Events and check you have mail_order_add and mail_order_alert enabled. Check both your OpenCart and PHP error logs. Check the mail server logs to see if the email reached that stage. In cPanel you can use Track Delivery.

Try setting SMTP as the Mail Engine in the OpenCart Mail settings.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by agenziarc@yahoo.com » Fri Nov 24, 2023 7:07 pm

xxvirusxx wrote:
Fri Nov 24, 2023 4:05 pm
Tested using Mail, and order email is sent...
it is not sent to the customer. using email it is not sent there either.

New member

Posts

Joined
Sun Jan 02, 2022 10:40 pm

Post by xxvirusxx » Sat Nov 25, 2023 1:09 am

I said...

I have tested 4.0.2.3 and customer received email..

Upgrade Service | OC 2.3.0.2 PHP 8 | My Custom OC 3.0.3.8 | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by JNeuhoff » Sat Nov 25, 2023 1:34 am

agenziarc@yahoo.com wrote:
Fri Nov 24, 2023 7:07 pm
it is not sent to the customer. using email it is not sent there either.
So why don't you check it with an online email deliverability checker first, to see what's happening?

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by agenziarc@yahoo.com » Sat Nov 25, 2023 5:20 pm

Because, the same email in version 3038 works. In version 4023 it doesn't work. So it's a problem I have in version 4023. I don't know what it could be? What file can I restore to see if it works?

New member

Posts

Joined
Sun Jan 02, 2022 10:40 pm

Post by agenziarc@yahoo.com » Sat Nov 25, 2023 5:47 pm

Resolved. I had set the store email different from the one entered in SMTP. It works now (SOLVED)

New member

Posts

Joined
Sun Jan 02, 2022 10:40 pm

Post by paulfeakins » Mon Nov 27, 2023 10:39 pm

agenziarc@yahoo.com wrote:
Sat Nov 25, 2023 5:47 pm
Resolved. I had set the store email different from the one entered in SMTP. It works now (SOLVED)
Please add [SOLVED] to the start of the post title.

UK OpenCart Hosting | OpenCart Audits | OpenCart Support - please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - London Gatwick, United Kingdom
Who is online

Users browsing this forum: No registered users and 3 guests