Post by YarniaPDX » Fri Nov 17, 2023 11:33 pm

When trying to check out as a user on my site (customyarn.com), I'm getting the following error message on Step 4 (delivery method). Can anyone tell me what this error message means and how to fix it?

Thanks,
- Lindsey

Active Member

Posts

Joined
Sat Sep 04, 2010 7:10 am

Post by ADD Creative » Sat Nov 18, 2023 12:21 am

I think you post is missing the error message. Posting you OpenCart and PHP version would also be helpful.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by YarniaPDX » Sat Nov 18, 2023 9:33 am

Oh my goodness, so sorry. Screenshot of the error message is attached here. I'm running OC v.3.0.3.2. I'm not sure how to find out which PHP version I'm running but can look it up if you can let me know where!

Thanks,
- Lindsey
ADD Creative wrote:
Sat Nov 18, 2023 12:21 am
I think you post is missing the error message. Posting you OpenCart and PHP version would also be helpful.

Attachments

Screenshot (283).png

Screenshot (283).png (277.25 KiB) Viewed 580 times


Active Member

Posts

Joined
Sat Sep 04, 2010 7:10 am

Post by xxvirusxx » Sat Nov 18, 2023 4:21 pm

Disable that ocmod extension and will work.

Upgrade Service | OC 2.3.0.2 PHP 8 | My Custom OC 3.0.3.8 | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by SohBH » Sat Nov 18, 2023 4:38 pm

Check and correct the class name for getQuote

Business Web Development | Content Creation | Analytics and Reporting | SEO


User avatar
Active Member

Posts

Joined
Mon Nov 02, 2020 12:01 am
Location - Malaysia

Post by YarniaPDX » Sun Nov 19, 2023 8:50 am

Can you be specific about which extension I need to disable? Not sure how to determine that from the error message.
xxvirusxx wrote:
Sat Nov 18, 2023 4:21 pm
Disable that ocmod extension and will work.

Active Member

Posts

Joined
Sat Sep 04, 2010 7:10 am

Post by xxvirusxx » Sun Nov 19, 2023 5:34 pm

YarniaPDX wrote:
Sun Nov 19, 2023 8:50 am
Not sure how to determine that from the error message.
/storage/modification/

Upgrade Service | OC 2.3.0.2 PHP 8 | My Custom OC 3.0.3.8 | Buy me a beer


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by paulfeakins » Mon Nov 20, 2023 7:25 pm

YarniaPDX wrote:
Sun Nov 19, 2023 8:50 am
Can you be specific about which extension I need to disable?
If you don't know which one, disable them one by one until the error goes.

UK OpenCart Hosting | OpenCart Audits | OpenCart Support - please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - London Gatwick, United Kingdom

Post by YarniaPDX » Tue Nov 21, 2023 4:43 am

I'm actually not able to even do that; when I go to Extensions and click Shipping, I get this error message before it even displays the list of extensions (see attached). Is it possible one of the core files that relates to shipping has been damaged? Can anyone attach the correct file so I can replace it and hopefully get this error to go away?
paulfeakins wrote:
Mon Nov 20, 2023 7:25 pm
YarniaPDX wrote:
Sun Nov 19, 2023 8:50 am
Can you be specific about which extension I need to disable?
If you don't know which one, disable them one by one until the error goes.

Active Member

Posts

Joined
Sat Sep 04, 2010 7:10 am

User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by paulfeakins » Tue Nov 21, 2023 11:56 pm

xxvirusxx wrote:
Tue Nov 21, 2023 7:38 am
https://www.opencart.com/index.php?rout ... ad/history

Or pay a developer
Yep, sounds like a developer or agency is needed on hand for issues like this.

UK OpenCart Hosting | OpenCart Audits | OpenCart Support - please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - London Gatwick, United Kingdom
Who is online

Users browsing this forum: No registered users and 26 guests