Post by purplesage » Sun Apr 23, 2023 3:43 am

Ok, thanks to all who replied. Not sure what "fixed" things but was able to re-install the version from the website Marketplace and have it work.
One thing to note is that the 4.13 version visited by the Admin panel Marketplace does not work.

Newbie

Posts

Joined
Sun Apr 02, 2023 9:27 am

Post by fangete » Fri May 05, 2023 9:52 pm

I've did like in manual:
1. Upload
2. Refreshed modification
3. Add right to group administrator
Menu item have been appeared, but front doesn't work:

Notice: Undefined offset: 1 in ****/storage/modification/catalog/controller/common/footer.php on line 244Notice: Undefined offset: 2 in ****/domains/storage/modification/catalog/controller/common/footer.php on line 244
Fatal error: Uncaught Exception: Error: Could not load template ****/domains/garry-miller.ru/catalog/view/theme/default/template/extension/module/callback.twig! in ****/domains/storage/modification/system/library/template/twig.php:21 Stack trace: #0 ****/domains/garry-miller.ru/system/library/template.php(51): Template\Twig->render('default/templat...', '') #1 ****/domains/storage/modification/system/engine/loader.php(125): Template->render('default/templat...', '') #2 ****/domains/garry-miller.ru/catalog/controller/extension/module/callback.php(81): Loader->view('extension/modul...', Array) #3****/domains/storage/modification/system/engine/action.php(79): ControllerExtensionModuleCallback->index(Array) #4 /****/domains/storage/modification/system/engine/loader.php(48): Action->execute(Object(Registry), Array) #5 ****/domains/storage/modification/catalog/controller/common/ in ****/domains/storage/modification/system/library/template/twig.php on line 21

PHP 7.4
Version of import/export: opencart-3-x-export-import-multilingual-4-13-cloud.ocmod

Newbie

Posts

Joined
Fri May 05, 2023 4:48 pm

Post by JNeuhoff » Wed May 10, 2023 7:49 pm

@fangete : Your frontend problem has nothing to do with the Export/Import tool. Rather, it's an issue likely caused by another extension which includes the catalog/controller/extension/module/callback.php . You need to contact the author of that extension module for help.

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by mazman » Mon May 22, 2023 5:26 am

I've installed the MOD per the instructions. I can access it via the Maintenance Menu. When I click the Export button it brings me to the error page: "This page isn't working...unable to handle this request. HTTP error 500"
I've refreshed and set access and modification permissions.
I've deleted, re-downloaded, and re-installed with the same results.
I tried exporting products (about 150) also tried exporting categories (only 5) so its not that there are too many items to export.
Running version 3.0.3.8. PHP version 8.1
Would appreciate any help. Thanks!

New member

Posts

Joined
Sun Apr 03, 2022 5:20 am

Post by Cue4cheap » Mon May 22, 2023 6:21 am

mazman wrote:
Mon May 22, 2023 5:26 am
I've installed the MOD per the instructions. I can access it via the Maintenance Menu. When I click the Export button it brings me to the error page: "This page isn't working...unable to handle this request. HTTP error 500"
I've refreshed and set access and modification permissions.
I've deleted, re-downloaded, and re-installed with the same results.
I tried exporting products (about 150) also tried exporting categories (only 5) so its not that there are too many items to export.
Running version 3.0.3.8. PHP version 8.1
Would appreciate any help. Thanks!
What does your server error logs say?
Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by mazman » Mon May 22, 2023 8:00 pm

Cue4cheap wrote:
Mon May 22, 2023 6:21 am


What does your server error logs say?
Mike
The error logs for today (and yesterday) from my site do not contain any entries. They are blank .
Error logs from MYSQL database are not available to me.
From the hosting company: "Unfortunately, logs are not available on Shared MySQL servers. This means that even technical support would be unable to retrieve them for you."

New member

Posts

Joined
Sun Apr 03, 2022 5:20 am

Post by JNeuhoff » Mon May 22, 2023 9:37 pm

This is a lame webhost, find another one!

In the meantime, try this in your .htaccess

Code: Select all

php_flag display_errors On
php_value error_reporting E_ALL
Or this in your .user.ini :

Code: Select all

display_errors = On
error_reporting = E_ALL
Only keep it there for a short moment while you are trying the Export again.

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by mazman » Tue May 23, 2023 3:44 am

JNeuhoff wrote:
Mon May 22, 2023 9:37 pm
This is a lame webhost, find another one!

In the meantime, try this in your .htaccess

Code: Select all

php_flag display_errors On
php_value error_reporting E_ALL
Or this in your .user.ini :

Code: Select all

display_errors = On
error_reporting = E_ALL
Only keep it there for a short moment while you are trying the Export again.
I altered the .htaccess file as you suggested and it did not generate any errors in the error log. (there were 2 .htaccess files, one in the main directory and another in the system folder...I tried them both individually)
I can't seem to find a 'user.ini' file

New member

Posts

Joined
Sun Apr 03, 2022 5:20 am

Post by JNeuhoff » Tue May 23, 2023 5:05 pm

If this doesn't work: https://stackoverflow.com/questions/540 ... ect=1&lq=1

Then it is time to contact your webhost again, and if they still refuse to help here, ditch them, and find another webhost!

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Jaap » Tue Jun 27, 2023 10:36 pm

Mister Neuhoff, please advice

OC 4.0.2.1
clean install
export_import.ocmod.zip 4.0.0.0, 4.0.1.0, 4.0.1.1, 4.0.2.0, 4.0.2.1

When downloading products I receive a 500 error.

2023-06-27 07:54:02 - Twig\Error\LoaderError: There are no registered paths for namespace "fg".
File: /home/u28621p37274/ocartdata/storage/vendor/twig/twig/src/Loader/FilesystemLoader.php
Line: 204

2023-06-27 08:05:09 - PHP Warning: require(/home/u28621p37274/domains/domain/public_html/shop/extension/export_import/system/library/export_import/vendor/composer/../symfony/polyfill-mbstring/bootstrap.php): Failed to open stream: No such file or directory in /home/u28621p37274/domains/domain/public_html/shop/extension/export_import/system/library/export_import/vendor/composer/autoload_real.php on line 55
2023-06-27 08:05:09 - Error: Failed opening required '/home/u28621p37274/domains/domain/public_html/shop/extension/export_import/system/library/export_import/vendor/composer/../symfony/polyfill-mbstring/bootstrap.php' (include_path='.:/opt/alt/php80/usr/share/pear:/opt/alt/php80/usr/share/php:/usr/share/pear:/usr/share/php')
File: /home/u28621p37274/domains/domain/public_html/shop/extension/export_import/system/library/export_import/vendor/composer/autoload_real.php
Line: 55

User avatar
Active Member

Posts

Joined
Fri Apr 15, 2011 12:10 am
Location - the Netherlands

Post by JNeuhoff » Tue Jun 27, 2023 11:40 pm

Check for the existence of file '/home/u28621p37274/domains/domain/public_html/shop/extension/export_import/system/library/export_import/vendor/symfony/polyfill-mbstring/bootstrap.php' via the cPanel's file manager or via FTP. You probably didn't do a proper installation.

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by ASG » Wed Jul 05, 2023 2:57 pm

Getting the following errors while importing on a new OC4.0.2.1 install.

PHP v8.2.4.

Code: Select all

2023-07-05 12:24:21 - PHP Unknown:  Using ${var} in strings is deprecated, use {$var} instead in /Applications/XAMPP/xamppfiles/htdocs/oc4/extension/export_import/system/library/export_import/vendor/phpoffice/phpspreadsheet/src/PhpSpreadsheet/Reader/Xlsx.php on line 408
2023-07-05 12:24:21 - Export/Import: Invalid header in the Categories worksheet

ASG
Active Member

Posts

Joined
Tue Sep 30, 2014 11:03 pm

Post by JNeuhoff » Wed Jul 05, 2023 5:46 pm

ASG wrote:
Wed Jul 05, 2023 2:57 pm
Getting the following errors while importing on a new OC4.0.2.1 install.

PHP v8.2.4.

Code: Select all

2023-07-05 12:24:21 - PHP Unknown:  Using ${var} in strings is deprecated, use {$var} instead in /Applications/XAMPP/xamppfiles/htdocs/oc4/extension/export_import/system/library/export_import/vendor/phpoffice/phpspreadsheet/src/PhpSpreadsheet/Reader/Xlsx.php on line 408
2023-07-05 12:24:21 - Export/Import: Invalid header in the Categories worksheet
I have now upgraded the phpoffice/phpspreadsheet package via composer to its latest version 1.29, that should solve your PHP Unknown error.

Use the latest Version 4.15 of the Export/Import tool which uses this upgraded library. You can also get it from our website at https://www.mhccorp.com/opencart/free-i ... t-import-4

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Frekey » Sat Aug 05, 2023 3:13 am

Hi,

I'm new in opencart and have installed this great extension.
I have only 1 problem.

Version of Export/Import Tool 4.16
Version of OpenCart 4.0.2.2
Version of PHP 8.2.3

When importing a file i received next error:
Export/Import: Keyword 'Htc-touch-hd' used more than once for store_id '0' in worksheet 'ProductSEOKeywords'!

Our opencart is installed in multi-language (EN, DE, ...)

The error only appear when using the same keyword by each language.
keyword(de-de) = Htc-touch-hd and keyword(en-gb) = Htc-touch-hd
When using different keywords the problem is solved.
keyword(de-de) = Htc-touch-hd-de and keyword(en-gb) = Htc-touch-hd
For some of our products the keyword must be the same.

How can this been resolved?

Many thanks

Newbie

Posts

Joined
Wed Jul 12, 2023 12:11 am

Post by JNeuhoff » Sun Aug 20, 2023 1:29 am

Frekey wrote:
Sat Aug 05, 2023 3:13 am
Hi,

I'm new in opencart and have installed this great extension.
I have only 1 problem.

Version of Export/Import Tool 4.16
Version of OpenCart 4.0.2.2
Version of PHP 8.2.3

When importing a file i received next error:
Export/Import: Keyword 'Htc-touch-hd' used more than once for store_id '0' in worksheet 'ProductSEOKeywords'!

Our opencart is installed in multi-language (EN, DE, ...)

The error only appear when using the same keyword by each language.
keyword(de-de) = Htc-touch-hd and keyword(en-gb) = Htc-touch-hd
When using different keywords the problem is solved.
keyword(de-de) = Htc-touch-hd-de and keyword(en-gb) = Htc-touch-hd
For some of our products the keyword must be the same.

How can this been resolved?

Many thanks
Thank you for pointing this out. OpenCart 4, unlike OpenCart 3, does indeed allow for the same keyword for each language. I have now fixed it in the Export/Import tool, use the new V4.17 of our tool.

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by ASG » Tue Sep 19, 2023 2:53 pm

On a fresh OC4.0.2.1 install on XAMPP(MacOS) I'm getting the following error when importing a spreadsheet:

Code: Select all

Error: Class "PhpOffice\PhpSpreadsheet\Spreadsheet" not found in /Applications/XAMPP/xamppfiles/htdocs/oc4/extension/export_import/admin/model/tool/export_import.php on line 5666
Upon investigating the following folder is not being created and hence its contents are not getting copied during installation:

Code: Select all

/system/library/export_import
Even after copying the directory manually, the error persists.

There is only a install.json file in the root of the export_import.ocmod .zip. XML seems to missing, not sure if that is how it is supposed to be on OC4.

Permissions on the directories are 777.

ASG
Active Member

Posts

Joined
Tue Sep 30, 2014 11:03 pm

Post by JNeuhoff » Tue Sep 19, 2023 4:58 pm

@ASG: Something clearly went wrong with your installation, because the export_import.ocmod.zip does contain this missing folder. Do a proper installation:

Installation for OpenCart 4.x
In the OpenCart admin backend, do the following steps:
  • Install via Extensions > Installer > Upload
  • Go to Extensions > Extensions > Other > Export/Import Tools to install and enable it
  • You should now see it under System > Maintenance > Export/Import

User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by samkung » Tue Sep 19, 2023 5:01 pm

JNeuhoff wrote:
Tue Oct 07, 2014 5:00 am
The Export/Import Tool (V2.x) is now available for OpenCart 2, with the same same features as the one for OpenCart 1.5.x.
About Export/Import Tool extension, i am using opencart 2.3.02

After i installed this extension, every single product got error 500:
Undefined index: product_id in /home/xxx/library/cart/cart.php on line 556

my Error.log say:
[19-Sep-2023 11:54:43 Asia/Hong_Kong] PHP Parse error: syntax error, unexpected '??' (T_COALESCE), expecting end of file in /home/dbbeingc/public_html/dummy/system/storage/modification/catalog/view/theme/journal3/template/product/product.tpl on line 199


Domain:https://dummy.db-being.com/index.php?ro ... ct_id=2271


Even i disable/remove the extension. now, i can see the product page on my store.

Also, when i try to export product, the system want me to click the box: Use filter_id instead of filter name in worksheets 'ProductFilters' and 'CategoryFilters' for export file. however, after i clicked the box, it can not be unclick!

Please tell me how to fix this, my site can not work.
Last edited by samkung on Tue Sep 19, 2023 5:04 pm, edited 1 time in total.

Newbie

Posts

Joined
Tue Sep 19, 2023 10:26 am

Post by ASG » Wed Sep 20, 2023 12:25 am

JNeuhoff wrote:
Tue Sep 19, 2023 4:58 pm
@ASG: Something clearly went wrong with your installation, because the export_import.ocmod.zip does contain this missing folder. Do a proper installation:

Installation for OpenCart 4.x
In the OpenCart admin backend, do the following steps:
  • Install via Extensions > Installer > Upload
  • Go to Extensions > Extensions > Other > Export/Import Tools to install and enable it
  • You should now see it under System > Maintenance > Export/Import
I know the missing folder is in export_import.ocmod.zip, it's just not getting copied to the Opencart directory while installing.

I have followed the process mentioned by you multiple times now, every time the end-result is the same.

While Installing(Clicking on + icon), the icon revolves like it is processing, however, it returns back to the green "install" + icon.
Then if I refresh the page, only then it changes to the "uninstall" icon.
Clearly, the installation is failing somewhere. But how do I check where? There are no instalation logs. The error log only shows the error mentioned previously.

ASG
Active Member

Posts

Joined
Tue Sep 30, 2014 11:03 pm

Post by JNeuhoff » Wed Sep 20, 2023 4:54 am

I am not able to reproduce your installation problem. Can you provide more details? PHP version? OpenCart version? Web browser used?

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 2 guests