Post by hagelslag2 » Wed Nov 16, 2022 10:17 pm

Hi guys,

Installing a new store on 2.2.0.
All is fine except that css of the product page does not load when a product link has a category.
For example www.site.com/iphone14 works perfect
But loading the exact same product page from a category page like www.site.com/phones/iphone14 doesn't load css, images etc

See the links here:
https://tinyurl.com/3fnh3c9r good product page
Same page loaded from a category page: https://tinyurl.com/9vcjae9d
The only thing i did to get SSL running is i put site_ssl=true in system/config/default.php, system/config/admin.php and system/config/catalog.php

Anyone that has an idea?
Many thanks!

Newbie

Posts

Joined
Wed Nov 16, 2022 10:04 pm

Post by ADD Creative » Wed Nov 16, 2022 11:10 pm

If you view the page source the base tag is wrong.

Code: Select all

<base href="" />
It should contain your site's URL. Try testing with the default theme.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by hagelslag2 » Thu Nov 17, 2022 4:36 am

Thanks for the quick response.
Changing back to the default theme would be a hassle.
I think it might come from the forcing ssl or forcing www in the .htaccess
Is it ok if i post the .htaccess here?

Newbie

Posts

Joined
Wed Nov 16, 2022 10:04 pm

Post by by mona » Thu Nov 17, 2022 9:07 am

You can check that yourself
https://www.google.com/search?forcing+s ... cart+forum
It has been asked and answered so many times

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Expert Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by JNeuhoff » Thu Nov 17, 2022 7:02 pm

ADD Creative wrote:
Wed Nov 16, 2022 11:10 pm
If you view the page source the base tag is wrong.

Code: Select all

<base href="" />
It should contain your site's URL. Try testing with the default theme.
The base tag value usually comes from the config_ssl or config_url (see e.g. catalog/controller/startup/startup.php), which in turn is taken from the HTTPS_SERVER or HTTP_SERVER which are defined in your config.php file. Hence you need to check your config.php file for correct entries.

Also check your .htaccess file, it needs to have a correct RewriteBase.

And it also makes sense to use a more standard-compliant and nicer looking web theme.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Guru Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by hagelslag2 » Thu Nov 17, 2022 10:04 pm

Thanks for your tips.
About the theme, yes it is a bit different but it's the only way that the options stay insight and the updating price too. All other themes have the problem that a longer options list pushes the content away and create a big gap below the image section. Any tips on a good computer theme are very welcome of course!

Newbie

Posts

Joined
Wed Nov 16, 2022 10:04 pm
Who is online

Users browsing this forum: No registered users and 1 guest