Post by LMP » Mon Oct 03, 2022 1:31 pm

We use OC 3.0.3.8

I have the feeling that when displaying multiple carousels there are conflicts - be it in javascript or in jQuery.

On the home page of our not yet opened store we have under: Desgin > Layouts > Home activated:

1. home page slideshow
2. sponsors banner

and now as 3. the owl-carousell for "Sellers latest products

Everything works except for the "latest products" extension
I uninstalled the extension and reinstalled it.
Then performed the refresh under customizations.

Nothing changes.
Only the headline "Sellers latest products" is displayed but the expected carousel does not appear.

I then added new products in a vendor store.
NOTHING appears in the carousel.

Does anyone have a solution?
I have also installed the latest version of the owl-carousel (2.3.4).

The code in the page looks like this:

<script type="text/javascript"><!--
$(document).ready(function(){
$("#carousel_latest").owlCarousel({
items:4,
margin:10,
autoPlay: 3000,
navigation:true,
navigationText: ['<i class="fa fa-chevron-left fa-5x"></i>', '<i class="fa fa-chevron-right fa-5x"></i>'],
pagination:true,
responsiveClass:true,
responsive:{
0:{
items:1,
},
768:{
items:3,
margin:20,
},
1024:{
items:4,
margin:20,
}
},
});
});
--></script>
Last edited by LMP on Sun Oct 30, 2022 3:06 pm, edited 1 time in total.

User avatar
LMP
New member

Posts

Joined
Sun Apr 24, 2022 2:54 pm
Location - Germany

Post by xxvirusxx » Mon Oct 03, 2022 2:55 pm

LMP wrote:
Mon Oct 03, 2022 1:31 pm
We use OC 3.0.3.8
And what theme?
Because on Default theme, Latest module doesn't use carousel or slideshow..

My Converted Modules | Opencart Upgrade Service | Free Dashboard Maps | Buy me a beer | My Custom OC 3.0.3.8


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by LMP » Mon Oct 03, 2022 3:19 pm

And what theme?
Because on Default theme, Latest module doesn't use carousel or slideshow..
--------------------------------------------

It was the default theme, which was automatically installed after downloading the version.

3 different product carousels are running there though.
So I mean for example the homepage slideshow.
I have there in 2 variants running.

Also test the carousell with the brands (CocaCola etc.) runs fine.

Only the "latest products" not.

User avatar
LMP
New member

Posts

Joined
Sun Apr 24, 2022 2:54 pm
Location - Germany

Post by xxvirusxx » Mon Oct 03, 2022 4:05 pm

As I said there is no Carousel/Swiper on Latest module....

https://github.com/opencart/opencart/bl ... atest.twig

Better post your store URL...

LE. Also 3.0.x.x use Swiper and not Owl Carousel
If is a custom module, you can contact module developer

My Converted Modules | Opencart Upgrade Service | Free Dashboard Maps | Buy me a beer | My Custom OC 3.0.3.8


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by paulfeakins » Mon Oct 03, 2022 7:37 pm

LMP wrote:
Mon Oct 03, 2022 1:31 pm
I have the feeling that when displaying multiple carousels there are conflicts - be it in javascript or in jQuery.
I've seen problems before when trying to download multiple versions of JQuery.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by LMP » Mon Oct 24, 2022 1:06 am

paulfeakins wrote:
Mon Oct 03, 2022 7:37 pm
LMP wrote:
Mon Oct 03, 2022 1:31 pm
I have the feeling that when displaying multiple carousels there are conflicts - be it in javascript or in jQuery.
I've seen problems before when trying to download multiple versions of JQuery.
YES Paul - you are right.
The error comes from jQuery loading from 2 different folders.
I think the best is I will use a banner controlled full via CSS

User avatar
LMP
New member

Posts

Joined
Sun Apr 24, 2022 2:54 pm
Location - Germany

Post by paulfeakins » Mon Oct 24, 2022 4:46 pm

LMP wrote:
Mon Oct 24, 2022 1:06 am
I think the best is I will use a banner controlled full via CSS
Or you could just disable one of the versions?

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom
Who is online

Users browsing this forum: No registered users and 14 guests