Post by chrismys » Sat Sep 24, 2022 1:58 am

Hello all,

I recently upgraded my store from 2.0.1.1 to 3.0.3.8 and everything went as swimmingly as it could have. I need the store to be compliant with PHP8 so unfortunately I now need to take the store to 4.x so I have chosen to just take it to 4.0.1.1.

The upgrade itself was 'successful', but then the problems started popping up one by one. First off the CSS for the admin side of things is completely fubared (everything seems to be pushed left), and my store no longer recognizes previous admin accounts. I checked to make sure I had DB connection, which I do, and so I created a new admin account via PHPMyAdmin and was able to login with the new account, but the old ones still don't work.

Another thing to note is when I login with the new account I am prompted with a JSON redirect, but the page doesn't actually redirect me. I just copied the link in the JSON and it took me to my dashboard where I managed to move my storage folder, and rename my admin folder but now any of the options inside the admin panel all give me the same error:

Code: Select all

TypeError: Unsupported operand types: string * int
I noticed via the GitHub issues that this was supposedly fixed already, by forcing a type of (int) of the controllers in the admin folder, but when I made the changes to just one to see if it works I am now prompted with the following error:

Code: Select all

DivisionByZeroError: Division by zero
All of my problems currently seem to stemming from the admin panel because the site works otherwise, I can even force my custom theme to load but everything just redirects to the homepage because none of my modules / extensions are activated currently.

Anybody have any ideas? Or some guidance on how to proceed? Let me know if you require anything else, thanks!

Couple of images of the CSS issues for you guys:
https://ibb.co/YkSJL6k
https://ibb.co/pdtvFxH
Last edited by chrismys on Wed Sep 28, 2022 9:33 pm, edited 1 time in total.

Newbie

Posts

Joined
Fri Sep 16, 2022 1:07 am

Post by ADD Creative » Sat Sep 24, 2022 7:31 pm

The general consensus on this forum is they version 4 is not stable enough for production use yet. Are you able to go back to a backup of 3.0.3.8? If so you could use the updates in the 3.0.x.x Maintenance branch on GitHub, which should be compatible with PHP 8.

https://github.com/opencart/opencart/tr ... aintenance

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by chrismys » Mon Sep 26, 2022 9:48 pm

ADD Creative wrote:
Sat Sep 24, 2022 7:31 pm
The general consensus on this forum is they version 4 is not stable enough for production use yet. Are you able to go back to a backup of 3.0.3.8? If so you could use the updates in the 3.0.x.x Maintenance branch on GitHub, which should be compatible with PHP 8.

https://github.com/opencart/opencart/tr ... aintenance
Thank you so much for pointing this out!

The install went excellent, however do you know of any issues that have arisen with the Cart / Checkout process? I no longer have the ability to remove cart items (I can update the quantity), and the checkout screen is just empty options that redirect to the homepage.

Newbie

Posts

Joined
Fri Sep 16, 2022 1:07 am

Post by ADD Creative » Mon Sep 26, 2022 11:51 pm

I don't know of any issues. Make sure you clear all the caches and update the storage folder if necessary. Alos check both the PHP and OpenCart error logs and your web browser's developer console for errors.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by chrismys » Tue Sep 27, 2022 12:30 am

ADD Creative wrote:
Mon Sep 26, 2022 11:51 pm
I don't know of any issues. Make sure you clear all the caches and update the storage folder if necessary. Also check both the PHP and OpenCart error logs and your web browser's developer console for errors.
Thank you, I cleared all the caches and made sure the storage folder was the one from the branch. I also checked the logs and there is nothing of relevance to this issue in any of them. I did manage to fix the issues of the cart adding / removing by forcing a query string on the common.js file to break the cache, but my Checkout Page isn't showing me any of the relevant information, just headings now and nothing is clickable.

https://ibb.co/pnJVyQS

Newbie

Posts

Joined
Fri Sep 16, 2022 1:07 am

Post by ADD Creative » Tue Sep 27, 2022 3:49 am

Sounds like you web browser is caching. Try disabling your web browser cache in the developer tool.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by JNeuhoff » Tue Sep 27, 2022 10:37 pm

Unable to reproduce your error. What's your website URL? And what's your theme?

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Guru Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by IP_CAM » Tue Sep 27, 2022 11:07 pm

Better download and install the latest OC v.4.0.2.0, the Version you use is known to not be error free yet.
https://github.com/opencart/opencart/bl ... /index.php

My Github OC Site: https://github.com/IP-CAM
5'000 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by WaxedPerfection » Wed Sep 28, 2022 7:47 pm

IP_CAM wrote:
Tue Sep 27, 2022 11:07 pm
Better download and install the latest OC v.4.0.2.0, the Version you use is known to not be error free yet.
https://github.com/opencart/opencart/bl ... /index.php
What on this gods earth have you link to ?

Code: Select all

* HELP SAVE BABY OCEAN
 *
 * Abuse
 *
 * - Starvation  				Oct 2020
 * - Leg Injuries				Dec 2020
 * - Lip Injuries				Feb 2021
 * - Head Injuries				Mar 2021
 * - Face/eye Injuries			Aug 2021
 * - Neck slashed		  		Nov 2021
 *   Initials stitched into
 *   the back of neck by the
 *   social worker. Child did
 *   not go to hospital or see
 *   a doctor.
 * - Broken Leg					Mar 2022

Active Member

Posts

Joined
Sun Mar 26, 2017 8:23 pm

Post by IP_CAM » Wed Sep 28, 2022 8:09 pm

I linked directly to the index.php file of the latest Release, to let people know what Version this is.
define('VERSION', '4.0.2.0')
The Download Link is: https://github.com/opencart/opencart

My Github OC Site: https://github.com/IP-CAM
5'000 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by chrismys » Wed Sep 28, 2022 9:32 pm

Thank you everyone for your insight, ultimately I was able to successfully upgrade to the 3.x.x-Maintenance to comply with my PHP8 requirements. I was able to solve all the issues I had. For those of you interested, I had a bootstrap conflict. The theme I am using was an older theme (custom designed) from 2.0.1.1 that we had to convert from .tpl to .twig and trying to use updated versions of bootstrap was breaking things. Reverted my bootstrap version back to 3.3.5 and everything is working flawlessly.

Newbie

Posts

Joined
Fri Sep 16, 2022 1:07 am
Who is online

Users browsing this forum: No registered users and 3 guests