Post by JPC60 » Wed Jul 01, 2020 12:29 pm

We've been using OpenCart 1.5x on 5 sites for years now with a pretty high satisfaction rate. A few hiccups here and there but overall quite pleased. Recently changed hosts and decided it was time to update as I wanted a native responsive behavior. I just recently went with 2.3.0.2 as I read that it was a very, very stable version. Not sure if it's the new host or OpenCart 2.3.0.2, but I really like this version! Very fast on the front and backends.

As I have a few more stores of ours to rebuild, I'm rethinking the newest version of OpenCart, 3.0.3.3, and am looking into maybe just diving right on on this version, leaving 2.3.0.2 behind. I've read up on some of the basic differences but thought it would be good to come here to get a sense of what's considered a better / more stable / future proof (I know, that never really exists) for at least a few years, version.

We ran 1.5x for around 5 years and I'd like to replicate this lifespan with the new version choices. Any input would be much appreciated.

Thanks, John

New member

Posts

Joined
Thu Nov 17, 2011 5:42 am

Post by OSWorX » Wed Jul 01, 2020 1:23 pm

In short: use 2.3.0.2
Forget 3.0.x
Next version which could be the best of all will be 3.1.x - when it will be finished once upon a time ..

Longer: enough posts here why you shuld use this version and not others - use the search.

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by paulfeakins » Wed Jul 01, 2020 6:09 pm

OSWorX wrote:
Wed Jul 01, 2020 1:23 pm
In short: use 2.3.0.2
Forget 3.0.x
Sorry to confuse you but I'd always say use the latest for reasons of future proofing, extension compatibility etc.

OSWorX wrote:
Wed Jul 01, 2020 1:23 pm
Longer: enough posts here why you shuld use this version and not others - use the search.
Yes, there are loads, the OP should read them.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by OSWorX » Wed Jul 01, 2020 7:36 pm

paulfeakins wrote:
Wed Jul 01, 2020 6:09 pm
OSWorX wrote:
Wed Jul 01, 2020 1:23 pm
In short: use 2.3.0.2
Forget 3.0.x
Sorry to confuse you but I'd always say use the latest for reasons of future proofing, extension compatibility etc.
Current 3.0.3.x release:
1x core pack
1x feature pack
Both no payment extensions except 1 PayPal.

"Future Proofing": what will you "proof" with old libraries?
"Extension compatibility": huuaahhh .. nearly all extensions are avaliable for 2.3.x, while for 3.0.3.4 .. good joke.

btw: using "always the latest" is in the context with OpenCart the wrong approach.
Never ever use any release which is published for example as 3.0.0.0 or 3.0.1.0 or 3.0.2.0 or 3.0.3.0
Look at the last number, ends with a 0 > forget it!
And, always wait approx. 3-4 weeks after any fresh published release .. and check before using it, the forum here!

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by JPC60 » Thu Jul 02, 2020 5:15 am

I appreciate both of these views, thank you. I believe we've got our decision after weighing options. Again thanks to both of you, it's appreciated.
John

New member

Posts

Joined
Thu Nov 17, 2011 5:42 am

Post by paulfeakins » Thu Jul 02, 2020 6:54 pm

OSWorX wrote:
Wed Jul 01, 2020 7:36 pm
Current 3.0.3.x release:
1x core pack
1x feature pack
Not sure what you mean by that?

OSWorX wrote:
Wed Jul 01, 2020 7:36 pm
Both no payment extensions except 1 PayPal.
This is a good point.

OSWorX wrote:
Wed Jul 01, 2020 7:36 pm
"Future Proofing": what will you "proof" with old libraries?
"Extension compatibility": huuaahhh .. nearly all extensions are avaliable for 2.3.x, while for 3.0.3.4 .. good joke.
Not sure I agree with this one, plenty are available for 3.x. I'm not sure I'd want to start one MAJOR version behind.

OSWorX wrote:
Wed Jul 01, 2020 7:36 pm
btw: using "always the latest" is in the context with OpenCart the wrong approach.
Never ever use any release which is published for example as 3.0.0.0 or 3.0.1.0 or 3.0.2.0 or 3.0.3.0
Look at the last number, ends with a 0 > forget it!
And, always wait approx. 3-4 weeks after any fresh published release .. and check before using it, the forum here!
It's true you should avoid versions ending in 0, but when I say "always use the latest" I mean always use the latest MAJOR version e.g. 3 rather than 2.

Summary: there are some good points from OSWorX and you probably wouldn't be making a major mistake by using either.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by Burt65 » Fri Jul 03, 2020 4:46 pm

JPC60 wrote:
Wed Jul 01, 2020 12:29 pm
We've been using OpenCart 1.5x on 5 sites for years now with a pretty high satisfaction rate. A few hiccups here and there but overall quite pleased. Recently changed hosts and decided it was time to update as I wanted a native responsive behavior. I just recently went with 2.3.0.2 as I read that it was a very, very stable version. Not sure if it's the new host or OpenCart 2.3.0.2, but I really like this version! Very fast on the front and backends.

As I have a few more stores of ours to rebuild, I'm rethinking the newest version of OpenCart, 3.0.3.3, and am looking into maybe just diving right on on this version, leaving 2.3.0.2 behind. I've read up on some of the basic differences but thought it would be good to come here to get a sense of what's considered a better / more stable / future proof (I know, that never really exists) for at least a few years, version.

We ran 1.5x for around 5 years and I'd like to replicate this lifespan with the new version choices. Any input would be much appreciated.

Thanks, John
I think you have already answered your own question..

1.5x Old version = 5 years no problems..
Update to 2.3.0.2 = Still, no problems and you like it..
Latest 3.0.3.x = Hmmm... ;)

Over 95% of all computer problems can be traced back to the interface between the keyboard and the chair...


User avatar
Active Member

Posts

Joined
Mon Nov 18, 2013 3:23 pm
Location - Oz

Post by johnp » Fri Jul 03, 2020 7:25 pm

1.5.6.5 still runs several of my clients sites on PHP7 and they very rarely get problems. To date it's still my favourite OC version. 2.3.0.2 is pretty good though IMO. 3 is pretty much off my radar.

Opencart 1.5.6.5/OC Bootstrap Pro/VQMOD 2.6.1 lover, user and geek.
Affordable Service £££ - Opencart Installs, Fixing, Development and Upgrades
Plus Ecommerce, Marketing, Mailing List Management and More
FREE Guidance and Advice at https://www.ecommerce-help.co.uk


User avatar
Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by JPC60 » Sat Jul 04, 2020 5:03 am

I really do appreciate all the feedback here. After letting these responses, and others I've read, sink in for a bit I have decided to continue with moving the rest of our sites to 2.3.0.2. from several 1.5 variants we're currently running. In for a penny... :)

New member

Posts

Joined
Thu Nov 17, 2011 5:42 am
Who is online

Users browsing this forum: No registered users and 13 guests