Post by Gobbo » Thu Oct 17, 2019 8:43 pm

Hi,

On my site, when I click on the About Us or Delivery Information links I keep getting a 404 error.

Does anyone know why this is?

Kind Regards,
Lee

Using opencart version 2.1.0.2


Active Member

Posts

Joined
Tue Jun 22, 2010 12:38 am

Post by thekrotek » Thu Oct 17, 2019 9:12 pm

Yes, I know: something is wrong.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by Gobbo » Fri Oct 18, 2019 4:44 am

:laugh:

Okay, do you know what is wrong?

Using opencart version 2.1.0.2


Active Member

Posts

Joined
Tue Jun 22, 2010 12:38 am

Post by thekrotek » Fri Oct 18, 2019 5:12 am

Gobbo wrote:
Fri Oct 18, 2019 4:44 am
Okay, do you know what is wrong?
No. And nobody knows, because you provided absolutely zero information about your issue.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by Gobbo » Fri Oct 18, 2019 5:34 am


Using opencart version 2.1.0.2


Active Member

Posts

Joined
Tue Jun 22, 2010 12:38 am

Post by uksitebuilder » Fri Oct 18, 2019 2:38 pm

Looks like you need to enable the htaccess file in your store root for rewrites to work with SEO URLs

In your store root you should see a file called .htaccess.txt

Simply rename it to just .htaccess (remove the .txt file extension)

Also just check in your admin - System -Settings for your store to make sure Use SEO URLs is enabled

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by Gobbo » Tue Oct 22, 2019 8:40 pm

It always has had the file name '.htaccess'.

Using opencart version 2.1.0.2


Active Member

Posts

Joined
Tue Jun 22, 2010 12:38 am

Post by Gobbo » Wed Oct 23, 2019 8:42 pm

And SEO URLs is set to Yes.

Using opencart version 2.1.0.2


Active Member

Posts

Joined
Tue Jun 22, 2010 12:38 am

Post by Gobbo » Wed Oct 30, 2019 9:36 pm

Does anyone know why this is happening?

Using opencart version 2.1.0.2


Active Member

Posts

Joined
Tue Jun 22, 2010 12:38 am

Post by uksitebuilder » Wed Oct 30, 2019 10:28 pm

Please paste the contents of your .htaccess file\

I also assume you are using an Apache server

If you are using NGINX then the .htaccess wont do anything and will need to be converted.

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by cedcommerceteam » Tue Nov 05, 2019 7:52 pm

Gobbo wrote:
Thu Oct 17, 2019 8:43 pm
Hi,

On my site, when I click on the About Us or Delivery Information links I keep getting a 404 error.

Does anyone know why this is?

Kind Regards,
Lee
Webpage returns “404 error” when the page you are looking for does not exist in website or removed from the website. Check the URL, error logs as well as root folder. Please let us know more about the issue so that we can help you out.

Call us at : (+91) -8765210318 , Skype: live:carlmorgan.cedcommerce , Email: support@cedcommerce.com
CedCommerece : Officail Opencart Partners
CedCommerce Official : www.cedcommerce.com
Opencart Services : www.cedcommerce/opencart-services.com
Sell On various Marketplace Integration : Opencart-Extensions
Magenative Mobile App/IOS Development : magenative.com


User avatar
Active Member

Posts

Joined
Wed Aug 09, 2017 9:02 pm

Post by knowband.plugins » Tue Nov 05, 2019 10:36 pm

It's definitely a .htaccess issue.

Try setting the SEO URL to NO & then click on the about us link from the site (From the footer. URL will be changed once you will set the SEO URL to No.)

To verify the same, Set the SEO URL for any product OR category. We hope they will also return the same error.

Kindly share the .htaccess content to share the solution.

Regards,
Knowband Team

Opencart Plugins: Knowband Store
Email: support@knowband.com


User avatar
Active Member

Posts

Joined
Thu Aug 04, 2016 2:56 pm


Post by Gobbo » Mon Nov 18, 2019 9:38 pm

I tried to set my SEO URLs to no, but got this message:

Warning: You do not have permission to modify settings!

Even though I'm admin ???

Using opencart version 2.1.0.2


Active Member

Posts

Joined
Tue Jun 22, 2010 12:38 am
Who is online

Users browsing this forum: No registered users and 20 guests