Post by olfactorymaven » Thu Feb 21, 2019 3:26 am

I am installing a zip file from TrustPilot. The file is now valid after affixing ocmod. However, the file only uploads halfway before showing this error. Has anyone experienced this? Does anyone know what this means and how to fix it?

My OC version is 2.3. The browser is Safari.

error
<!DOCTYPE html>
<!--[if IE]><![endif]-->
<!--[if IE 8 ]><html dir="ltr" lang="en" class="ie8"><![endif]-->
<!--[if IE 9 ]><html dir="ltr" lang="en" class="ie9"><![endif]-->
<!--[if (gt IE 9)|!(IE)]><!-->
<html dir="ltr" lang="en">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<title>The page you requested cannot be found!</title>
<base href="https://smellgoodspa.com/" />
<script src="catalog/view/javascript/jquery/jquery-2.1.1.min.js" type="text/javascript"></script>
<link href="catalog/view/javascript/bootstrap/css/bootstrap.min.css" rel="stylesheet" media="screen" />
<script src="catalog/view/javascript/bootstrap/js/bootstrap.min.js" type="text/javascript"></script>
<link href="catalog/view/javascript/font-awesome/css/font-awesome.min.css" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=Open+Sans:400,400i,300,700" rel="stylesheet" type="text/css" />
<link href="catalog/view/theme/default/stylesheet/stylesheet.css" rel="stylesheet">
<link href="catalog/view/theme/default/stylesheet/slsoffr.css" type="text/css" rel="stylesheet" media="screen" />
<script src="catalog/view/javascript/common.js" type="text/javascript"></script>
<link href="https://smellgoodspa.com/image/catalog/site pics/newlogo_site_2018.jpg" rel="icon" />
UA-21600270-1</head>
<body class="error-not_found">
<nav id="top">
<div class="container">
<div class="pull-left">
<form action="https://smellgoodspa.com/index.php?rout ... y/currency" method="post" enctype="multipart/form-data" id="form-currency">
<div class="btn-group">
<button class="btn btn-link dropdown-toggle" data-toggle="dropdown">
<strong>$</strong>
<span class="hidden-xs hidden-sm hidden-md">Currency</span> <i class="fa fa-caret-down"></i></button>
<ul class="dropdown-menu">
<li><but

New member

Posts

Joined
Fri Apr 19, 2013 3:35 am


Post by OSWorX » Thu Feb 21, 2019 4:33 am

It simply shows the beginning ot the html-code of the shop.
Guess the file has bugs inside.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by Johnathan » Thu Feb 21, 2019 10:35 pm

Double-check the structure of your .zip bundle. It should have an "upload" folder within it, and if it uses ocMod, a file called "install.xml". If it doesn't have that structure, then changing the extension to .ocmod.zip wouldn't fix it.

You may want to just upload the files manually using FTP, if it's not ocMod-based. If you don't know how to do that, here's a tutorial on it:

https://opencart-training.com/installing-modules

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by OSWorX » Thu Feb 21, 2019 11:42 pm

@Johnathan: never thought the someone would simply rename a non-valid extension file (package).
But it seems, some has strange ideas.

4 scenarios are now possible:

1. file is not an extension file
2. file is a valid OCMod extension file, but has wrong name (I assume not)
3. file a valid VQMod extension file, if true not installable by the internal extension installer, VQMod has to be installed additionally
4. file is .zip package and is called somewhat.zip

#4 could be:
4.1 a VQMod file or package
4.2 a OCMod file or package

If it is a package, basically 2 must be included:

A. folder Upload (may contain further files and folders
B. file install.xml

But it could be also have only 1 file included (have seen such also):

I. install.xml
or
II. somename.ocmod.xml

If I > it is a VQMod file >> VQMod needed
If II > it is a OCMod file >> installable by the already integrated installer (since OpenCart 2.x )

But, and that is also possible - it is a zip package and it contain only 1 folder called upload.
Not it is getting funny, because that could be everything!

a. this package could be installable by the integrated installer > only if the whole package is named like: mypackage.ocmod.zip
b. the folder (or files inside) have to be uploaded by FTP, because the name is somewhat like mypackage.zip
c. it could be a package which has several other zip packages included - unzip locale and see what's inside - and now it depends on the extension names and file types how to install.

Strange and curious?
Maybe, but I have seen all these variants the last years!

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by olfactorymaven » Mon Feb 25, 2019 10:39 pm

Johnathan wrote:
Thu Feb 21, 2019 10:35 pm
Double-check the structure of your .zip bundle. It should have an "upload" folder within it, and if it uses ocMod, a file called "install.xml". If it doesn't have that structure, then changing the extension to .ocmod.zip wouldn't fix it.

You may want to just upload the files manually using FTP, if it's not ocMod-based. If you don't know how to do that, here's a tutorial on it:

https://opencart-training.com/installing-modules
It does.
FTP: Did that first, still errors in certain folders.

Thanks for replying.

New member

Posts

Joined
Fri Apr 19, 2013 3:35 am


Post by OSWorX » Mon Feb 25, 2019 11:59 pm

Before that ends in a neverending story, why posting here not the file?

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by olfactorymaven » Tue Feb 26, 2019 12:07 am

OSWorX wrote:
Mon Feb 25, 2019 11:59 pm
Before that ends in a neverending story, why posting here not the file?
I don’t understand your comment nor question. Nonetheless, waiting to hear back from Trust Pilot. Thanks.

New member

Posts

Joined
Fri Apr 19, 2013 3:35 am


Post by OSWorX » Tue Feb 26, 2019 1:18 am

olfactorymaven wrote:
Tue Feb 26, 2019 12:07 am
OSWorX wrote:
Mon Feb 25, 2019 11:59 pm
Before that ends in a neverending story, why posting here not the file?
I don’t understand your comment nor question. Nonetheless, waiting to hear back from Trust Pilot. Thanks.
What is so hard to understand?
You are asking here for help, but with these spare infos nobody can.

So, post the file here or a link where you have stored it.
Understood?

Of course, you can also wait for trustpilot ...

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by olfactorymaven » Tue Feb 26, 2019 1:22 am

OSWorX wrote:
Tue Feb 26, 2019 1:18 am
olfactorymaven wrote:
Tue Feb 26, 2019 12:07 am
OSWorX wrote:
Mon Feb 25, 2019 11:59 pm
Before that ends in a neverending story, why posting here not the file?
I don’t understand your comment nor question. Nonetheless, waiting to hear back from Trust Pilot. Thanks.
What is so hard to understand?
You are asking here for help, but with these spare infos nobody can.

So, post the file here or a link where you have stored it.
Understood?

Of course, you can also wait for trustpilot ...
Now, that you composed your sentences better, I understand. It was hard, just not comprehensible. Again, thank you.

New member

Posts

Joined
Fri Apr 19, 2013 3:35 am


Post by olfactorymaven » Tue Feb 26, 2019 1:24 am

olfactorymaven wrote:
Tue Feb 26, 2019 1:22 am
OSWorX wrote:
Tue Feb 26, 2019 1:18 am
olfactorymaven wrote:
Tue Feb 26, 2019 12:07 am

I don’t understand your comment nor question. Nonetheless, waiting to hear back from Trust Pilot. Thanks.
What is so hard to understand?
You are asking here for help, but with these spare infos nobody can.

So, post the file here or a link where you have stored it.
Understood?

Of course, you can also wait for trustpilot ...
Now, that you composed your sentences better, I understand. It was hard, just not comprehensible. Again, thank you.
*was not hard

New member

Posts

Joined
Fri Apr 19, 2013 3:35 am

Who is online

Users browsing this forum: No registered users and 8 guests