Post by ForgedGround » Sun Feb 17, 2019 1:33 am

Hello people, Opencart 3.0.2

I optimized my site images...and i did saw some tiny changes but is not even close to good.

Tested my site in gtmetrix....extremly slow....

What i did :

1) Images optimized - check
2) Disabled some content on home page - Check
3) Admin - Settings - Gzip set to 6
4) edited my .htaccess file, and added belor re-write rules :

<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE image/x-icon
AddOutputFilterByType DEFLATE image/svg+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/x-font
AddOutputFilterByType DEFLATE application/x-font-truetype
AddOutputFilterByType DEFLATE application/x-font-ttf
AddOutputFilterByType DEFLATE application/x-font-otf
AddOutputFilterByType DEFLATE application/x-font-opentype
AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
AddOutputFilterByType DEFLATE font/ttf
AddOutputFilterByType DEFLATE font/otf
AddOutputFilterByType DEFLATE font/opentype
# For Older Browsers Which Can't Handle Compression
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
</IfModule>

When checking CHROME DEV :
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8
Accept-Encoding: gzip, deflate, br
Accept-Language: pt-PT,pt;q=0.9,en-US;q=0.8,en;q=0.7
Cache-Control: max-age=0

But in GTmetrix Results are :
PageSpeed Score : F 39%
YSlow Score : E 58%
Fully Loaded Time : 8.4 Secs
Total Page Size : 7.92 Mb
Requests : 137

And when checking if my site is gzip enabled....it says NO

What am i missing?

New member

Posts

Joined
Sat Aug 04, 2018 4:36 am

Post by straightlight » Sun Feb 17, 2019 2:20 am

And when checking if my site is gzip enabled....it says NO

What am i missing?
To contact your host to enable it or edit your php.ini file provided with OC.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ForgedGround » Sun Feb 17, 2019 2:40 am

my php.ini :

magic_quotes_gpc = Off;
register_globals = Off;
default_charset = UTF-8;
memory_limit = 64M;
max_execution_time = 36000;
upload_max_filesize = 999M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.auto_start = Off;
session.use_only_cookies = On;
session.use_cookies = On;
session.use_trans_sid = Off;
session.cookie_httponly = On;
session.gc_maxlifetime = 3600;
allow_url_fopen = on;
;display_errors = 1;
;error_reporting = E_ALL;

Uploaded php info to my root...this is what i have (if im looking at the right place) :

Phar
Phar: PHP Archive support enabled
Phar EXT version 2.0.2
Phar API version 1.1.1
SVN revision $Id: 56fa253a6fef2a07ac702a358f778eddc01a09ea $
Phar-based phar archives enabled
Tar-based phar archives enabled
ZIP-based phar archives enabled
gzip compression enabled
bzip2 compression enabled
OpenSSL support enabled

New member

Posts

Joined
Sat Aug 04, 2018 4:36 am

Post by straightlight » Sun Feb 17, 2019 3:19 am

Follow this documentation: https://www.warpconduit.net/2010/10/23/ ... d_deflate/ and ensure to make a backup of your php.ini and .htaccess before starting to work on them.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ForgedGround » Sun Feb 17, 2019 3:23 am

Thx Straightlight, but before i posted here, i checked every corner of the net looking for solution...

I tested that, didnt work...

Now....my server has GZIP and Deflate enabled...and i test both, nothing works....

In my wordpress site (same server) it did work....

New member

Posts

Joined
Sat Aug 04, 2018 4:36 am

Post by straightlight » Sun Feb 17, 2019 3:41 am

If on the same server you have two different results, then there's something you're probably doing wrong while following this process. To make the task easier, contact your host to edit your php.ini file. This is something they should be able to handle.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Sun Feb 17, 2019 1:36 pm

PageSpeed Score : 39% - YSlow Score : 58% - Total Page Size : 7.92 Mb - Requests : 137
Well, I am not sure, if it makes much sense, to reply on such, since you seem to
be building a fully plastered Download Page, size- and request- wise at least, but
sure not a speedy Layout. But if done right, I bet, that it would look more like:
PageSpeed Score : 93% - YSlow Score : 85% - Total Page Size : 0.92 Mb - Requests : 37
It's therefore of no use, trying to assist, because you want it to look, as it does,
and so, you'll have to accept, what you get in return, there is no way around it.
At least not, as long as the Web Instrastucture is not ready yet, to handle such
great big amounts of data in a better way.
Good Luck !
Ernie

For Sale: Turnkey URLs with Opencart installed
Present Opencart LIGHT Testsite: http://www.velomech.ch
Attacker IP Blocks are denied from further access to my Sites!
Just contact me for more Information at: jti@jacob.ch
730+ FREE OC Extension-Repositories - from OC v.1.5.x up
on the largest Opencart-Mod Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by uksitebuilder » Sun Feb 17, 2019 4:35 pm

You want lots of images on your homepage and to get the requests down on initial page load, of course methods exist currently to do that.

You should look into Lazy loading of images, critical CSS, and possibly service worker integration.

Almost turning the site into a progressive web app

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by ForgedGround » Sun Feb 17, 2019 5:19 pm

Thx people...i talked to my host, mod_deflate is enabled....but i don't know if working on my site...

Anyway...i took down the blog, reduced the Latest products, removed the featured carousel, the footer logo, and some "blocks" i had...site looking "naked", but...

Performance Scores
PageSpeed Score : (60%)
YSlow Score : (60%)

Page Details
Fully Loaded Time : 4.8s
Total Page Size : 1.80MB
Requests : 70

That's a huge diference....

How can i check if mod_deflate is working?

New member

Posts

Joined
Sat Aug 04, 2018 4:36 am

Post by straightlight » Sun Feb 17, 2019 11:16 pm

ForgedGround wrote:
Sun Feb 17, 2019 5:19 pm
How can I check if mod_deflate is working?
how to check mod_deflate is enabled in apache?: https://stackoverflow.com/questions/970 ... -in-apache

By Googling it.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ForgedGround » Tue Feb 19, 2019 3:47 am

I tested both mobile and desktop, on the same page : http://www.whatsmyip.org/http-compression-test

This issue i founded :

http://forgedxxxxx.com is beeing compressed
https://forgedxxxxxx.com NOT COMPRESSED

Any ideeas?

New member

Posts

Joined
Sat Aug 04, 2018 4:36 am

Post by straightlight » Tue Feb 19, 2019 5:17 am

Your zlib.output_compression setting must probably be off in your php.ini file. Follow the first post of this site to know how to set it on: https://premium.wpmudev.org/forums/topi ... ot-working

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ForgedGround » Wed Feb 20, 2019 3:47 am

This is what i found in my php info :

https://ibb.co/yNxLQJQ

New member

Posts

Joined
Sat Aug 04, 2018 4:36 am

Post by straightlight » Wed Feb 20, 2019 6:22 am

Then, you found the issue. The output compression is set to off and the compression level is currently at - 1. Contact your host with those readings and request assistance on their behalf to enable these options for your domain.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ForgedGround » Thu Feb 21, 2019 3:54 am

ForgedGround wrote:
Sun Feb 17, 2019 5:19 pm
Thx people...i talked to my host, mod_deflate is enabled....but i don't know if working on my site...

Anyway...i took down the blog, reduced the Latest products, removed the featured carousel, the footer logo, and some "blocks" i had...site looking "naked", but...

Performance Scores
PageSpeed Score : (60%)
YSlow Score : (60%)

Page Details
Fully Loaded Time : 4.8s
Total Page Size : 1.80MB
Requests : 70

That's a huge diference....

How can i check if mod_deflate is working?
Done, i asked my host to activate zlib, and i added Leverage Caching in my htaccess.... and i added a Featured Block in my home page (fetish)

this is now my score :

PageSpeed Score (72%)
YSlow Score (69%)
Fully Loaded Time 6.5s
Total Page Size 3.42MB
Requests 84

New member

Posts

Joined
Sat Aug 04, 2018 4:36 am

Post by IP_CAM » Thu Feb 21, 2019 4:43 am

Well, for the remaining 15-20% of both GTMetrix Values, to belong to the
speedier OC-Sites, you have to look for the solution on the GTMetrix Testsite
itself, since you seemengly want to avoid to show aUrl here, for what reason
ever.
Good Luck
Ernie

For Sale: Turnkey URLs with Opencart installed
Present Opencart LIGHT Testsite: http://www.velomech.ch
Attacker IP Blocks are denied from further access to my Sites!
Just contact me for more Information at: jti@jacob.ch
730+ FREE OC Extension-Repositories - from OC v.1.5.x up
on the largest Opencart-Mod Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by ForgedGround » Fri Feb 22, 2019 5:35 am

Well IP_CAM, i dont post my domain because of my past experience....

1 time i did...and i got 100 shitty accounts testing the site with fake infos, orders, and whatever....

But i sent you a PM...you more than welcome to check it out....

New member

Posts

Joined
Sat Aug 04, 2018 4:36 am

Post by IP_CAM » Fri Feb 22, 2019 1:49 pm

Well, I don't believe it, but this Forum works again, I can even add Smilies and
use Quotations, Links, and other Gizmos, by clicking a link again, like it used to
be, some Moon's ago ... ::)

UPDATE: In the Forum Back Section, still not everything works, as I just found out .... :choke:
---
And to you, it's clearly shown on GTMETRIX.COM, what's still missing
to add a little more Performance to your Site. I just added a few parts to the image below.
Otherways, it's a nice Site, I assume, that a Market might exist in my Country for such...
Ernie
PS: And to the stinkers, I welcome them, but just to further keep 'em out for good,
and I'm getting better, day by day. But no-one yet was able to ruin one of my sites,
and that makes me feel good too.
I always look at such from the positive side, because without them, I just would not
know, how solid that code really is ... :laugh:
---
Image

Attachments

Performance_result_gtmetrix_com.jpg

Performance_result_gtmetrix_com.jpg (400.72 KiB) Viewed 321 times


For Sale: Turnkey URLs with Opencart installed
Present Opencart LIGHT Testsite: http://www.velomech.ch
Attacker IP Blocks are denied from further access to my Sites!
Just contact me for more Information at: jti@jacob.ch
730+ FREE OC Extension-Repositories - from OC v.1.5.x up
on the largest Opencart-Mod Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by ForgedGround » Sun Feb 24, 2019 4:25 pm

Thx IP_CAM for not showing my url...hahahaha

Where the hell in Switzerland are you? I lived 14 years in Interlaken, you been there?

Well, i will work on the other optimizations, that's for sure, but the biggest flaw is fixed (i think).

In Portugal/Spain/France/Italy/Germany and a shit load of others countries, you don't believe this market....in a company i work, we make easy 15.000€/week, (fxxxxxxxxx.com) is my solo project....more focus to quality and quality clients...

We do sell dozens to Switzerland too...but the transport is a major issue....expensive as fxxxk....

New member

Posts

Joined
Sat Aug 04, 2018 4:36 am

Post by IP_CAM » Mon Feb 25, 2019 10:56 am

Well, good for you, Interlaken is a nice Place, but rather expensive.
I was not there for Decades anymore, since I had no reason to go there.
It's not much fun anymore, to use our freeways, due to the steady traffic,
and no political Majority, to do anything about it. I live near Lenzburg,
and my (Adult-) Club, the lovely EFA Dreamland, is located in Wettingen.
And with the unfamous BAREGG Tunnel in between, you can imagine, how
pissed I get, at least once, every single day, due to the traffic.
So much to Switzerland, it used to be a great place, but it's a while since ...
---
I will send you a copy of my .htaccess file by PM. Make sure, to have the
RewriteBase /shop/ Path set to RewriteBase /, if you run
your Shop out of the Site ROOT Section. Then, you will find out, if this
one add's a little to Performance. Other adjustments would be, to
LINK the header file links by http(s), if your Shop runs as http(s)/www. ,
and 'javascript-link' the jquery-2.1.1.min.js, as shown on the image
below, and make all images 'cookie-free', by following the Info on the Pages,
linked here:
viewtopic.php?f=119&t=207572&p=737130&h ... ee#p737130
viewtopic.php?f=20&t=172286&p=653220&hi ... ee#p653220
---
And with a decent Theme, you should end up near 90/90 on a 20-product category
Page, as long as not not plastered with shiny + good for nothing surplus crab Code.
Set the Admin System Compression to ZERO, since the .htaccess file does that already.
Try it out, and come back, to tell us about ! :D
Ernie
---
download/file.php?mode=view&id=36544

Attachments

cookiefree_linking.jpg

cookiefree_linking.jpg (136.49 KiB) Viewed 243 times


For Sale: Turnkey URLs with Opencart installed
Present Opencart LIGHT Testsite: http://www.velomech.ch
Attacker IP Blocks are denied from further access to my Sites!
Just contact me for more Information at: jti@jacob.ch
730+ FREE OC Extension-Repositories - from OC v.1.5.x up
on the largest Opencart-Mod Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 20 guests