Post by Harry881 » Thu Feb 14, 2019 8:22 pm

Hi guys,

I have a site base on opencart that a friend did for me and last week he started a new job and quit providing web services.
Since then (I don't know if I did something) but I get this error once I visit a product page in the front-end :

Warning: count(): Parameter must be an array or an object that implements Countable in /home/themename/public_html/catalog/model/tool/path_manager.php on line 41Warning: count(): Parameter must be an array or an object that implements Countable in /home/themename/public_html/catalog/model/tool/path_manager.php on line 41

And when I check the error log in the back-end I get like 140 pages of errors like :

PHP Notice: Undefined variable: color_styles in /home/themename/public_html/catalog/view/theme/journal2/template/journal2/men u/main.tpl on line 27

PHP Notice: Undefined index: route in /home/themename/public_html/vqmod/vqcache/vq2- system_storage_modification_catalog_controller_startup_seo_url.php on line 231

PHP Warning: count(): Parameter must be an array or an object that implements Countable in /home/themename/public_html/catalog/model/tool/path_manager.php on line 41

Can these errors be due to wrong php version from the cPanel ?

Regards,
Harry

Newbie

Posts

Joined
Thu Feb 14, 2019 8:12 pm

Post by IP_CAM » Thu Feb 14, 2019 11:15 pm

Well, that COUNTABLE Problem has something to do with PHP v.7, meaning,
that you use a 'path_manager' Extension, not able to function with PHP v.7.x.
You therefore probably require Pro Support, to solve your Problems.
Good Luck!
Ernie

I'm no longer quite active at the Forum, to reach me, better contact: jti@jacob.ch
My free Opencart LIGHT 1.5.6.5 Code is available on GitHub soon,
a Demoversion of it can be seen in Action here: http://www.bigmax.ch
930+ FREE OC Extension-Repositories - from OC v.1.5.x up, on the
world's largest OC-related Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by jlaframboise » Fri Feb 15, 2019 1:42 am

Did you just upgrade your version of php? That will break things sometimes. Check with your hosting provider if you didn't change it yourself.

Newbie

Posts

Joined
Thu Dec 27, 2018 10:39 am

Post by paulfeakins » Fri Feb 15, 2019 5:33 pm

Sounds like you could do with someone to turn to for OpenCart support - we provide this as do many others in the Commercial Support Forum.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom
Who is online

Users browsing this forum: No registered users and 11 guests