Post by xairflyer » Tue Feb 12, 2019 10:53 pm

I have got all done with my hosting in regard to setting up the SSL, I have modified both config files and turned on SSL in admin panel and when I select my store from inside the admin panel it opens up showing https and I can view the cert, however it still shows http and not secure when I try it by simply opening a new tab, Its the same with firefox, IE, chrome and my phone.

New member

Posts

Joined
Sun Jan 11, 2015 8:58 am

Post by xxvirusxx » Tue Feb 12, 2019 11:12 pm

Post you website URL.

Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - RO

Post by xairflyer » Tue Feb 12, 2019 11:28 pm


New member

Posts

Joined
Sun Jan 11, 2015 8:58 am

Post by xxvirusxx » Tue Feb 12, 2019 11:31 pm

You problem is .htaccess redirect issue from www and non www to https://.

First try to add something like this in .htaccess

Code: Select all

RewriteCond %{HTTPS} off
RewriteCond %{HTTP_HOST} ^.*$
RewriteRule ^/?$ "https\:\/\/www\.3dlasercraft\.com\/" [R=301,L]
And if not woking remove that lines and try this

Code: Select all

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - RO

Post by xairflyer » Wed Feb 13, 2019 8:46 pm

Thanks for taking time to reply
when I add either of those lines site stops working but maybe my fault for how I added lines

my htaccess
# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

New member

Posts

Joined
Sun Jan 11, 2015 8:58 am

Post by xairflyer » Thu Feb 14, 2019 10:51 pm

I have tried this as well but still not working, but unsure if I am adding the lines to the htaccess file correctly
RewriteEngine On
RewriteCond %{HTTP_HOST} ^3dlasercraft\.com [NC]
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.3dlasercraft.com/$1 [R=301,L]

New member

Posts

Joined
Sun Jan 11, 2015 8:58 am

Post by tdaubs » Fri Feb 15, 2019 4:09 am

Try this...
RewriteEngine On
RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteRule ^(.*) http://www.%{SERVER_NAME}%{REQUEST_URI} [L,R=301]
RewriteCond %{HTTPS} off
RewriteRule ^(.*) https://%{SERVER_NAME}%{REQUEST_URI} [L,R=301]

Image
Opencart Support . Opencart Galaxy . Buy Me a Coffee?


User avatar
Active Member

Posts

Joined
Fri Apr 08, 2011 4:51 am
Location - Southern California

Post by xairflyer » Sun Feb 17, 2019 11:02 pm

Thanks but for some reason now https is showing on all platforms with no change to htaccess

New member

Posts

Joined
Sun Jan 11, 2015 8:58 am

Post by tdaubs » Wed Feb 20, 2019 12:15 am

Yes, you want an all https site. Not just for checkout and admin but across all pages. It will help the site rank better in Google.

Image
Opencart Support . Opencart Galaxy . Buy Me a Coffee?


User avatar
Active Member

Posts

Joined
Fri Apr 08, 2011 4:51 am
Location - Southern California
Who is online

Users browsing this forum: No registered users and 9 guests