Post by bagstage » Thu Jan 31, 2019 7:15 pm

Hallo zusammen,
ich habe unseren Shop umgezogen in den subfolder /shop/. Die .htaccess und die beiden config.php Dateien habe ich angepasst.

Beim Aufruf der Startseite werden die Bilder nicht geladen und beim Zugriff auf eine Produktseite oder Kategorieseite kommt folgende Fehlermeldung:

300 Multiple Choices
The document name you requested (/index.php) could not be found on this server. However, we found documents with names similar to the one you requested....

Die .htaccess sieht so aus:

RewriteBase /shop/
RewriteCond %{HTTP_HOST} ^xxxxx.de$ [NC]
RewriteRule ^(.*)$ https://www.xxxxx.de/$1 [L,R=301]

RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.xxxxx.de/shop/$1 [R=301,L]

Hat jemand ne Idee?

LG
Last edited by bagstage on Fri Feb 08, 2019 6:27 pm, edited 1 time in total.

Opencart Version: 2.3.0.2
PHP 7.2.18
https://bagstage.de/shop/


User avatar
Newbie

Posts

Joined
Wed Jan 30, 2019 5:31 pm
Location - Düsseldorf

Post by IP_CAM » Thu Jan 31, 2019 11:19 pm

ich würde es einfach mal so probieren:

Code: Select all

# SEO URL Settings
RewriteEngine On
RewriteCond %{HTTP_HOST} ^xxxxx.de$ [NC]
RewriteRule ^(.*)$ https://www.xxxxx.de/$1 [L,R=301]

RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.xxxxx.de/shop/$1 [R=301,L]

RewriteBase /shop/
Aber ohne genaue Angabe über die OC Version kommst Du hier
im Allgemeinen nicht sehr viel weiter.
Ernst

I'm no longer quite active at the Forum, to reach me, better contact: jti@jacob.ch
My free Opencart LIGHT 1.5.6.5 Code is available on GitHub soon,
a Demoversion of it can be seen in Action here: http://www.bigmax.ch
930+ FREE OC Extension-Repositories - from OC v.1.5.x up, on the
world's largest OC-related Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by bagstage » Fri Feb 01, 2019 8:45 pm

Hallo,

OC-Version ist 2.2.0.0.

Ich habe es jetzt so eingetragen, weil wir von www. auf non-www weiterleiten:
RewriteEngine On
RewriteBase /shop/

RewriteCond %{HTTP_HOST} ^www\.xxx\.de$ [NC]
RewriteRule (.*) https://xxx.de/$1 [R=301,L]

RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://xxx.de/shop/$1 [R=301,L]

Leider klappt das auch nicht :-(

Opencart Version: 2.3.0.2
PHP 7.2.18
https://bagstage.de/shop/


User avatar
Newbie

Posts

Joined
Wed Jan 30, 2019 5:31 pm
Location - Düsseldorf

Post by OSWorX » Sat Feb 02, 2019 5:31 am

Sehe dass jetzt alles funktioniert, Problem scheint gelöst zu sein?
Wenn ja, bitte 1. Beitrag mit [GELÖST] in Überschrift markieren - danke.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88
Dedicated Support: https://dedicated.opencart.com/
Marketplace Support: https://www.opencart.com/index.php?rout ... rt/support
Documentation: http://docs.opencart.com/en-gb/extension/theme/

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by bagstage » Mon Feb 04, 2019 5:13 pm

Nee, es funktioniert leider nicht - das Problem besteht immer noch ....

Opencart Version: 2.3.0.2
PHP 7.2.18
https://bagstage.de/shop/


User avatar
Newbie

Posts

Joined
Wed Jan 30, 2019 5:31 pm
Location - Düsseldorf

Post by OSWorX » Mon Feb 04, 2019 11:00 pm

Also wenn ich mit FF 65 den Shop aufrufe, sehe ich da keine Meldungen oder Probleme.
Aber vielleicht bin ich auch auf der falschen Seite ..

Und was die .htaccess betrifft, würde ich das hier verwenden:

Code: Select all

# Force ssl
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]

# www > non-www (http)
RewriteCond %{HTTP_HOST} ^www\.meine-seite\.de$ [NC]
RewriteRule ^(.*)$ http://meine-seite.de/$1 [L,R=301]

# www > non-www (https)
RewriteCond %{HTTP_HOST} ^www\.meine-seite\.de$ [NC]
RewriteRule ^(.*)$ https://meine-seite.de/$1 [L,R=301]
p.s.: https verwendet Port 443 und nicht 80

Forum Rules [en]: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88
Dedicated Support: https://dedicated.opencart.com/
Marketplace Support: https://www.opencart.com/index.php?rout ... rt/support
Documentation: http://docs.opencart.com/en-gb/extension/theme/

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by bagstage » Tue Feb 05, 2019 5:14 pm

Hallo, danke für die Antworten ... leider funktionieren obige .htaccess Angaben auch nicht. In Chrome erhalte ich jetzt einen 500 Error und in Fire forx eine weiße Seite. Der Shop liegt unter https://bagstage.de/shop/.

Der aktuelle Shop läuft auf einer anderen Domain ohne Probleme mit folgender .htaccess
RewriteEngine On
RewriteBase /

RewriteCond %{HTTP_HOST} ^www\.bagstage24\.de$ [NC]
RewriteRule (.*) https://bagstage24.de/$1 [R=301,L]

RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://bagstage24.de/$1 [R=301,L]

Dieser Shop soll nun unter https://bagstage.de/shop/ laufen .... Ich dachte ich passe dazu einfach die .htaccess wie folgt an - das klappt aber leider nicht ...

RewriteEngine On
RewriteBase /shop/

RewriteCond %{HTTP_HOST} ^www\.bagstage\.de$ [NC]
RewriteRule (.*) https://bagstage.de/$1 [R=301,L]

RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://bagstage.de/$1 [R=301,L]

Opencart Version: 2.3.0.2
PHP 7.2.18
https://bagstage.de/shop/


User avatar
Newbie

Posts

Joined
Wed Jan 30, 2019 5:31 pm
Location - Düsseldorf

Post by OSWorX » Wed Feb 06, 2019 4:24 pm

Weiße Seite bzw. Fehler 500 kann alles möglich sein - leider!
Am besten folgendes entweder in die index.php oder startup.php an den Anfang einfügen (danach wieder löschen!):

Code: Select all

error_reporting( E_ALL );
ini_set( 'error_reporting', E_ALL );
ini_set( 'display_errors', 'On' );
Damit sollte alles sichtbar werden was Fehler erzeugt.
Denn ansonsten kommen wir da nicht weiter, die .htaccess sollte passen - da stimmt etwas anderes nicht.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88
Dedicated Support: https://dedicated.opencart.com/
Marketplace Support: https://www.opencart.com/index.php?rout ... rt/support
Documentation: http://docs.opencart.com/en-gb/extension/theme/

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by bagstage » Wed Feb 06, 2019 10:25 pm

Hallo,

jetzt kommt folgender Fehler:

Fatal error: Uncaught Error: Call to undefined function DB\mysql_connect() in /homepages/42/d521432471/htdocs/corp-dev/shop/system/library/db/mysql.php:14 Stack trace: #0 /homepages/42/dbase/htdocs/corp-dev/shop/system/library/db.php(9): DB\MySQL->__construct('localhost:/tmp/...', 'dbo', 'passwort...', 'dbase', '') #1 /homepages/42/d521432471/htdocs/corp-dev/shop/system/framework.php(25): DB->__construct('mysql', 'localhost:/tmp/...', 'dbo', 'passwort', 'dbase', '') #2 /homepages/42/d521432471/htdocs/corp-dev/shop/index.php(58): require_once('/homepages/42/d...') #3 {main} thrown in /homepages/42/d521432471/htdocs/corp-dev/shop/system/library/db/mysql.php on line 14

Opencart Version: 2.3.0.2
PHP 7.2.18
https://bagstage.de/shop/


User avatar
Newbie

Posts

Joined
Wed Jan 30, 2019 5:31 pm
Location - Düsseldorf

Post by OSWorX » Thu Feb 07, 2019 4:33 pm

Dann ist mal soweit klar woher die weiße Seite bzw. der Fehler 500 kommt.
Ausbessern und gut ist (was das betrifft).

Was dann aber noch immer nicht das Grundproblem beheben wird.
Leider wurde nirgends angeführt welche
1. OpenCart Version
2. php-Version
3. installierte Erweiterungen
4. Vorlage
verwendet werden.

Daher ist jede weitere Hilfe schwer.

Unabhängig davon sollte mysql nicht mehr verwendet werden - nur mehr mindestens mysqli
Zudem - schon aus Geschwindigkeitsgründen und Sicherheit - ebenso php 7.2.x

Und für eine allgemeine Hilfestellung hier im Forum denke ich, wurde genug gemacht.
Entweder eine Anfrage an einen vertrauten Entwickler senden oder im kommerziellen Forum hier ein neue Anfrage machen.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88
Dedicated Support: https://dedicated.opencart.com/
Marketplace Support: https://www.opencart.com/index.php?rout ... rt/support
Documentation: http://docs.opencart.com/en-gb/extension/theme/

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria
Who is online

Users browsing this forum: No registered users and 1 guest