Post by imdevlper18 » Thu Aug 23, 2018 1:54 pm

I would like to know if something can be done about this issue.
Ocmod does not work on 3.0.x version if the theme uses the TPL file format.

So a lot of extensions that adds code on the front end on the twig file won't work.
This is actually because the theme is not following the standard for 3.0.x version which is a twig.

I even contacted the theme developer. One said he will need to build from scratch for making into a twig.
Now for this themes which are unlimited and different. Extension developers have to provide extra support. Though not our issue.

So is there any good way to overcome this? I am currently doing this via creating the VQMOD for this themes.

Opencart Extensions | Professional opencart support | Support Ticket | support@cartbinder.com


User avatar
Active Member

Posts

Joined
Sun May 11, 2014 2:04 pm

Post by thekrotek » Thu Aug 23, 2018 3:00 pm

Just add a code for TWIG in your OCMod, no big deal.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member
Online

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by xxvirusxx » Thu Aug 23, 2018 3:05 pm

@imdevlper18

But if you use that extension for .tpl files (prevision version 2.3.0.2), doesn`t work on 3.x with that theme?

Opencart 2.3.0.2 Bugs Fix Added | Opencart 2.3.0.2 Custom Version | Opencart 3.0.3.1 Bugs Fix Added


Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - RO

Post by imdevlper18 » Thu Aug 23, 2018 3:35 pm

thekrotek wrote:
Thu Aug 23, 2018 3:00 pm
Just add a code for TWIG in your OCMod, no big deal.
I will explain again to avoid confusion. I have a module which adds features on the product page. It's of course designed for twig. Added via ocmod.
But theme does not have twig file. So it won't work.
If you create an ocmod for TPL file it won't work still. Check reason below:

Well, I tried that. It also creates the modification cache for TPL file. I verified the cache file in storage modification folder.
Still, it would pick the original TPL file present in catalog/view/theme folder. And not from cache.

The reason for this I believe is no code is added to pick cache file from storage folder for TPL format.
And it works via VQMOD. So VQMOD has the code to check TPL cache file.

I also understand its not big deal. It's an easy fix.

Still creating a separate code for TPL format is another work for the extension developer. Be it vqmod or ocmod.
Also increases the ocmod file size. Maintenance work increases when new features come.
As you now need to add all things in both the codes TPL and twig.

Opencart Extensions | Professional opencart support | Support Ticket | support@cartbinder.com


User avatar
Active Member

Posts

Joined
Sun May 11, 2014 2:04 pm

Post by imdevlper18 » Thu Aug 23, 2018 3:38 pm

xxvirusxx wrote:
Thu Aug 23, 2018 3:05 pm
@imdevlper18

But if you use that extension for .tpl files (prevision version 2.3.0.2), doesn`t work on 3.x with that theme?
Sorry did not get you.

Opencart Extensions | Professional opencart support | Support Ticket | support@cartbinder.com


User avatar
Active Member

Posts

Joined
Sun May 11, 2014 2:04 pm

Post by thekrotek » Thu Aug 23, 2018 3:41 pm

But OC 3 should process TWIG files out of the box, which means your module should be processed properly without any tweaks. This is your template, which requires TPL processing, but I assume you already have it added to your store.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member
Online

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by xxvirusxx » Thu Aug 23, 2018 3:46 pm

imdevlper18 wrote:
Thu Aug 23, 2018 3:38 pm
Sorry did not get you.
You said that you use opencart 3.0.2.0.
You said that template is .tpl (theme for prevision oc: 2.3.0.2)

If you use extension X who read code from .twig, that extension doesn`t have a version for 2.3.0.2? ( tpl files) to see if work on that theme (tpl theme)

Opencart 2.3.0.2 Bugs Fix Added | Opencart 2.3.0.2 Custom Version | Opencart 3.0.3.1 Bugs Fix Added


Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - RO

Post by imdevlper18 » Thu Aug 23, 2018 3:47 pm

thekrotek wrote:
Thu Aug 23, 2018 3:41 pm
But OC 3 should process TWIG files out of the box, which means your module should be processed properly without any tweaks.
Well, Yes, the extension shall work fine when the template is using TWIG format.
It has worked well already on themes that use twig format. Ex: Journal Theme is using Twig.
So no issues with them.
thekrotek wrote:
Thu Aug 23, 2018 3:41 pm
This is your template, which requires TPL processing, but I assume you already have it added to your store.
It's another template which is designed for 3.x version and is designed using TPL format.
If the template is using TPL format. The extension won't work with ocmod which is what I am trying to say.
You need to create a new VQMOD patch file for that.

Opencart Extensions | Professional opencart support | Support Ticket | support@cartbinder.com


User avatar
Active Member

Posts

Joined
Sun May 11, 2014 2:04 pm

Post by imdevlper18 » Thu Aug 23, 2018 3:52 pm

xxvirusxx wrote:
Thu Aug 23, 2018 3:46 pm
If you use extension X who read code from .twig, that extension doesn`t have a version for 2.3.0.2? ( tpl files) to see if work on that theme (tpl theme)
Okay. You are asking me to install the 2.3.x version of extension on this theme.

No. Because there are other things like token name change and restrictions to a certain directory.
And 2.3.x version cannot be installed without doing those changes.

Thanks for pointing out in this direction.

Opencart Extensions | Professional opencart support | Support Ticket | support@cartbinder.com


User avatar
Active Member

Posts

Joined
Sun May 11, 2014 2:04 pm
Who is online

Users browsing this forum: No registered users and 20 guests