Post by adensoft » Mon May 07, 2018 4:06 pm

i have this error when i try log to admin page

Code: Select all

Parse error: syntax error, unexpected 'DIR_APPLICATION' (T_STRING), expecting ',' or ')' in /home/a5eell/public_html/admin/config.php on line 11
my admin config.php

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'http://www.tafassell.com/admin/');
define('HTTP_CATALOG', 'http://www.tafassell.com/');

// HTTPS
define('HTTPS_SERVER', 'https://www.tafassell.com/admin/');
define('HTTPS_CATALOG', 'https://www.tafassell.com/);

// DIR
define('DIR_APPLICATION', '/home/a5eell/public_html/admin/');
define('DIR_SYSTEM', '/home/a5eell/public_html/system/');
define('DIR_IMAGE', '/home/a5eell/public_html/image/');
define('DIR_STORAGE', '/home/a5eell/storage/');
define('DIR_CATALOG', '/home/a5eell/public_html/catalog/');
define('DIR_LANGUAGE', DIR_APPLICATION . 'language/');
define('DIR_TEMPLATE', DIR_APPLICATION . 'view/template/');
define('DIR_CONFIG', DIR_SYSTEM . 'config/');
define('DIR_CACHE', DIR_STORAGE . 'cache/');
define('DIR_DOWNLOAD', DIR_STORAGE . 'download/');
define('DIR_LOGS', DIR_STORAGE . 'logs/');
define('DIR_MODIFICATION', DIR_STORAGE . 'modification/');
define('DIR_SESSION', DIR_STORAGE . 'session/');
define('DIR_UPLOAD', DIR_STORAGE . 'upload/');



Newbie

Posts

Joined
Sun May 28, 2017 7:08 pm

Post by kestas » Mon May 07, 2018 4:24 pm

Hi try to change to this:

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'http://www.tafassell.com/admin/');
define('HTTP_CATALOG', 'http://www.tafassell.com/');

// HTTPS
define('HTTPS_SERVER', 'https://www.tafassell.com/admin/');
define('HTTPS_CATALOG', 'https://www.tafassell.com/');

// DIR
define('DIR_APPLICATION', '/home/a5eell/public_html/admin/');
define('DIR_SYSTEM', '/home/a5eell/public_html/system/');
define('DIR_IMAGE', '/home/a5eell/public_html/image/');
define('DIR_STORAGE', '/home/a5eell/storage/');
define('DIR_CATALOG', '/home/a5eell/public_html/catalog/');
define('DIR_LANGUAGE', DIR_APPLICATION . 'language/');
define('DIR_TEMPLATE', DIR_APPLICATION . 'view/template/');
define('DIR_CONFIG', DIR_SYSTEM . 'config/');
define('DIR_CACHE', DIR_STORAGE . 'cache/');
define('DIR_DOWNLOAD', DIR_STORAGE . 'download/');
define('DIR_LOGS', DIR_STORAGE . 'logs/');
define('DIR_MODIFICATION', DIR_STORAGE . 'modification/');
define('DIR_SESSION', DIR_STORAGE . 'session/');
define('DIR_UPLOAD', DIR_STORAGE . 'upload/');
Cheers

Custom OpenCart modules and solutions. You can write PM with additional questions... Extensions you can find here


Active Member

Posts

Joined
Tue Oct 12, 2010 2:23 am

Post by IP_CAM » Tue May 08, 2018 1:18 am

Well, this will usually not work:

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'http://www.tafassell.com/admin/');
define('HTTP_CATALOG', 'http://www.tafassell.com/');
// HTTPS
define('HTTPS_SERVER', 'https://www.tafassell.com/admin/');
define('HTTPS_CATALOG', 'https://www.tafassell.com/');
it needs either to be http:

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'http://www.tafassell.com/admin/');
define('HTTP_CATALOG', 'http://www.tafassell.com/');
// HTTPS
define('HTTPS_SERVER', 'http://www.tafassell.com/admin/');
define('HTTPS_CATALOG', 'http://www.tafassell.com/');
or https:

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'https://www.tafassell.com/admin/');
define('HTTP_CATALOG', 'https://www.tafassell.com/');
// HTTPS
define('HTTPS_SERVER', 'https://www.tafassell.com/admin/');
define('HTTPS_CATALOG', 'https://www.tafassell.com/');
Ernie

I am no longer active at this Forum.
Please don't send Personal Messages, contact: jti@jacob.ch
---
Github OC Downloads: https://github.com/IP-CAM
2'000+ FREE OC Extensions from the World's largest Github OC Archive.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by uksitebuilder » Tue May 08, 2018 4:27 am

Sorry Ernie, that is incorrect.

However, it is not used much these days as people prefer to either have full SSL or no SSL at all.

The error was simply on line 8 not having a closing single quote after the URL.

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by kestas » Tue May 08, 2018 4:38 am

uksitebuilder wrote:
Tue May 08, 2018 4:27 am

The error was simply on line 8 not having a closing single quote after the URL.
Correct

Cheers

Custom OpenCart modules and solutions. You can write PM with additional questions... Extensions you can find here


Active Member

Posts

Joined
Tue Oct 12, 2010 2:23 am

Post by IP_CAM » Tue May 08, 2018 4:57 am

Well, sorry about that, but in some Files, only SSL Linking is used, and
if those links are not rerouted, if http only is used, this would lead to
problems, I assume. That's, where my 'understanding of this' started, and
it seemed to be logical, to avoid this, by use of, what I mentioned above.
But I am not a Coder, I could therefore be far off track... :D
Ernie
---
Samples:

Code: Select all

$this->data['checkout'] = $this->url->link('checkout/checkout', '', 'SSL');
$this->data['account'] = $this->url->link('account/account', '', 'SSL');

I am no longer active at this Forum.
Please don't send Personal Messages, contact: jti@jacob.ch
---
Github OC Downloads: https://github.com/IP-CAM
2'000+ FREE OC Extensions from the World's largest Github OC Archive.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by uksitebuilder » Tue May 08, 2018 5:32 am

Since the early days of OpenCart, if SSL is enabled, it only ever protected the 'my account' and 'checkout' sections of the store.

All standard pages, products and categories never ran through SSL.

That has not changed even today, however, people force SSL if they have it enabled to work on all pages.

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by paulfeakins » Tue May 08, 2018 6:53 pm

uksitebuilder wrote:
Tue May 08, 2018 5:32 am
That has not changed even today, however, people force SSL if they have it enabled to work on all pages.
Yeah, best to have it on all pages.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom
Who is online

Users browsing this forum: No registered users and 30 guests