Post by giancarlo64 » Mon Apr 02, 2018 1:18 pm

Ok,
it works if I download the extension locally to my PC and after I install it uploading it to my OC.

New member

Posts

Joined
Tue Jun 27, 2017 6:30 pm

Post by Dsignjewlry » Wed Sep 26, 2018 5:55 am

I had an issue with the API settings saving after i input them. This is apparently a permissions issue where the web server does have the ability to write the string to wherever it was stored. To solve this issue i changed the owner of the entire installation to the user that apache is running as.
For ubuntu this would be
sudo chown -R www-data:www-data /var/www/html

for fedora based servers it would be

Code: Select all

sudo chown -R apache:apache /var/www/html
(or wherever your opencart install is)
Last edited by straightlight on Tue Apr 21, 2020 1:47 am, edited 1 time in total.
Reason: Added code tags.

Newbie

Posts

Joined
Wed Sep 26, 2018 2:33 am

Post by rj-10x » Wed Sep 26, 2018 11:06 pm

Hello.

Guys I have SOLUTION:
Step 1. Go to www.opencart.com and sign up. After that you will have a username or login: http://prntscr.com/kz05mk
Step 2. Make a password. Go to your account, click the "Your Stores -- Register your store to access the marketplace API" http://prntscr.com/kz07u7 Add your store by typing only URL without any http or https or www only the domain name. After that you will have a password: http://prntscr.com/kz0a1j

Newbie

Posts

Joined
Mon Jul 09, 2018 10:52 pm

Post by MasterCATZ » Wed May 15, 2019 5:47 am

Tired adding store does not provide any user / password for api ?

Newbie

Posts

Joined
Mon May 13, 2019 4:58 pm

Post by benli » Sat Aug 24, 2019 2:08 am

Not a bug!!!
Press the settings button in the marketplace page (top right).
Fill in opencart.com username. In your opencart.com account go to "your stores".
Press "add store"
Fill in domain or ip.
save
view
copy key and paste in the marketplace popup.

Good luck

Newbie

Posts

Joined
Sat Dec 12, 2015 10:16 pm

Post by islam store » Fri Sep 27, 2019 9:21 pm

Hello
I have the same problem and found the solution
In your OpenCart account
Add the URL as it appears on your site
If it's with www
Write it completely like this www.yoursite.com
And if not with www
Type it as yoursite.com

Good luck

Newbie

Posts

Joined
Tue Mar 14, 2017 5:06 am

Post by klaviyojad » Fri Aug 07, 2020 10:42 pm

I had the same issue as many of the folks here but figured it out. I am running OpenCart on a MAMP Server and use an internal hostname and port number 8888.

So for the registration on opencart.com I had to also add :8888 to the hostname for it to work. The hostname alone did not cut it

Newbie

Posts

Joined
Fri Aug 07, 2020 1:58 am
Who is online

Users browsing this forum: No registered users and 6 guests