Post by Springtime » Tue Feb 20, 2018 1:00 am

Hi everyone,

I've resized all my photos to fit the exact dimensions they are supposed to display at (500x500px) but whenever I click on a product and go into the product page, the first image that is displayed is always blurry. Then if I click another image in the series, they all display clearly. And if I then click on the first image again, it displays clearly as well.

I've attached two images to show how it looks different (Blurry at first right when the page loads... then clear after clicking on another image and then back to the first again).

Is this just a glitch or is there a setting or mod that can pre-load the image so it displays clearly from the beginning?

Or perhaps it's an image preparation issue? Although they're just standard JPEGs at a quality is set to about 9 or 10.

Thoughts?

Using OC version 3.0.2.0 - Theme is Journal 2

Thanks!

Attachments

ThenClearAfterClicking.png

ThenClearAfterClicking.png (1.46 MiB) Viewed 587 times

BlurryAtFirst.png

BlurryAtFirst.png (980.38 KiB) Viewed 587 times


Newbie

Posts

Joined
Tue Feb 13, 2018 6:08 am

Post by IP_CAM » Tue Feb 20, 2018 2:35 am

You should better link your Shop Site, everything else is just wild guessing.
Ernie

I'm rarely still active at the OC Forum. To reach me, contact: jti@jacob.ch
A Demoversion of my free OpenCart LIGHT v.1.5.6.5 Software Edition
can be seen in real Action here: http://www.jti.li/shop/
---
1'000+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Springtime » Wed Feb 21, 2018 4:08 am


Newbie

Posts

Joined
Tue Feb 13, 2018 6:08 am

Post by Springtime » Wed Feb 21, 2018 4:27 am

Figured it out.

It was the setting in Extensions>Extensions>Themes>Edit where you have to change the "Product Image Thumb Size"

The word Thumb was throwing me off. It made me this this was a setting for a smaller thumbnail picture on the site, not the actual product image gallery that is displayed with each product. But that's what it was. I had to increase the dimensions of the "Product Image Thumb Size" and now the primary image of each product is displayed nice and crisp immediately upon entering the page.

Ta da!

Newbie

Posts

Joined
Tue Feb 13, 2018 6:08 am
Who is online

Users browsing this forum: otd and 27 guests