Post by lavieverte » Sat Aug 19, 2017 7:52 pm

I am using Opencart 2.3.0.2, and have hosted it on Hostinger. I have been trying to configure the hosting site email on Opencart but failed. It only works when the Mail Protocol is set as Mail but not SMTP. I prefer to use SMTP as the problem of sending system emails via Mail is that the email headers will say the email is sent from the website hosting name instead of my actual domain name. However, the following msg is always shown after submitting Contact Form when Mail is choose:

Warning: fsockopen(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/u729687566/public_html/test/system/library/mail.php on line 167Warning: fsockopen(): unable to connect to ssl://mx1.hostinger.com :587 (php_network_getaddresses: getaddrinfo failed: Name or service not known) in /home/u729687566/public_html/test/system/library/mail.php on line 167
Fatal error: Uncaught Exception: Error: php_network_getaddresses: getaddrinfo failed: Name or service not known (0) in /home/u729687566/public_html/test/system/library/mail.php:170 Stack trace: #0 /home/u729687566/public_html/test/catalog/controller/information/contact.php(25): Mail->send() #1 /home/u729687566/public_html/test/system/engine/action.php(51): ControllerInformationContact->index() #2 /home/u729687566/public_html/test/catalog/controller/startup/router.php(25): Action->execute(Object(Registry)) #3 /home/u729687566/public_html/test/system/engine/action.php(51): ControllerStartupRouter->index() #4 /home/u729687566/public_html/test/system/engine/front.php(34): Action->execute(Object(Registry)) #5 /home/u729687566/public_html/test/system/engine/front.php(29): Front->execute(Object(Action)) #6 /home/u729687566/public_html/test/system/framework.php(103): Front->dispatch(Object(Action), Object(Action)) #7 /home/u729687566/public_html/test/system/startup.php(124): require_once('/home/u72968756...') #8 /home/u729687566/ in /home/u729687566/public_html/test/system/library/mail.php on line 170

Anyone here could help? Below is my setting. Pls kindly advise if anything is wrong.

Mail Protocol: Mail
Mail Parameters: -f xx@XXXXXX.com
SMTP Hostname: ssl://mx1.hostinger.com
SMTP Username: xx@XXXXXX.com
SMTP Password: My password
SMTP Port: 587
SMTP Timeout: 5

Hope that someone here could help!

Newbie

Posts

Joined
Mon Jul 17, 2017 1:03 am

Post by webcorvo » Thu Aug 24, 2017 7:20 pm

Try this:
Mail Parameters: xx@XXXXXX.com - remove the -
SMTP Port: 465
SMTP Timeout: 5

Opencart Developer - For custom work and support contact @ webcorvo@gmail.com


User avatar
Active Member

Posts

Joined
Mon Mar 20, 2017 11:42 pm
Location - Lisbon, Portugal

Post by lavieverte » Sun Aug 27, 2017 4:55 pm

Thanks. I at last found out that this is the server which imposes Sender Policy Framework (SPF) that blocks the access. I at last changes to another host, and email problem is well solved.

Newbie

Posts

Joined
Mon Jul 17, 2017 1:03 am

Post by webcorvo » Mon Aug 28, 2017 4:17 pm

lavieverte wrote:
Sun Aug 27, 2017 4:55 pm
Thanks. I at last found out that this is the server which imposes Sender Policy Framework (SPF) that blocks the access. I at last changes to another host, and email problem is well solved.
:)

Opencart Developer - For custom work and support contact @ webcorvo@gmail.com


User avatar
Active Member

Posts

Joined
Mon Mar 20, 2017 11:42 pm
Location - Lisbon, Portugal
Who is online

Users browsing this forum: No registered users and 37 guests