Post by caver911 » Tue Jan 31, 2017 5:30 pm

I lookthrough marketplace and see in many extensions description there is written that VQ mod is needed to be installed. So my question is, does the OC 2.3.0.2 have VQ mod as a standard installation? Or do I need to download it and install it.

Thanks for any reply....
Last edited by caver911 on Tue Jan 31, 2017 7:55 pm, edited 1 time in total.

New member

Posts

Joined
Thu Dec 15, 2016 4:36 am

Post by thekrotek » Tue Jan 31, 2017 5:51 pm

Yes, you need to install either official VQMod or Integrated VQMod. I personally prefer the latter. It should have been added to core OpenCart long time ago.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by paulfeakins » Tue Jan 31, 2017 7:37 pm

vQmod needs to be installed but essentially you just upload a folder and then browse to it.

But OpenCart does now come with OCMod which many extensions now use.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by caver911 » Tue Jan 31, 2017 7:57 pm

paulfeakins wrote:vQmod needs to be installed but essentially you just upload a folder and then browse to it.

But OpenCart does now come with OCMod which many extensions now use.
So should I install VQ mod just in case even though OCMod are standard with 2.3.0.2 version ( I assumue it is standard)?

New member

Posts

Joined
Thu Dec 15, 2016 4:36 am

Post by thekrotek » Tue Jan 31, 2017 10:11 pm

caver911 wrote:So should I install VQ mod just in case even though OCMod are standard with 2.3.0.2 version ( I assumue it is standard)?
Yes, you do. There're lots of developers, who don't use OCMod at all. It supposed to be a standard, when OC 2.0 was first released, but very few people liked it. VQMod is still a standard, not OCMod, which is a weaker version of VQMod with slightly different syntax.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by Johnathan » Tue Jan 31, 2017 11:37 pm

thekrotek wrote:Yes, you need to install either official VQMod or Integrated VQMod. I personally prefer the latter. It should have been added to core OpenCart long time ago.
I prefer the standard version. The "integrated" version loses some of the benefits of the standard vQmod, including keeping all cache files in a single directory (so it's easy to see at-a-glance which files are being modified). It's also not maintained by the actual vQmod developers, so any changes made to vQmod in the future would have a delay in being implemented.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by thekrotek » Wed Feb 01, 2017 12:31 am

Johnathan wrote:I prefer the standard version. The "integrated" version loses some of the benefits of the standard vQmod, including keeping all cache files in a single directory (so it's easy to see at-a-glance which files are being modified). It's also not maintained by the actual vQmod developers, so any changes made to vQmod in the future would have a delay in being implemented.
The biggest advantage of Integrated VQMod is static cache. Official VQMod caches files on every page load, which isn't very good in terms of loading speed. It's not a huge difference, but sill.

The rest is mostly a matter of taste. I don't like official VQMod file naming and having log files in different place is also not the best idea. But in the end it doesn't matter much :-)

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am

Who is online

Users browsing this forum: No registered users and 18 guests