Post by fmw » Fri Oct 28, 2016 12:22 am

My opencart 2.3 website is running really really slowly. So slowly that sometimes links time out. Having spent two months filling it with products I'd like to fix it rather than abandon it. I'm running on a microsoft server. The place where my web server is located thinks the problem is not with the server but with the opencart configuration. They said the site would run a little faster on a Linux server but not enough to solve the problem. They don't think opencart itself is the problem since there are many websites running successfully with it. I've installed a handful of extensions but installing them hasn't made the site materially slower. I wonder if someone else has encountered this problem and found a resolution.

fmw
New member

Posts

Joined
Tue Aug 30, 2016 7:28 am

Post by labeshops » Fri Oct 28, 2016 2:08 am

Really impossible to say without a link to your site. Make sure you disable product and category count, but without seeing anything, that's the best advice you can get really.

Running Opencart v3.0.3.2 with multi-stores from https://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by fmw » Fri Oct 28, 2016 8:33 am

Actually it turned out that is one of the factors. I'm amazed it is such a drag on performance. The gurus also found a less than optimal PHP configuration my server. It seems to be running pretty well now or at least much faster than before. The site is http://www.knifeoutlet.com if you can find anything else that is dragging down performance.

fmw
New member

Posts

Joined
Tue Aug 30, 2016 7:28 am

Post by labeshops » Sat Oct 29, 2016 1:02 am

Glad you worked out at least some of it. You might also try running a speed test on https://gtmetrix.com/ and see what suggestions they make on speeding up your site. Google also has a pagespeed tool.

Running Opencart v3.0.3.2 with multi-stores from https://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by IP_CAM » Sat Oct 29, 2016 8:22 am

I would still advise you, to move to a Linux Server, yesterday, I quick removed my posting here again, after finding out, that you are on a Microsoft Server, and my .htaccess file, displayed here, and solving many of your Performance Problems, found on GtMetrix, could not be used anyway, since MS-Servers cannot handle .htaccess the usual way.
Ernie

I am no longer active at the Forum. Please do NOT send me Personal Mails,
they will no longer be replied to.
My Github OC Site: https://github.com/IP-CAM
4'300 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by goivvy » Sun Jan 01, 2017 9:27 pm

could anybody suggest a tutorial on how to go green for page speed score? like i found for magento 2 pagespeed optimization

speed up magento by an expert


Newbie

Posts

Joined
Sun Jan 01, 2017 9:23 pm

Who is online

Users browsing this forum: No registered users and 41 guests