Post by andyd92 » Sun Jan 31, 2016 11:14 pm

Hi all

I setting up a new Opencart 2.1.0.1 site and have installed a few extensions and the journal theme.

One of the extensions (which imports products / cats from a supplier) hangs. The extension error log shows this

PHP Fatal error: Call to a member function get() on a non-object in ******/public_html/t4nb/system/engine/controller.php on line 10

I have tried replacing the controller.php with the original in case it was modified by an extension but still does not work.

Any ideas??

Thanks

Andy

New member

Posts

Joined
Tue Dec 11, 2012 1:50 am

Post by OSWorX » Sun Jan 31, 2016 11:18 pm

This controller file calls only those function requested by the extension.
Replacing the file will help .. nothing.
Either contact the author of that extension to fix the bug or check the extension controller by yourself and see what is called there.

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by andyd92 » Mon Feb 01, 2016 12:59 am

Hi,

Thanks for the reply.

The strange thing is I installed the extension which hangs onto a clean install of Opencart 2.1.0.1 and it works fine.

So I guess there must be a conflict with another extension or the theme?

Unfortunately the extension author simply told me my Opencart install must be corrupt, which is not correct as everything else is working fine. They not being much help other than that.

If I search the site for the call, what am I looking for exactly. Could it just be typo in code?

Sorry very advanced at this.....

New member

Posts

Joined
Tue Dec 11, 2012 1:50 am

Post by Randem » Mon Feb 01, 2016 9:38 am

Hi andyd92,

Unfortunately there is no quality control in the OpenCart extension store and many extension are flawed due t lack of good testing so you purchase them at your own risk and as you know support may be fleeting after they get your money...

Every third party theme I have tested is flawed. Aslo check to see if the extension & theme that you are using is for the current version of OpenCart that you are using.

More Helpful Information

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by napok » Sat Apr 23, 2016 3:34 pm

I have the same problem.
What was the solution, please?

New member

Posts

Joined
Mon Feb 11, 2013 1:46 am

Post by Randem » Sun Apr 24, 2016 4:11 am

napok wrote:I have the same problem.
What was the solution, please?
Testing... There are no shortcuts. Remove your theme and test. remove your extentions and test. Test, Test and test again until you find the problem gone and it will be the solution.

2016 - Why are there so many Terrible themes?!
Remove item issues in Checkout Cart when changing to third party themes

That should help...

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am
Who is online

Users browsing this forum: No registered users and 6 guests