Post by 4andilyn » Tue Oct 27, 2015 4:50 am

Just tried to upgrade and now I can't even get in to my Admin

Notice: Use of undefined constant DB_PORT - assumed 'DB_PORT' in /home4/andilyn/public_html/install/model/upgrade.php on line 139
Warning: mysqli::mysqli() expects parameter 5 to be long, string given in /home4/andilyn/public_html/system/library/db/mysqli.php on line 7
Warning: mysqli::set_charset(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 14
Warning: mysqli::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 15
Warning: mysqli::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 19
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 21
Notice: Trying to get property of non-object in /home4/andilyn/public_html/install/model/upgrade.php on line 146
Warning: Invalid argument supplied for foreach() in /home4/andilyn/public_html/install/model/upgrade.php on line 146
Warning: mysqli::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 19
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 21
Notice: Trying to get property of non-object in /home4/andilyn/public_html/install/model/upgrade.php on line 314
Warning: Invalid argument supplied for foreach() in /home4/andilyn/public_html/install/model/upgrade.php on line 314
Warning: mysqli::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 19
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 21
Warning: mysqli::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 19
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 21
Notice: Undefined index: oc_customer_group in /home4/andilyn/public_html/install/model/upgrade.php on line 332
Warning: in_array() expects parameter 2 to be array, null given in /home4/andilyn/public_html/install/model/upgrade.php on line 332
Notice: Undefined index: oc_product_option in /home4/andilyn/public_html/install/model/upgrade.php on line 348
Warning: in_array() expects parameter 2 to be array, null given in /home4/andilyn/public_html/install/model/upgrade.php on line 348
Warning: mysqli::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 19
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 21
Notice: Trying to get property of non-object in /home4/andilyn/public_html/install/model/upgrade.php on line 357
Warning: Invalid argument supplied for foreach() in /home4/andilyn/public_html/install/model/upgrade.php on line 357
Warning: mysqli::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 19
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 21
Notice: Trying to get property of non-object in /home4/andilyn/public_html/install/model/upgrade.php on line 368
Warning: Invalid argument supplied for foreach() in /home4/andilyn/public_html/install/model/upgrade.php on line 368
Warning: mysqli::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 19
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 21
Notice: Trying to get property of non-object in /home4/andilyn/public_html/install/model/upgrade.php on line 391
Warning: Invalid argument supplied for foreach() in /home4/andilyn/public_html/install/model/upgrade.php on line 391
Warning: mysqli::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 19
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 21
Notice: Trying to get property of non-object in /home4/andilyn/public_html/install/model/upgrade.php on line 402
Warning: Invalid argument supplied for foreach() in /home4/andilyn/public_html/install/model/upgrade.php on line 402
Warning: mysqli::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 19
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 21
Notice: Trying to get property of non-object in /home4/andilyn/public_html/install/model/upgrade.php on line 425
Warning: Invalid argument supplied for foreach() in /home4/andilyn/public_html/install/model/upgrade.php on line 425
Warning: mysqli::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 19
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 21
Notice: Trying to get property of non-object in /home4/andilyn/public_html/install/model/upgrade.php on line 441
Warning: Invalid argument supplied for foreach() in /home4/andilyn/public_html/install/model/upgrade.php on line 441
Warning: Cannot modify header information - headers already sent by (output started at /home4/andilyn/public_html/install/model/upgrade.php:139) in /home4/andilyn/public_html/system/library/response.php on line 12
Warning: mysqli::close(): Couldn't fetch mysqli in /home4/andilyn/public_html/system/library/db/mysqli.php on line 58

Newbie

Posts

Joined
Thu Apr 16, 2015 7:24 pm

Post by elorac » Thu Oct 29, 2015 1:54 am

I'm getting the same exact errors. Someone please help?

Newbie

Posts

Joined
Wed Dec 10, 2014 4:06 am

Post by elorac » Thu Oct 29, 2015 2:05 am

These errors occur when running the installation script on the upgrade as well. There is something miscoded in this upgrade. This is very frustrating. I am running PHP version 5.6.14. Opencart worked fine up until trying to upgrade to the version 2.1.0.1. Anyone who can help, it would be much appreciated.

Newbie

Posts

Joined
Wed Dec 10, 2014 4:06 am

Post by 4andilyn » Sat Oct 31, 2015 8:09 pm

apparently they do upgrades, but any form of support is non-existent even when you pay for it.

Newbie

Posts

Joined
Thu Apr 16, 2015 7:24 pm

Post by Cue4cheap » Mon Nov 02, 2015 2:57 am

Folks... please do a search on this issue in the forum... it has been answered a few times. You need to add a definition for that port in your config files....

Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by tdprado » Thu Nov 05, 2015 3:23 pm

Cue4cheap wrote:Folks... please do a search on this issue in the forum... it has been answered a few times. You need to add a definition for that port in your config files....

Mike
For us beginner users, that means very little.

Wouldn't it of been easier to just insert a link to one of the posts!

The upgrade to 2.1.0.1 should have been straight forward, not just for the seasoned programmer.

I can't understand why the Opencart team hasn't provided an update as yet to make the upgrade an easier process for ALL their users.

Steve

Newbie

Posts

Joined
Fri Jun 19, 2015 7:48 am

Post by pingpongrob » Fri Nov 13, 2015 8:57 am

I certainly agree that a link would be great, I tried to upgrade from Version 1.5 to 2.0 and recieved a similar error, and have no idea where to start, yet am familiar with some aspects of coding. If anyone know the link to the solution can they please append it to this thread.
tdprado wrote:
Cue4cheap wrote:Folks... please do a search on this issue in the forum... it has been answered a few times. You need to add a definition for that port in your config files....

Mike
For us beginner users, that means very little.

Wouldn't it of been easier to just insert a link to one of the posts!

The upgrade to 2.1.0.1 should have been straight forward, not just for the seasoned programmer.

I can't understand why the Opencart team hasn't provided an update as yet to make the upgrade an easier process for ALL their users.

Steve

New member

Posts

Joined
Sun Sep 25, 2011 4:51 pm

Post by 4andilyn » Tue Nov 17, 2015 3:00 am

I'm not an idiot! The first thing I did was a search for possible solutions. I tried every one of the suggestions and still nothing works.

Newbie

Posts

Joined
Thu Apr 16, 2015 7:24 pm

Post by Bassi » Thu Nov 19, 2015 4:55 am

You may want to try http://goo.gl/R8PIAT which is a fix after the upgrade breaks.

You can also check the thread at Github.https://github.com/opencart/opencart/issues/3424

This thread reported that the upgrade was broken on October 6th.

Regards
Bassi

Newbie

Posts

Joined
Thu Dec 16, 2010 5:04 am
Who is online

Users browsing this forum: No registered users and 5 guests