Post by oz457 » Thu Oct 22, 2015 4:07 am

Dear all,

I have upgraded my website from 1.5.6.4 to 2.O.1.3 successfully. Everything works, but one thing!

I can't change any order status when going in admin to home/orders/history. I'm totally lost, so I have no clue.
Is there anyone who has seen this error:
-----start of quote--->
SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

OK

<b>Notice</b>: Undefined variable: json in <b>/export/websites/le-parfumeur/shop/admin/controller/sale/order.php</b> on line <b>2221</b>

<-----end of quote----
Deleting an order does not work either, but I don't see any error messages. Same error occurs when editing an order.

I try to figure out what variable is not defined, but it leaves me no clue. I have tried the api trick, does not work either.
If you have any answers, maybe let me know how to debug this error. How to find which variable is missing...


Thanks for any help.

New member

Posts

Joined
Wed Oct 28, 2009 5:33 am

Post by giproc » Thu Oct 22, 2015 7:20 am

Same for me.

Tried everything suggested from numerous threads. No luck.

I suspect it's the host blocking cURL loopbacks, but that hasn't been confirmed. Surely OC can release a patch so that those of us who don't want to upgrade to 2.1 at this time can complete the implementation of our sites.

New member

Posts

Joined
Sat Aug 29, 2015 9:24 pm

Post by oz457 » Thu Oct 22, 2015 7:58 am

Upgrading to 2.1.0.1 is not an option as there are too many errors when upgrading. The upgrade scripts are not yet working well. I prefer to stick to 2.0.x.x until the upgrade scripts are working well.
But now 2.0.x.x is also not working due to the above error, I'm still with an operational version of 1.5.6.4. As long the test environment is not working, I'm stuck with the upgrade.

New member

Posts

Joined
Wed Oct 28, 2009 5:33 am

Post by oz457 » Thu Oct 22, 2015 9:43 pm

Issue solved,

Curl got deleted for some reasons from the apache server.

a
sudo apt-get install php5-curl
and
sudo /etc/init.d/apache2 restart

did the trick. Hope this will be of any help for other people.

New member

Posts

Joined
Wed Oct 28, 2009 5:33 am

Post by giproc » Thu Oct 22, 2015 11:02 pm

Not for us I'm afraid. cURL is running.

New member

Posts

Joined
Sat Aug 29, 2015 9:24 pm

Post by giproc » Wed Oct 28, 2015 8:03 pm

Strange twist.

On the default store the orders can be edited fine.

On secondary stores in mulit-store environments we get his error when trying to edit. Same thing happening on two separate installs.

ANy suggestiong GREATLY appreciated since we are paralyzed until we find a solution.

New member

Posts

Joined
Sat Aug 29, 2015 9:24 pm
Who is online

Users browsing this forum: No registered users and 19 guests