Post by HelenH » Thu Sep 03, 2015 7:54 pm

Paypal have asked me to do the following update:-

"We are contacting you regarding a change that you are required to make by 30th August 2015.

PayPal has detected that you have hard coded the following Pro Hosted Solution URL in your code:
https://www.paypal.com/cgi-bin/webscr?c ... ed-payment

PayPal does not recommend hard coding. Instead, you should read the URL from the button creation API response.

If you must hard code this URL, you need to update it to the following: https://securepayments.paypal.com/webap ... ionProcess

Important: you must either read the URL from the button creation API response or update your hard code URL by no later than 30 August 2015. Otherwise, your existing hard coded Pro Hosted Solution URL will not be supported after that date. "

I set up the opencart website myself and I'm not a web designer so not sure what to do? I run Paypal pro and have Paypal Express Checkout and PayPal Website Payment Pro iFrame enabled/working as the Opencart payment options. I think the issue is potentially with the Express Checkout Button. Working fine to date. Is there a simple solution to this?

Helen

Newbie

Posts

Joined
Sat Jan 17, 2015 8:46 pm

Post by HelenH » Thu Sep 03, 2015 7:56 pm


Newbie

Posts

Joined
Sat Jan 17, 2015 8:46 pm

Post by HelenH » Thu Sep 03, 2015 11:22 pm

Looks like everyone using Opencart 1.5 with Paypal Pro could be affected. See correspondence with Paypal below:-

Hello Helen,

Anyone using HSS with Opencart version 1.5 will encounter the same problem.

From my understanding, the Express Checkout is running through the iframe with the credit card option, so both will be effected.

Sincerely,
Erin
Merchant Technical Support
PayPal

Customer By Email (Helen Holterman) 09/03/2015 08:10 AM
Ok so does that mean that everyone using opencart (mine is version 1.5) has the same problem? I have raised the query on the opencart community. I'm using PayPal pro with iframe (for credit/debit cards) and also PayPal express. Does the problem potentially effect both payment methods?

Helen


Response Via Email (Erin) 09/03/2015 07:58 AM
Hello Helen,

The issue is with how the Opencart module was created. It is currently setup with an outdated URL. This is something that Opencart or the Opencart community would need to address. PayPal does make changes to our integrations over time to provide better service and improve security. If a cart hard codes specific details, this could break the integration in the future. If you were not using HSS previously, the change to this payment integration is why this issue has arisen. If you were using just Express Checkout, the redirect URL for buyers is different and you do not get it from an API call.

Sincerely,
Erin
Merchant Technical Support
PayPal

Newbie

Posts

Joined
Sat Jan 17, 2015 8:46 pm

User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 44 guests