Post by gibby » Sat Aug 15, 2015 4:58 pm

HI, Im running 1.5.6.
All was well until a day ago and then we noticed the backend/admin was painfully slow.

We thought at first it was something to do with our hosts/dedicated server. The hosting co have checked it over to find no issues although we had the same issues from 3 seperate connections.
It is so slow we can't edit or add products, amend orders etc.

The front end seems to be ok and orders are coming in. As soon as we login to the admin both the front end and admin become hopeless for us
We need to resolve this fast. Has anyone any ideas where to start?

Ta.
G

New member

Posts

Joined
Mon Jul 08, 2013 3:27 am

Post by IP_CAM » Sun Aug 16, 2015 1:23 am

1. check your server error log files.
2. remove all shop/vqmod/vqcache/ content on your server, by use of an FTP Client.
3. remove all shop/system/cache/ content, as well as all shop/system/cache/Subfolders Content.
4. remove ALL Cached images in your shop/image/cache/ Folder and it's Subfolders.
5. In Admin DB Backup/Restore , OPTIMIZE your MySql DB, if your Admin works afterwards well again.
6. Then, come back and report, what possible problems you have, and find, after clicking yourselfs trough a few Shop Sections, and create a few sample orders, to find out, if your Admin VqMod Manager display's some error messages, or then the Admin System Error Console.

Good Luck
Ernie
hitline.info/shop/

Please don't send Personal OC Forum Messages, contact: jti@jacob.ch
---
Test Site: http://www.bigmax.ch/shop/
Github OC Downloads: https://github.com/IP-CAM
2'250+ FREE OC Extensions from the World's largest Github OC Repository Archive.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by gibby » Sun Aug 16, 2015 3:03 am

Hi Ernie, many thanks for your help

Ive got the nitro page cache mod and cleared all of those, plus I have tried taking the mod out with no benefits.
Ive optimsied the DB too,

To do these tasks by FTP, do I just delete the info in the files?

Ta

G
IP_CAM wrote:1. check your server error log files.
2. remove all shop/vqmod/vqcache/ content on your server, by use of an FTP Client.
3. remove all shop/system/cache/ content, as well as all shop/system/cache/Subfolders Content.
4. remove ALL Cached images in your shop/image/cache/ Folder and it's Subfolders.
5. In Admin DB Backup/Restore , OPTIMIZE your MySql DB, if your Admin works afterwards well again.
6. Then, come back and report, what possible problems you have, and find, after clicking yourselfs trough a few Shop Sections, and create a few sample orders, to find out, if your Admin VqMod Manager display's some error messages, or then the Admin System Error Console.

Good Luck
Ernie
hitline.info/shop/

New member

Posts

Joined
Mon Jul 08, 2013 3:27 am

Post by IP_CAM » Sun Aug 16, 2015 3:33 am

remove ALL files, within the /vqcache/and /cache/ subsections, everything!
JUST LEAVE any (empty) subdirectories, placed inside such folders. It you use some
pagechache Mod, you will possibly have uncounted such subsections, each one
full of files, they would be placed in a Common Sub, then, you could remove everything
inside such a common Sub, including their directories.
Ernie

Please don't send Personal OC Forum Messages, contact: jti@jacob.ch
---
Test Site: http://www.bigmax.ch/shop/
Github OC Downloads: https://github.com/IP-CAM
2'250+ FREE OC Extensions from the World's largest Github OC Repository Archive.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by gibby » Mon Aug 17, 2015 12:30 am

Thanks. Ive done all of that.
The front end seems faster but the admin side is still very slow.

G

New member

Posts

Joined
Mon Jul 08, 2013 3:27 am

Post by IP_CAM » Mon Aug 17, 2015 2:21 am

what about server error logs ? Or, why not just open a new ADMIN DEMO Account, with READ ONLY Access, to check on?
At least, if you have a File/Code Editor installed, and possibly a MySql-DB Tool, to enable one, to have a look...? Everything else is plain guessing...
Ernie

Please don't send Personal OC Forum Messages, contact: jti@jacob.ch
---
Test Site: http://www.bigmax.ch/shop/
Github OC Downloads: https://github.com/IP-CAM
2'250+ FREE OC Extensions from the World's largest Github OC Repository Archive.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by gibby » Thu Aug 20, 2015 12:48 am

Thanks
We are getting some errors although the hosting co don't think they are the issue with the speed.
I have attached it just incase you can find anything there.

G

New member

Posts

Joined
Mon Jul 08, 2013 3:27 am

Post by IP_CAM » Thu Aug 20, 2015 4:32 am

No wonder, or, better, I wonder, that your Shop still works! :-\ :o
You have many problems, all overall, created by some
Undefined variables
Undefined indexes
related with some listings, and Value's, to be
'handled/used' in/by different Files, such as:

Code: Select all

model/account/customer.php
/controller/product/search.php
/sale/order/info.tpl
/quickcheckout/payment/address.php
/controller/module/category/accordion.php
/template/common/header.tp
/points/transactions/list.tpl
e.t.c.
due to some setup, and/or possibly Mod's, like cat-accordion ,
and Quick-Checkout, as I see from some error lines,
Probably additional Values, not correctly defined/declared....,
someone would have to find out first, why it hurts, to find out, where to fix.

Sorry, you'll probably have to get a Pro, to get on your Site.
Good Luck
Ernie

Please don't send Personal OC Forum Messages, contact: jti@jacob.ch
---
Test Site: http://www.bigmax.ch/shop/
Github OC Downloads: https://github.com/IP-CAM
2'250+ FREE OC Extensions from the World's largest Github OC Repository Archive.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by gibby » Thu Aug 20, 2015 6:24 am

Thanks. Can you suggest anyone?

Ta
G

New member

Posts

Joined
Mon Jul 08, 2013 3:27 am
Who is online

Users browsing this forum: No registered users and 23 guests