Post by agah » Thu Jul 23, 2015 6:30 pm

Hi,

There are topics about this subject but they are old and they don't work on 2.x version. How can I put Information Pages to main menu like other categories? I prefer codes instead of extensions. Could someone help me about this?

Thanks.

Newbie

Posts

Joined
Sat Jun 20, 2015 8:16 pm

Post by viethemes » Thu Jul 23, 2015 9:21 pm

You can open file catalog/view/theme/default/common/header.tpl
find

Code: Select all

<ul class="nav navbar-nav">
and add links

Code: Select all

<li><a href="{page_link}">{page_name}</a></li>
Note that: Change {page_link} and {page_name} to yours.

http://www.viethemes.com - OpenCart turtorials, news, tips and stricks, extension

Our extensions:
Visual Theme Editor - Powerful tool for customizing style of any theme visually
Live Theme Editor - Customize layout, colors, backgrounds, fonts of the default theme
Theme Animation - Animation Editor for any theme

Extra Positions PRO, Custom JavaScript, Custom CSS and others


User avatar
Active Member

Posts

Joined
Thu Jan 08, 2015 12:17 pm


Post by agah » Fri Jul 24, 2015 12:09 am

viethemes wrote:You can open file catalog/view/theme/default/common/header.tpl
find

Code: Select all

<ul class="nav navbar-nav">
and add links

Code: Select all

<li><a href="{page_link}">{page_name}</a></li>
Note that: Change {page_link} and {page_name} to yours.
Thanks a lot! This is an excellent solution. It works perfectly, but there is just one problem. When I change the language of the site, {page-name} doesn't translate to that other language. Main language is Turkish, I wrote İLETİŞİM for the {page-name} place. (İLETİŞİM means CONTACT US) When I make the language English, it should be CONTACT US but it stays still İLETİŞİM. Is there a php code or something for this?

Edit: Also when I add this <li> tags, they don't appear on mobile theme :( Because they're not considered as a category.

Newbie

Posts

Joined
Sat Jun 20, 2015 8:16 pm

Post by InfiniteDezigns » Wed Oct 21, 2015 1:54 am

Now this solution appears not to be working now in OC 2.0.3.1. SMH. Any other ways or solutions?

New member

Posts

Joined
Mon Jun 21, 2010 5:18 am
Who is online

Users browsing this forum: No registered users and 48 guests