Post by dpit » Tue Apr 21, 2015 4:50 am

Evenin' open cart'ers. I seem to be stuck and wondering if someone can help please...

My store's category URLs all redirect to include index.php?_route_=

The product pages are working how I'd like. (They do not redirect to include index.php?_route_=)

Is there a way to fix the category URLs to not redirect and show index.php?_route_=? (I've played with .htaccess and seo_url.php a little so far with no joy.)

Newbie

Posts

Joined
Sun Apr 08, 2012 12:58 am

Post by labeshops » Tue Apr 21, 2015 5:04 am

If seo urls are working on product pages, they should be working on category pages as well. Did you give the categories a unique seo url?

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member
Online

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by dpit » Tue Apr 21, 2015 5:16 am

Thanks for the quick reply.

Yes the category has that specified and it is what follows the index.php?_route_...

Newbie

Posts

Joined
Sun Apr 08, 2012 12:58 am

Post by xlam » Sat May 16, 2015 2:00 am

I have same problem too....on product page seo is working. Problem on top category link.
Standart url :
http://pakaiankorea.co.id/index.php?rou ... ry&path=66 on my top category my website always show like this.
Seo url is http://pakaiankorea.co.id/baju-pria if i try open this seo page is working

Before this i use oc 1.5.5.1 then i try upgrade to 1.5.6.4 problem still same. I try switch with another theme but not luck

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by EvolveWebHosting » Sat May 16, 2015 2:32 am

I've only seen this happen when the .htaccess file is altered. You can comment out one line at a time in the RewriteBase section or paste the contents of the file here.

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by xlam » Sat May 16, 2015 12:45 pm

EvolveWebHosting wrote:I've only seen this happen when the .htaccess file is altered. You can comment out one line at a time in the RewriteBase section or paste the contents of the file here.
Thanks for your reply.....before this i change with .htaccess with new file from opencart default but not luck.

here my htaccess

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled. 

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing 
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

RewriteCond %{QUERY_STRING} ^route=common/home$
RewriteCond %{REQUEST_METHOD} !^POST$
RewriteRule ^index\.php$ http://pakaiankorea.co.id? [R=301,L]
RewriteRule ^daftar*$ http://pakaiankorea.co.id/index.php?route=account/register [R=301,L]
RewriteCond %{HTTP_HOST} ^www\.pakaiankorea\.co.id [NC]
RewriteRule ^(.*)$ http://pakaiankorea.co.id/$1 [L,R=301]


### Additional Settings that may need to be enabled for some servers 
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by labeshops » Sat May 16, 2015 7:27 pm

Pretty sure that isn't the default htaccess that came with opencart. I would rename the one you have and reupload the default one and see it works.

You are including the route path in the one you posted which is probably what is causing the problem.

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member
Online

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by EvolveWebHosting » Sat May 16, 2015 10:16 pm

This is your problem and Labeshops is right, it's not the default Opencart .htaccess file.

RewriteCond %{QUERY_STRING} ^route=common/home$
RewriteCond %{REQUEST_METHOD} !^POST$
RewriteRule ^index\.php$ http://pakaiankorea.co.id? [R=301,L]
RewriteRule ^daftar*$ http://pakaiankorea.co.id/index.php?rou ... t/register [R=301,L]
RewriteCond %{HTTP_HOST} ^www\.pakaiankorea\.co.id [NC]
RewriteRule ^(.*)$ http://pakaiankorea.co.id/$1 [L,R=301]

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by xlam » Fri May 22, 2015 11:40 am

EvolveWebHosting wrote:This is your problem and Labeshops is right, it's not the default Opencart .htaccess file.

RewriteCond %{QUERY_STRING} ^route=common/home$
RewriteCond %{REQUEST_METHOD} !^POST$
RewriteRule ^index\.php$ http://pakaiankorea.co.id? [R=301,L]
RewriteRule ^daftar*$ http://pakaiankorea.co.id/index.php?rou ... t/register [R=301,L]
RewriteCond %{HTTP_HOST} ^www\.pakaiankorea\.co.id [NC]
RewriteRule ^(.*)$ http://pakaiankorea.co.id/$1 [L,R=301]
I had change with new default opencart now...but still don't have ant effect. Any other solution sir?

Thanks

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by xlam » Fri May 22, 2015 11:55 am

SOLVED NOW! after upload file seo_url.php please check this http://forum.opencart.com/viewtopic.php?f=20&t=38117

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm
Who is online

Users browsing this forum: No registered users and 45 guests