Post by virgotch » Thu Dec 11, 2014 4:50 pm

oc 2.0.1.1 is released but is it enough stable to use in online real stores ? or we can continue with 1..5.6.4 version ? i read many programmer posts and nobody belive and trust yet to 2.0 version to use in real online store because still bugs and isues

New member

Posts

Joined
Sun Oct 26, 2014 4:10 am

Post by RonLens » Thu Dec 11, 2014 4:59 pm

You're right. The frontend works pretty good but the backend has still some errors and issues (e.g. edit orders doesn't work).

Newbie

Posts

Joined
Wed Dec 10, 2014 3:37 am
Location - Germany

Post by pm-netti » Thu Dec 11, 2014 5:30 pm

RonLens wrote:(e.g. edit orders doesn't work).
That is not bug. It is to server feature, cURL is blocked:
http://forum.opencart.com/viewtopic.php ... 20#p531813

etc.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by RonLens » Thu Dec 11, 2014 5:51 pm

For sure? Why doesn't it work in the demostore from Opencart itself?

Newbie

Posts

Joined
Wed Dec 10, 2014 3:37 am
Location - Germany

Post by pm-netti » Thu Dec 11, 2014 6:05 pm

RonLens wrote:For sure? Why doesn't it work in the demostore from Opencart itself?
When these settings are correct:
http://forum.opencart.com/viewtopic.php ... 20#p531798

And $api_info is show, but $response is not show:
http://forum.opencart.com/viewtopic.php ... 20#p531632
cURL is bloced in server.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by RonLens » Thu Dec 11, 2014 6:23 pm

Damn, I deleted all the browser cookies and tried again the test output of $api_info and $response and what happened?
It works ... :D

Newbie

Posts

Joined
Wed Dec 10, 2014 3:37 am
Location - Germany

Post by virgotch » Thu Dec 11, 2014 6:47 pm

For sure? Why doesn't it work in the demostore from Opencart itself?
opencart demo store is still use Version 2.0.0.1b

New member

Posts

Joined
Sun Oct 26, 2014 4:10 am

Post by virgotch » Thu Dec 11, 2014 6:49 pm

i have 3 web site using 1.5.6.4 old sites and i still wait new update from template designers and other module sellers but when i talk with them everytime they still wait and say me continue to use 1.5.6.4 for the new sites and oc 2 version need long time to be stable without problems and every new release has more and more and for example now admin page load time is 3 times slow compare before and we again started our new web sites with 1.5.6.4

New member

Posts

Joined
Sun Oct 26, 2014 4:10 am

Post by JAY6390 » Thu Dec 11, 2014 9:15 pm

2.X is unlikely to be stable for a few months. You should not be using the bleeding edge version on any live store ever due to lack of testing

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by pm-netti » Thu Dec 11, 2014 9:34 pm

JAY6390 wrote:2.X is unlikely to be stable for a few months. You should not be using the bleeding edge version on any live store ever due to lack of testing
I think this is already pretty good. This change should still be made:
http://forum.opencart.com/viewtopic.php ... 40#p532054

And write even a small documentation.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by JAY6390 » Thu Dec 11, 2014 9:38 pm

A store being "pretty good" to me isn't justification for using it on a site where you are taking personal details of customers and handling their currency. To me, people should still use 1.5.5.1 or 1.5.6.4 for now. Using 2.0.1.1 is careless and could be potentially devastating for the store owner and its customers

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by virgotch » Thu Dec 11, 2014 9:47 pm

A store being "pretty good" to me isn't justification for using it on a site where you are taking personal details of customers and handling their currency. To me, people should still use 1.5.5.1 or 1.5.6.4 for now. Using 2.0.1.1 is careless and could be potentially devastating for the store owner and its customers
im %100 totaly agree with you , this version need long test and fix time yet before use in online marketing.

New member

Posts

Joined
Sun Oct 26, 2014 4:10 am

Post by pm-netti » Thu Dec 11, 2014 10:28 pm

JAY6390 wrote:Using 2.0.1.1 is careless and could be potentially devastating for the store owner and its customers
Eg. You could identify the problems?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by JAY6390 » Thu Dec 11, 2014 10:39 pm

Just take a look at all the bug reports coming in every day for 2.x - this in itself should be cause for concern. If you want to use it go ahead, but I would advise against it and would definitely not recommend it to others just yet

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by virgotch » Thu Dec 11, 2014 10:57 pm

Just take a look at all the bug reports coming in every day for 2.x - this in itself should be cause for concern. If you want to use it go ahead, but I would advise against it and would definitely not recommend it to others just yet
oc team dont accept any bug or isue report :) and when you report in github some problem they answer with rude bad words and close the isue , sure this is opensource and free project and we cant complain to much about it and if some problems need to find developer but if want to go ahead thhis project need to care every even very small isue or bug report.

New member

Posts

Joined
Sun Oct 26, 2014 4:10 am
Who is online

Users browsing this forum: No registered users and 14 guests