Post by jfer3 » Thu Nov 13, 2014 11:33 am

Hi all hoping someone can help me with my problem here.

When i go to sales > orders

and try to click the delete trash can button i get this error:

"SyntaxError: Unexpected end of input
OK"

I also get the error when i try to read an order, which is also very strange. The order opens up fine, when i click one of the tabs in the order i get the error.

The website is running in a sub domain, all credentials , API User etc have been assigned correctly. Any idea as to what could be going wrong here ?

thank you for your help in advance....

:'(

Web designer at http://www.3rddesign.com. Specializing in Joomla and creative marketing.


New member

Posts

Joined
Tue Mar 05, 2013 2:59 pm

Post by jfer3 » Thu Nov 13, 2014 12:53 pm

also wanted to add that this is only happening on the sales > order page.

i also get an error:

Warning: CURL error Couldn't resolve host 'HTTPS_CATALOGindex.php'(6)!

when clicking the delete button.

Web designer at http://www.3rddesign.com. Specializing in Joomla and creative marketing.


New member

Posts

Joined
Tue Mar 05, 2013 2:59 pm

Post by Nesster » Thu Nov 13, 2014 9:57 pm

You seem to have the same problem I had, your server lacks dns entries. See my post about fixing it.

For completeness:
http://forum.opencart.com/viewtopic.php?f=181&t=132699

Newbie

Posts

Joined
Tue Oct 21, 2014 8:09 am

Post by mattd4 » Fri Mar 06, 2015 12:57 pm

Hi everyone,

I am having this exact issue on a new OC installs. "SyntaxError: Unexpected end of input OK" when updating order details from the admin area. I have followed all advise I can find without any success, does anyone have more ideas?

My versions are 2.0.1.1 and is hosted on hostgeek.com.au which runs cPanel. I have another OC 2.0.1.1 install that is working fine, but that one is installed on a Windows Azure VM.

I have check API settings both in the OC admin settings and also directly in the database tables.
I have disabled ModSecurty in cPanel
I have removed directory password protection (I had the directory protected while building the site).

Any suggestions would be greatly appreciated. Thanks in advance!

Matt

Newbie

Posts

Joined
Fri Mar 06, 2015 12:45 pm

Post by chilledworld » Fri Mar 13, 2015 2:47 am

I am having the same problem.
I cannot change the order status or edit orders in any way.
Any suggestions would be greatly appreciated.

Newbie

Posts

Joined
Mon Jan 31, 2011 4:29 am

Post by BrandonBerner » Wed Jul 15, 2015 7:12 pm

BUMP!

Im having the same problem!

When i change an order and click the "Add History" button i receive the "SyntaxError: Unexpected end of input OK".

Now my solution might be different due to the following:

Today i renamed my OC directory, to OC2 for example. I then installed a fresh OC 2.0.3.1 into OC Directory. Then Backed up my MySQL, Connected the New Install to a New MySQL Database, copied the old MySQL to the new install. Lots of my product pictures...but not all were missing (directory problem).

This caught my attention as "mattd4" said something about Databases. Does OpenCart use more than 1 Database?

Active Member

Posts

Joined
Sat Dec 15, 2012 4:49 am

User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 11 guests